aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 13:41:24 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-19 08:54:56 +0100
commit5049a1fcc45c60067f5d96704bda851c234f2812 (patch)
tree676afa9dbb7d26254892016cf497d60cb860c719 /recipes
parent81f27f67f470231fce4e79e2be01e22b44a5b873 (diff)
downloadopenembedded-5049a1fcc45c60067f5d96704bda851c234f2812.tar.gz
wbxml2: add version 0.10.7 from SHR
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/opensync/wbxml2_0.10.7.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/opensync/wbxml2_0.10.7.bb b/recipes/opensync/wbxml2_0.10.7.bb
new file mode 100644
index 0000000000..77d819a423
--- /dev/null
+++ b/recipes/opensync/wbxml2_0.10.7.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "WBXML parsing and encoding library."
+HOMEPAGE = "http://libwbxml.opensync.org/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libwbxml/libwbxml-${PV}.tar.gz \
+ "
+
+S = "${WORKDIR}/libwbxml-${PV}"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE += " . -B${WORKDIR}/build "
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}"
+FILES_${PN} = "${libdir}/*.so.*"
+
+do_build_prepend() {
+ cd ${WORKDIR}/build
+}
+
+do_install_prepend() {
+ cd ${WORKDIR}/build
+}