aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-27 19:19:28 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-27 19:19:28 +0200
commit38d4c8a1b4074698351cb3aa37f4912d36bbdd46 (patch)
treefb3f177551969d374ca9b61907ea2dca74cad30c /recipes
parenta6349cc0bd9ea07274bb7a02dd44b2172ca2306a (diff)
downloadopenembedded-38d4c8a1b4074698351cb3aa37f4912d36bbdd46.tar.gz
linux-omap-psp 2.6.32: update patchset to fix mpurate passing and scary udev errors
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/0044-ARM-OMAP-modify-mpurate-logic-to-accept-anything-upt.patch25
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/0045-MTD-silence-ecc-errors-on-mtdblock0.patch59
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb2
3 files changed, 86 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-psp-2.6.32/0044-ARM-OMAP-modify-mpurate-logic-to-accept-anything-upt.patch b/recipes/linux/linux-omap-psp-2.6.32/0044-ARM-OMAP-modify-mpurate-logic-to-accept-anything-upt.patch
new file mode 100644
index 0000000000..36effaf37a
--- /dev/null
+++ b/recipes/linux/linux-omap-psp-2.6.32/0044-ARM-OMAP-modify-mpurate-logic-to-accept-anything-upt.patch
@@ -0,0 +1,25 @@
+From a15dcc1ce77bd298dd472458e0cc836b9b4484c4 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Tue, 20 Apr 2010 20:59:27 +0200
+Subject: [PATCH 44/46] ARM: OMAP: modify mpurate logic to accept anything upto 4GHz, instead of the previous 999MHz
+
+---
+ arch/arm/plat-omap/clock.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/arch/arm/plat-omap/clock.c b/arch/arm/plat-omap/clock.c
+index 89cafc9..42788ab 100644
+--- a/arch/arm/plat-omap/clock.c
++++ b/arch/arm/plat-omap/clock.c
+@@ -190,7 +190,7 @@ static int __init omap_clk_setup(char *str)
+ if (!mpurate)
+ return 1;
+
+- if (mpurate < 1000)
++ if (mpurate < 4000)
+ mpurate *= 1000000;
+
+ return 1;
+--
+1.6.6.1
+
diff --git a/recipes/linux/linux-omap-psp-2.6.32/0045-MTD-silence-ecc-errors-on-mtdblock0.patch b/recipes/linux/linux-omap-psp-2.6.32/0045-MTD-silence-ecc-errors-on-mtdblock0.patch
new file mode 100644
index 0000000000..7a57eebb9c
--- /dev/null
+++ b/recipes/linux/linux-omap-psp-2.6.32/0045-MTD-silence-ecc-errors-on-mtdblock0.patch
@@ -0,0 +1,59 @@
+From dedd8e25de8fcf93aee1f95c32b2f2f56020bf57 Mon Sep 17 00:00:00 2001
+From: Steve Sakoman <steve@sakoman.com>
+Date: Mon, 26 Apr 2010 11:17:26 -0700
+Subject: [PATCH 45/46] MTD: silence ecc errors on mtdblock0
+
+mtdblock0 is the x-load partition, which uses hw ecc
+this confuses linux, which uses sw ecc
+this patch silences ecc error messages when linux peeks into mtdblock0
+* not for upstream submission *
+---
+ block/blk-core.c | 3 ++-
+ drivers/mtd/nand/nand_ecc.c | 2 +-
+ fs/buffer.c | 3 ++-
+ 3 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/block/blk-core.c b/block/blk-core.c
+index 718897e..c526fde 100644
+--- a/block/blk-core.c
++++ b/block/blk-core.c
+@@ -1970,7 +1970,8 @@ bool blk_update_request(struct request *req, int error, unsigned int nr_bytes)
+ req->errors = 0;
+
+ if (error && (blk_fs_request(req) && !(req->cmd_flags & REQ_QUIET))) {
+- printk(KERN_ERR "end_request: I/O error, dev %s, sector %llu\n",
++ if (req->rq_disk && (strcmp(req->rq_disk->disk_name, "mtdblock0") != 0))
++ printk(KERN_ERR "end_request: I/O error, dev %s, sector %llu\n",
+ req->rq_disk ? req->rq_disk->disk_name : "?",
+ (unsigned long long)blk_rq_pos(req));
+ }
+diff --git a/drivers/mtd/nand/nand_ecc.c b/drivers/mtd/nand/nand_ecc.c
+index 92320a6..2b86b6d 100644
+--- a/drivers/mtd/nand/nand_ecc.c
++++ b/drivers/mtd/nand/nand_ecc.c
+@@ -492,7 +492,7 @@ int __nand_correct_data(unsigned char *buf,
+ if ((bitsperbyte[b0] + bitsperbyte[b1] + bitsperbyte[b2]) == 1)
+ return 1; /* error in ecc data; no action needed */
+
+- printk(KERN_ERR "uncorrectable error : ");
++// printk(KERN_ERR "uncorrectable error : ");
+ return -1;
+ }
+ EXPORT_SYMBOL(__nand_correct_data);
+diff --git a/fs/buffer.c b/fs/buffer.c
+index 6fa5302..27b3103 100644
+--- a/fs/buffer.c
++++ b/fs/buffer.c
+@@ -114,7 +114,8 @@ static int quiet_error(struct buffer_head *bh)
+ static void buffer_io_error(struct buffer_head *bh)
+ {
+ char b[BDEVNAME_SIZE];
+- printk(KERN_ERR "Buffer I/O error on device %s, logical block %Lu\n",
++ if (strcmp(bdevname(bh->b_bdev, b), "mtdblock0") != 0)
++ printk(KERN_ERR "Buffer I/O error on device %s, logical block %Lu\n",
+ bdevname(bh->b_bdev, b),
+ (unsigned long long)bh->b_blocknr);
+ }
+--
+1.6.6.1
+
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index e9a699b0c2..458233ad47 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -55,6 +55,8 @@ SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=gi
file://0041-ARM-Expose-some-PMON-registers-through-sysfs.patch;patch=1 \
file://0042-musb-allow-host-io-without-gadget-module.patch;patch=1 \
file://0043-ARM-OMAP-Change-DSP-rate-table-for-36xx-37xx.patch;patch=1 \
+ file://0044-ARM-OMAP-modify-mpurate-logic-to-accept-anything-upt.patch;patch=1 \
+ file://0045-MTD-silence-ecc-errors-on-mtdblock0.patch;patch=1 \
file://defconfig"
SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \