aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-02-26 18:26:15 +0100
committerSimon Busch <morphis@gravedo.de>2011-02-27 13:58:22 +0100
commit2f7832b2465efe5bc9bf3bd7d31a52773ba05b5f (patch)
tree126601b3cd849251a19789d5799f3d3f91fd3d9c /recipes
parent3eda2bfe44698b3abb64e5f81ecfad5bad1bc990 (diff)
downloadopenembedded-2f7832b2465efe5bc9bf3bd7d31a52773ba05b5f.tar.gz
libphone-ui: refactor recipe to make it possible to use machine specific configs
Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/shr/libphone-ui/libphoneui.conf82
-rw-r--r--recipes/shr/libphone-ui_git.bb27
2 files changed, 104 insertions, 5 deletions
diff --git a/recipes/shr/libphone-ui/libphoneui.conf b/recipes/shr/libphone-ui/libphoneui.conf
new file mode 100644
index 0000000000..ae7005413e
--- /dev/null
+++ b/recipes/shr/libphone-ui/libphoneui.conf
@@ -0,0 +1,82 @@
+# The following sections are "view" specific settings
+# every view must have a "module" field that specifies the name of the
+# module that should be used for that view, and additional view specific
+# settings if supported by that view.
+[dialer]
+module = shr
+
+[messages]
+module = shr
+request_message_receipt = 0
+
+[contacts]
+module = shr
+
+[calls]
+module = shr
+
+[phonelog]
+module = shr
+
+[notification]
+module = shr
+
+[idle_screen]
+module = shr
+
+[settings]
+module = shr
+
+#Alsa configuration for the sound utility functions
+# The general alsa section
+[alsa]
+hardware_control_name = hw:0
+
+#Each section describs a sound state
+#each section can accept the following fields:
+#speaker: the name of the corrosponding alsa control
+#microphone: the name of the corrosponding alsa control
+#speaker_min: the wanted lower bound to allow setting this control to
+#speaker_max: the wanted upper bound to allow setting this control to
+#microphone_min: the wanted lower bound to allow setting this control to
+#microphone_max: the wanted upper bound to allow setting this control to
+
+[alsa_control_idle]
+#speaker = PCM Volume
+
+[alsa_control_speaker]
+speaker = Headphone Playback Volume
+microphone = Mono Playback Volume
+microphone_mute = Mono Mixer Sidetone Playback Switch
+
+[alsa_control_handset]
+speaker = Speaker Playback Volume
+speaker_min = 90
+microphone = Mono Playback Volume
+microphone_mute = Mono Mixer Sidetone Playback Switch
+
+[alsa_control_headset]
+speaker = Headphone Playback Volume
+microphone = Mono Playback Volume
+microphone_mute = Mono Mixer Sidetone Playback Switch
+
+[alsa_control_bluetooth]
+speaker = Speaker Playback Volume
+microphone = Mono Playback Volume
+
+#Remove the segfaulting stuff
+#[device]
+# sysfs node for the vibrator to use
+#vibrator = /sys/class/leds/neo1973:vibrator/brightness
+# sysfs node to set the backlight brightness
+#backlight = /sys/class/backlight/gta02-bl
+
+
+#[feedback_error]
+
+#[feedback_warning]
+
+#[feedback_notice]
+
+#[feedback_click]
+
diff --git a/recipes/shr/libphone-ui_git.bb b/recipes/shr/libphone-ui_git.bb
index c002ea1716..b6500201e7 100644
--- a/recipes/shr/libphone-ui_git.bb
+++ b/recipes/shr/libphone-ui_git.bb
@@ -4,14 +4,31 @@ LICENSE = "GPL"
SECTION = "libs"
SRCREV = "4ad47c4db9ad766ad2b38ffc3bd181a85575fd75"
PV = "0.0.1+gitr${SRCPV}"
-PR = "r0"
+PR = "r1"
DEPENDS="glib-2.0 libshr-glib libfso-glib libfsoframework libphone-utils alsa-lib"
-inherit pkgconfig autotools autotools
+SRC_URI = " \
+ git://git.shr-project.org/repo/libphone-ui.git;protocol=http;branch=master \
+ file://libphoneui.conf \
+"
-SRC_URI = "git://git.shr-project.org/repo/libphone-ui.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
-S="${WORKDIR}/git"
+inherit autotools pkgconfig
-CONFFILES_${PN} = "${sysconfdir}/libphoneui.conf"
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/libphoneui.conf ${D}${sysconfdir}/libphoneui.conf
+}
+
+PACKAGES =+ "${PN}-config"
+PACKAGE_ARCH_${PN}-config = "${MACHINE_ARCH}"
+
+FILES_${PN}-config = " \
+ ${sysconfdir}/libphoneui.conf \
+"
+
+CONFFILES_${PN}-config = "\
+ ${sysconfdir}/libphoneui.conf \
+"