aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorThomas Zimmermann <zimmermann@vdm-design.de>2009-10-16 21:24:02 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-19 09:14:31 +0100
commit26bb9d71306bb1011cdeb50e3911970828a35cd8 (patch)
tree613eb0b42bd47c6b3f22420f45dfc0d865612f8c /recipes
parent64931fdf4e2c29ab6b9a9ad520148bed6ef8cb24 (diff)
downloadopenembedded-26bb9d71306bb1011cdeb50e3911970828a35cd8.tar.gz
shr/merge: mplayer: fix ivtv build problem
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/mplayer/mplayer-0.0+1.0rc2/ivtv-fix.patch26
-rw-r--r--recipes/mplayer/mplayer_0.0+1.0rc2.bb5
2 files changed, 29 insertions, 2 deletions
diff --git a/recipes/mplayer/mplayer-0.0+1.0rc2/ivtv-fix.patch b/recipes/mplayer/mplayer-0.0+1.0rc2/ivtv-fix.patch
new file mode 100644
index 0000000000..25635bc5c6
--- /dev/null
+++ b/recipes/mplayer/mplayer-0.0+1.0rc2/ivtv-fix.patch
@@ -0,0 +1,26 @@
+--- MPlayer-1.0rc2/configure~ 2009-10-17 00:08:35.000000000 +0200
++++ MPlayer-1.0rc2/configure 2009-10-17 00:08:35.000000000 +0200
+@@ -4965,7 +4965,7 @@
+ echores "$_dxr3"
+
+
+-echocheck "IVTV TV-Out"
++echocheck "IVTV TV-Out (pre linux-2.6.24)"
+ if test "$_ivtv" = auto ; then
+ cat > $TMPC << EOF
+ #include <stdlib.h>
+@@ -4973,7 +4973,13 @@
+ #include <linux/types.h>
+ #include <linux/videodev2.h>
+ #include <linux/ivtv.h>
+-int main(void) { return 0; }
++#include <sys/ioctl.h>
++int main(void) {
++struct ivtv_cfg_stop_decode sd;
++struct ivtv_cfg_start_decode sd1;
++ioctl (0, IVTV_IOC_START_DECODE, &sd1);
++ioctl (0, IVTV_IOC_STOP_DECODE, &sd);
++return 0; }
+ EOF
+ _ivtv=no
+ cc_check && _ivtv=yes
diff --git a/recipes/mplayer/mplayer_0.0+1.0rc2.bb b/recipes/mplayer/mplayer_0.0+1.0rc2.bb
index 481acce475..9a16dada8c 100644
--- a/recipes/mplayer/mplayer_0.0+1.0rc2.bb
+++ b/recipes/mplayer/mplayer_0.0+1.0rc2.bb
@@ -28,7 +28,8 @@ SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-1.0rc2.tar.bz2 \
file://imageon-video_out.patch;patch=1 \
file://pxa_configure.patch;patch=1 \
file://pxa-video_out.patch;patch=1 \
- file://motion-comp-pld.patch;patch=1 "
+ file://motion-comp-pld.patch;patch=1 \
+ file://ivtv-fix.patch;patch=1 "
# This is required for the collie machine only as all stacks in that
# machine seem to be set to executable by the toolchain. If someone
@@ -45,7 +46,7 @@ ARM_INSTRUCTION_SET = "ARM"
RCONFLICTS_${PN} = "mplayer-atty"
RREPLACES_${PN} = "mplayer-atty"
-PR = "r12"
+PR = "r13"
PARALLEL_MAKE = ""