aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zlapspeed
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/zlapspeed
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/zlapspeed')
-rw-r--r--recipes/zlapspeed/zlapspeed-1.0.0/qtopia17.patch25
-rw-r--r--recipes/zlapspeed/zlapspeed_1.0.0.bb19
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes/zlapspeed/zlapspeed-1.0.0/qtopia17.patch b/recipes/zlapspeed/zlapspeed-1.0.0/qtopia17.patch
new file mode 100644
index 0000000000..320ea5ee47
--- /dev/null
+++ b/recipes/zlapspeed/zlapspeed-1.0.0/qtopia17.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- zlaps-src/zlaps_main.cpp~qtopia17 2004-04-15 04:44:10.000000000 +0200
++++ zlaps-src/zlaps_main.cpp 2004-04-18 12:54:08.000000000 +0200
+@@ -1,5 +1,15 @@
+ #include "zlaps.h"
+ #include <qpe/qpeapplication.h>
+
+-QTOPIA_ADD_APPLICATION("zlaps", zlaps)
+-QTOPIA_MAIN
++//QTOPIA_ADD_APPLICATION("zlaps", zlaps)
++//QTOPIA_MAIN
++
++int main(int argc, char** argv)
++{
++ QPEApplication a( argc, argv );
++ zlaps* w = new zlaps();
++ a.showMainWidget( w );
++ a.exec();
++}
++
++
diff --git a/recipes/zlapspeed/zlapspeed_1.0.0.bb b/recipes/zlapspeed/zlapspeed_1.0.0.bb
new file mode 100644
index 0000000000..a419d9d2ab
--- /dev/null
+++ b/recipes/zlapspeed/zlapspeed_1.0.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Zaurus Race Lap Speed Measuring Application for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.cinlug.org/modules/Static_Docs/data/db/zlaps/zlaps_${PV}_arm.src.tar.gz \
+ file://qtopia17.patch;patch=1"
+S = "${WORKDIR}/zlaps-src"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'TMAKE_LIBS-="-luuid" TMAKE_LIBS+="-lqpe" CONFIG+=qt CONFIG-=qtopia'
+
+do_install() {
+ install -d ${D}${palmtopdir}/{bin,pics,apps/Applications}
+ install -m 0755 zlaps ${D}${palmtopdir}/bin/
+ install -m 0755 images/zlaps.png ${D}${palmtopdir}/pics/
+ install -m 0644 zlaps.desktop ${D}${palmtopdir}/apps/Applications/
+}