aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-xserver
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-05-30 17:18:15 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-05-30 23:45:44 +0200
commitcc0e53de68376fb1987e0a11cd977e481cd7d95d (patch)
tree01362fc6bad50a045928e0a93b972a7120bb688b /recipes/xorg-xserver
parent600ce4b48922a1f7d74652d85c71a13fedfc1086 (diff)
downloadopenembedded-cc0e53de68376fb1987e0a11cd977e481cd7d95d.tar.gz
xserver-xorg: upgrade from 1.10.1.902 to 1.10.2 and replace part of randr-support.patch with upstream patch
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-xserver')
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch61
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch (renamed from recipes/xorg-xserver/xserver-xorg-1.10.1.902/hack-assume-pixman-supports-overlapped-blt.patch)0
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch (renamed from recipes/xorg-xserver/xserver-xorg-1.10.1.902/hack-fbdev-ignore-return-mode.patch)0
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch (renamed from recipes/xorg-xserver/xserver-xorg-1.10.1.902/randr-support.patch)29
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.10.2.bb (renamed from recipes/xorg-xserver/xserver-xorg_1.10.1.902.bb)5
5 files changed, 64 insertions, 31 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch b/recipes/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch
new file mode 100644
index 0000000000..2c4078a001
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-1.10.2/50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch
@@ -0,0 +1,61 @@
+From 50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd Mon Sep 17 00:00:00 2001
+From: Aaron Plattner <aplattner@nvidia.com>
+Date: Tue, 24 May 2011 23:02:42 +0000
+Subject: randr: check rotated virtual size limits correctly
+
+Commit d1107918d4626268803b54033a07405122278e7f introduced checks to
+the RandR path that cause RRSetScreenConfig requests to fail if the
+size is too large. Unfortunately, when RandR 1.1 rotation is enabled
+it compares the rotated screen dimensions to the unrotated limits,
+which causes 90- and 270-degree rotation to fail unless your screen
+happens to be square:
+
+ X Error of failed request: BadValue (integer parameter out of range for operation)
+ Major opcode of failed request: 153 (RANDR)
+ Minor opcode of failed request: 2 (RRSetScreenConfig)
+ Value in failed request: 0x780
+ Serial number of failed request: 14
+ Current serial number in output stream: 14
+
+Fix this by moving the check above the code that swaps the dimensions
+based on the rotation.
+
+Signed-off-by: Aaron Plattner <aplattner@nvidia.com>
+Reviewed-by: Jeremy Huddleston <jeremyhu@apple.com>
+Tested-by: Robert Hooker <robert.hooker@canonical.com>
+Tested-by: Kent Baxley <kent.baxley@canonical.com>
+Signed-off-by: Keith Packard <keithp@keithp.com>
+(cherry picked from commit b6c7b9b2f39e970cedb6bc1e073f901e28cb0fa3)
+---
+diff --git a/randr/rrscreen.c b/randr/rrscreen.c
+index 1bc1a9e..da6d48d 100644
+--- a/randr/rrscreen.c
++++ b/randr/rrscreen.c
+@@ -910,12 +910,6 @@ ProcRRSetScreenConfig (ClientPtr client)
+ */
+ width = mode->mode.width;
+ height = mode->mode.height;
+- if (rotation & (RR_Rotate_90|RR_Rotate_270))
+- {
+- width = mode->mode.height;
+- height = mode->mode.width;
+- }
+-
+ if (width < pScrPriv->minWidth || pScrPriv->maxWidth < width) {
+ client->errorValue = width;
+ free(pData);
+@@ -927,6 +921,12 @@ ProcRRSetScreenConfig (ClientPtr client)
+ return BadValue;
+ }
+
++ if (rotation & (RR_Rotate_90|RR_Rotate_270))
++ {
++ width = mode->mode.height;
++ height = mode->mode.width;
++ }
++
+ if (width != pScreen->width || height != pScreen->height)
+ {
+ int c;
+--
+cgit v0.8.3-6-g21f6
diff --git a/recipes/xorg-xserver/xserver-xorg-1.10.1.902/hack-assume-pixman-supports-overlapped-blt.patch b/recipes/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch
index a947582f15..a947582f15 100644
--- a/recipes/xorg-xserver/xserver-xorg-1.10.1.902/hack-assume-pixman-supports-overlapped-blt.patch
+++ b/recipes/xorg-xserver/xserver-xorg-1.10.2/hack-assume-pixman-supports-overlapped-blt.patch
diff --git a/recipes/xorg-xserver/xserver-xorg-1.10.1.902/hack-fbdev-ignore-return-mode.patch b/recipes/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch
index d3661cbea2..d3661cbea2 100644
--- a/recipes/xorg-xserver/xserver-xorg-1.10.1.902/hack-fbdev-ignore-return-mode.patch
+++ b/recipes/xorg-xserver/xserver-xorg-1.10.2/hack-fbdev-ignore-return-mode.patch
diff --git a/recipes/xorg-xserver/xserver-xorg-1.10.1.902/randr-support.patch b/recipes/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch
index 258deb3eb4..632a64ce52 100644
--- a/recipes/xorg-xserver/xserver-xorg-1.10.1.902/randr-support.patch
+++ b/recipes/xorg-xserver/xserver-xorg-1.10.2/randr-support.patch
@@ -100,32 +100,3 @@ diff -ur xorg-server-1.10.1.901//hw/xfree86/modes/xf86Crtc.c git/xorg-server-1.1
return ret;
}
-diff -ur xorg-server-1.10.1.901//randr/rrscreen.c git/xorg-server-1.10.1.901//randr/rrscreen.c
---- xorg-server-1.10.1.901//randr/rrscreen.c 2011-02-25 04:27:32.000000000 +0100
-+++ git/xorg-server-1.10.1.901//randr/rrscreen.c 2011-05-18 23:19:39.007760004 +0200
-@@ -910,11 +910,6 @@
- */
- width = mode->mode.width;
- height = mode->mode.height;
-- if (rotation & (RR_Rotate_90|RR_Rotate_270))
-- {
-- width = mode->mode.height;
-- height = mode->mode.width;
-- }
-
- if (width < pScrPriv->minWidth || pScrPriv->maxWidth < width) {
- client->errorValue = width;
-@@ -926,7 +921,12 @@
- free(pData);
- return BadValue;
- }
--
-+ if (rotation & (RR_Rotate_90|RR_Rotate_270))
-+ {
-+ width = mode->mode.height;
-+ height = mode->mode.width;
-+ }
-+
- if (width != pScreen->width || height != pScreen->height)
- {
- int c;
diff --git a/recipes/xorg-xserver/xserver-xorg_1.10.1.902.bb b/recipes/xorg-xserver/xserver-xorg_1.10.2.bb
index 8c461df04e..95877c4b8f 100644
--- a/recipes/xorg-xserver/xserver-xorg_1.10.1.902.bb
+++ b/recipes/xorg-xserver/xserver-xorg_1.10.2.bb
@@ -12,12 +12,13 @@ DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_shr = "1"
SRC_URI += " \
+ file://50b9d3142ff90af2f7fa35b7b1bf9e5a07723dbd.patch \
file://randr-support.patch \
file://hack-fbdev-ignore-return-mode.patch \
file://hack-assume-pixman-supports-overlapped-blt.patch \
"
-SRC_URI[archive.md5sum] = "996d9e183ad1940f1cd802db2698b6e1"
-SRC_URI[archive.sha256sum] = "06d9d25cde3c943709adb24dc44426df58f4a8774a048e422ce9543c34e37dbc"
+SRC_URI[archive.md5sum] = "c9ba50bd44ea70da51f13100336a5484"
+SRC_URI[archive.sha256sum] = "65264f6640568b9db8d738aec1ddd036c3ae21b7ba05b98d006759d11a72792c"
do_install_prepend() {
mkdir -p ${D}/${libdir}/X11/fonts