aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-xserver
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-20 17:23:58 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-20 18:31:13 +0200
commitbd79cb8ef77d3731c810bdc553d93bcfc7d3dee8 (patch)
treee6d60bc72ffe0e6bb09bf42c020d5def208a4e67 /recipes/xorg-xserver
parent096ab4990ce8aaa12196ee10d8ad23a86063a289 (diff)
downloadopenembedded-bd79cb8ef77d3731c810bdc553d93bcfc7d3dee8.tar.gz
xserver-xorg_git: bump SRCREV
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-xserver')
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.9.99.1/hack-assume-pixman-supports-overlapped-blt.patch14
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.9.99.1/hack-fbdev-ignore-return-mode.patch39
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.9.99.1/randr-support.patch102
-rw-r--r--recipes/xorg-xserver/xserver-xorg_git.bb7
4 files changed, 158 insertions, 4 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg-1.9.99.1/hack-assume-pixman-supports-overlapped-blt.patch b/recipes/xorg-xserver/xserver-xorg-1.9.99.1/hack-assume-pixman-supports-overlapped-blt.patch
new file mode 100644
index 0000000000..a947582f15
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-1.9.99.1/hack-assume-pixman-supports-overlapped-blt.patch
@@ -0,0 +1,14 @@
+diff --git a/fb/fbcopy.c b/fb/fbcopy.c
+index 07eb663..ba394b7 100644
+--- a/fb/fbcopy.c
++++ b/fb/fbcopy.c
+@@ -91,8 +91,7 @@ fbCopyNtoN (DrawablePtr pSrcDrawable,
+ while (nbox--)
+ {
+ #ifndef FB_ACCESS_WRAPPER /* pixman_blt() doesn't support accessors yet */
+- if (pm == FB_ALLONES && alu == GXcopy && !reverse &&
+- !upsidedown)
++ if (pm == FB_ALLONES && alu == GXcopy)
+ {
+ if (!pixman_blt ((uint32_t *)src, (uint32_t *)dst, srcStride, dstStride, srcBpp, dstBpp,
+ (pbox->x1 + dx + srcXoff),
diff --git a/recipes/xorg-xserver/xserver-xorg-1.9.99.1/hack-fbdev-ignore-return-mode.patch b/recipes/xorg-xserver/xserver-xorg-1.9.99.1/hack-fbdev-ignore-return-mode.patch
new file mode 100644
index 0000000000..d3661cbea2
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-1.9.99.1/hack-fbdev-ignore-return-mode.patch
@@ -0,0 +1,39 @@
+Ugly hack that prevents server termination with xf86-video-fbdev-0.4.1
+(and probably other) while returning from chvt or resume on some
+hardware (e. g. zaurus).
+
+Correct fix would require debugging of fbdev mode during LeaveVT and
+EnterVT.
+
+This patch may cause staying in incorrect or corrupted display mode
+after EnterVT, but on man affected devices it does not cause any visible
+problems.
+
+Hacked code is never called on properly written drivers.
+
+Devices affected and testers involved for future patch removal:
+Sharp Zaurus (spitz/akita): Stanislav Brabec <utx@penguin.cz>
+
+See also:
+https://bugzilla.redhat.com/show_bug.cgi?id=238451
+
+The bug (first line indicates that your device is affected):
+
+(EE) FBDEV(0): FBIOPUT_VSCREENINFO succeeded but modified mode
+
+Fatal server error:
+EnterVT failed for screen 0
+
+Index: xorg-server-1.7.3/hw/xfree86/fbdevhw/fbdevhw.c
+===================================================================
+--- xorg-server-1.7.3.orig/hw/xfree86/fbdevhw/fbdevhw.c
++++ xorg-server-1.7.3/hw/xfree86/fbdevhw/fbdevhw.c
+@@ -571,7 +571,7 @@ fbdevHWSetMode(ScrnInfoPtr pScrn, Displa
+ #if DEBUG
+ print_fbdev_mode("returned", &set_var);
+ #endif
+- return FALSE;
++ /* return FALSE; UGLY HACK to allow return from chvt */
+ }
+
+ if (!check)
diff --git a/recipes/xorg-xserver/xserver-xorg-1.9.99.1/randr-support.patch b/recipes/xorg-xserver/xserver-xorg-1.9.99.1/randr-support.patch
new file mode 100644
index 0000000000..abc7db41eb
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-1.9.99.1/randr-support.patch
@@ -0,0 +1,102 @@
+diff -uNr xorg-server-1.9.0.orig//hw/xfree86/common/xf86Xinput.c xorg-server-1.9.0/hw/xfree86/common/xf86Xinput.c
+--- xorg-server-1.9.0.orig//hw/xfree86/common/xf86Xinput.c 2010-08-13 07:53:48.000000000 +0200
++++ xorg-server-1.9.0/hw/xfree86/common/xf86Xinput.c 2010-08-28 21:31:10.000000000 +0200
+@@ -106,6 +106,8 @@
+
+ #include "os.h"
+
++#define RR_Rotate_All (RR_Rotate_0|RR_Rotate_90|RR_Rotate_180|RR_Rotate_270)
++
+ EventListPtr xf86Events = NULL;
+
+ /**
+@@ -1359,4 +1361,73 @@
+ EnableDevice(dev, TRUE);
+ }
+
++/* Taken from evdev-properties.h. */
++#define EVDEV_PROP_SWAP_AXES "Evdev Axes Swap"
++#define EVDEV_PROP_INVERT_AXES "Evdev Axis Inversion"
++
++/* This is a hack until we get device -> CRTC association. */
++void
++xf86InputRotationNotify(Rotation rotation)
++{
++ DeviceIntPtr dev;
++ LocalDevicePtr local;
++ int ret;
++ int swap_axes = 0;
++ CARD8 invert[2] = { 0, 0 };
++ static Atom prop_swap = 0, prop_invert = 0;
++ static int atom_generation = -1;
++
++ if (atom_generation != serverGeneration) {
++ prop_swap = 0;
++ prop_invert = 0;
++ }
++
++ switch (rotation & RR_Rotate_All) {
++ case RR_Rotate_0:
++ swap_axes = 1;
++ invert[0] = 0;
++ invert[1] = 0;
++ break;
++ case RR_Rotate_90:
++ swap_axes = 0;
++ invert[0] = 0;
++ invert[1] = 1;
++ break;
++ case RR_Rotate_180:
++ swap_axes = 1;
++ invert[0] = 0;
++ invert[1] = 0;
++ break;
++ case RR_Rotate_270:
++ swap_axes = 0;
++ invert[0] = 0;
++ invert[1] = 1;
++ break;
++ }
++
++ if (!prop_swap)
++ prop_swap = MakeAtom(EVDEV_PROP_SWAP_AXES,
++ strlen(EVDEV_PROP_SWAP_AXES), TRUE);
++ if (!prop_invert)
++ prop_invert = MakeAtom(EVDEV_PROP_INVERT_AXES,
++ strlen(EVDEV_PROP_INVERT_AXES), TRUE);
++
++ for (dev = inputInfo.devices; dev; dev = dev->next) {
++ local = dev->public.devicePrivate;
++ ret = XIChangeDeviceProperty(dev, prop_swap, XA_INTEGER, 8,
++ PropModeReplace, 1, &swap_axes, FALSE);
++ if (ret != Success) {
++ xf86Msg(X_ERROR, "Changing swap_xy property failed!\n");
++ continue;
++ }
++ ret = XIChangeDeviceProperty(dev, prop_invert, XA_INTEGER, 8,
++ PropModeReplace, 2, invert, FALSE);
++ if (ret != Success) {
++ xf86Msg(X_ERROR, "Changing invert property failed!\n");
++ continue;
++ }
++ }
++}
++
++
+ /* end of xf86Xinput.c */
+diff -uNr xorg-server-1.9.0.orig//hw/xfree86/modes/xf86Crtc.c xorg-server-1.9.0/hw/xfree86/modes/xf86Crtc.c
+--- xorg-server-1.9.0.orig//hw/xfree86/modes/xf86Crtc.c 2010-07-20 05:24:12.000000000 +0200
++++ xorg-server-1.9.0/hw/xfree86/modes/xf86Crtc.c 2010-08-28 21:28:48.000000000 +0200
+@@ -387,6 +387,12 @@
+ if (didLock)
+ crtc->funcs->unlock (crtc);
+
++ /*
++ * Rotate Touchscreen
++ */
++ xf86InputRotationNotify(crtc->rotation);
++
++
+ return ret;
+ }
+
diff --git a/recipes/xorg-xserver/xserver-xorg_git.bb b/recipes/xorg-xserver/xserver-xorg_git.bb
index 9c821748cf..8d99a3cbab 100644
--- a/recipes/xorg-xserver/xserver-xorg_git.bb
+++ b/recipes/xorg-xserver/xserver-xorg_git.bb
@@ -5,16 +5,15 @@ require xorg-xserver-common.inc
DESCRIPTION = "the X.Org X server"
DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts font-util-native"
-PV = "1.8.99.906"
-PR = "${INC_PR}.4"
+PV = "1.9.99.1"
+PR = "${INC_PR}.0"
PR_append = "+gitr${SRCPV}"
PE = "2"
DEFAULT_PREFERENCE = "-1"
-SRCREV = "71af1f71c0492c365707c6b3810f94642ff39352"
+SRCREV = "d738175eaf1098e29b8afb6de8e99b5098e366a7"
SRC_URI = "git://anongit.freedesktop.org/xorg/xserver;protocol=git;branch=master \
- file://dolt-fix.patch \
file://randr-support.patch \
file://hack-fbdev-ignore-return-mode.patch \
"