aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xinetd
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xinetd
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xinetd')
-rw-r--r--recipes/xinetd/xinetd/service.c.patch24
-rw-r--r--recipes/xinetd/xinetd/xinetd.conf11
-rw-r--r--recipes/xinetd/xinetd/xinetd.init57
-rw-r--r--recipes/xinetd/xinetd_2.3.13.bb40
4 files changed, 132 insertions, 0 deletions
diff --git a/recipes/xinetd/xinetd/service.c.patch b/recipes/xinetd/xinetd/service.c.patch
new file mode 100644
index 0000000000..b94ae2184f
--- /dev/null
+++ b/recipes/xinetd/xinetd/service.c.patch
@@ -0,0 +1,24 @@
+--- xinetd-2.3.13/xinetd/service.c.orig 2006-07-01 19:14:23.000000000 +0200
++++ xinetd-2.3.13/xinetd/service.c 2006-07-01 19:22:28.000000000 +0200
+@@ -764,8 +764,8 @@
+ return FAILED;
+
+ if ( last == NULL ) {
+- last = SAIN( SVC_LAST_DGRAM_ADDR(sp) ) =
+- SAIN( calloc( 1, sizeof(union xsockaddr) ) );
++ last = SAIN(calloc( 1, sizeof(union xsockaddr) ) );
++ SVC_LAST_DGRAM_ADDR(sp) = (union xsockaddr *)last;
+ }
+
+ (void) time( &current_time ) ;
+@@ -791,8 +791,8 @@
+ return FAILED;
+
+ if( last == NULL ) {
+- last = SAIN6(SVC_LAST_DGRAM_ADDR(sp)) =
+- SAIN6(calloc( 1, sizeof(union xsockaddr) ) );
++ last = SAIN6(calloc( 1, sizeof(union xsockaddr) ) );
++ SVC_LAST_DGRAM_ADDR(sp) = (union xsockaddr *)last;
+ }
+
+ (void) time( &current_time ) ;
diff --git a/recipes/xinetd/xinetd/xinetd.conf b/recipes/xinetd/xinetd/xinetd.conf
new file mode 100644
index 0000000000..9e6ea2577e
--- /dev/null
+++ b/recipes/xinetd/xinetd/xinetd.conf
@@ -0,0 +1,11 @@
+# Simple configuration file for xinetd
+#
+# Some defaults, and include /etc/xinetd.d/
+
+defaults
+{
+
+
+}
+
+includedir /etc/xinetd.d
diff --git a/recipes/xinetd/xinetd/xinetd.init b/recipes/xinetd/xinetd/xinetd.init
new file mode 100644
index 0000000000..26dbea7415
--- /dev/null
+++ b/recipes/xinetd/xinetd/xinetd.init
@@ -0,0 +1,57 @@
+#!/bin/sh
+#
+# /etc/init.d/xinetd -- script to start and stop xinetd.
+
+if test -f /etc/default/xinetd; then
+ . /etc/default/xinetd
+fi
+
+
+test -x /usr/sbin/xinetd || exit 0
+
+checkportmap () {
+ if grep "^[^ *#]" /etc/xinetd.conf | grep -q 'rpc/'; then
+ if ! rpcinfo -u localhost portmapper >/dev/null 2>&1; then
+ echo
+ echo "WARNING: portmapper inactive - RPC services unavailable!"
+ echo " Commenting out or removing the RPC services from"
+ echo " the /etc/xinetd.conf file will remove this message."
+ echo
+ fi
+ fi
+}
+
+case "$1" in
+ start)
+ checkportmap
+ echo -n "Starting internet superserver: xinetd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/xinetd -- -pidfile /var/run/xinetd.pid $XINETD_OPTS
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping internet superserver: xinetd"
+ start-stop-daemon --stop --signal 3 --quiet --exec /usr/sbin/xinetd
+ echo "."
+ ;;
+ reload)
+ echo -n "Reloading internet superserver configuration: xinetd"
+ start-stop-daemon --stop --signal 1 --quiet --exec /usr/sbin/xinetd
+ echo "."
+ ;;
+ force-reload)
+ echo "$0 force-reload: Force Reload is deprecated"
+ echo -n "Forcefully reloading internet superserver configuration: xinetd"
+ start-stop-daemon --stop --signal 1 --quiet --exec /usr/sbin/xinetd
+ echo "."
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: /etc/init.d/xinetd {start|stop|reload|force-reload|restart}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/xinetd/xinetd_2.3.13.bb b/recipes/xinetd/xinetd_2.3.13.bb
new file mode 100644
index 0000000000..d6d42223d0
--- /dev/null
+++ b/recipes/xinetd/xinetd_2.3.13.bb
@@ -0,0 +1,40 @@
+DEPENDS = ""
+DESCRIPTION = "Highly configurable, modular and secure inetd"
+PR ="r4"
+
+SRC_URI = "http://www.xinetd.org/xinetd-${PV}.tar.gz \
+ file://xinetd.init \
+ file://xinetd.conf \
+ file://service.c.patch;patch=1 \
+ "
+
+EXTRA_OECONF="--disable-nls"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "xinetd"
+INITSCRIPT_PARAMS = "defaults"
+
+do_configure() {
+ # Looks like configure.in is broken, so we are skipping
+ # rebuilding configure and are just using the shipped one
+ oe_runconf
+}
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install() {
+ # Same here, the Makefile does some really stupid things,
+ # but since we only want two files why not override
+ # do_install from autotools and doing it ourselfs?
+ install -d "${D}/usr/sbin"
+ install -d "${D}/etc/init.d"
+ install -d "${D}/etc/xinetd.d"
+ install -m 644 "${WORKDIR}/xinetd.conf" "${D}/etc"
+ install -m 755 "${WORKDIR}/xinetd.init" "${D}/etc/init.d/xinetd"
+ install -m 755 "${S}/xinetd/xinetd" "${D}/usr/sbin"
+ install -m 755 "${S}/xinetd/itox" "${D}/usr/sbin"
+
+}
+
+CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"