aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xbmc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-06-30 14:04:36 +0200
committerKoen Kooi <koen@openembedded.org>2010-06-30 14:04:36 +0200
commit81adc0e1ce121a1cb04ea484761920e6e79c6f25 (patch)
treed6af4e2961bde74467962919233a039b47906aa9 /recipes/xbmc
parent52ebbfaf6c5ce452a89e6537034d86586b3c377f (diff)
downloadopenembedded-81adc0e1ce121a1cb04ea484761920e6e79c6f25.tar.gz
xbmc: fix version and fixup python lib
Diffstat (limited to 'recipes/xbmc')
-rw-r--r--recipes/xbmc/xbmc_svn.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/xbmc/xbmc_svn.bb b/recipes/xbmc/xbmc_svn.bb
index 4085e58527..2d1d476e87 100644
--- a/recipes/xbmc/xbmc_svn.bb
+++ b/recipes/xbmc/xbmc_svn.bb
@@ -5,7 +5,7 @@ DEPENDS = "libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image lib
SRCREV = "21029056aa4c26c6ce3aa7d09703ca8b458df201"
-PV = "0.0"
+PV = "10.05"
PR = "r2"
PR_append = "+gitr${SRCPV}"
@@ -48,6 +48,11 @@ do_compile_prepend() {
sed -i 's:I/usr/include:I${STAGING_INCDIR}:g' ${S}/Makefile
}
+do_install_append() {
+ ln -sf ${libdir}/xbmc/system/python/python24-arm.so ${D}${datadir}/xbmc/system/python/ || true
+ ln -sf ${libdir}/xbmc/system/python/python26-arm.so ${D}${datadir}/xbmc/system/python/ || true
+}
+
FILES_${PN} += "${datadir}/xsessions"
FILES_${PN}-dbg += "${libdir}/xbmc/.debug ${libdir}/xbmc/*/.debug ${libdir}/xbmc/*/*/.debug ${libdir}/xbmc/*/*/*/.debug"