aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xbmc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-07-21 12:16:38 +0200
committerKoen Kooi <koen@openembedded.org>2010-07-21 12:16:38 +0200
commit5fba14fa819ed873daa515e03ac65c303f6f9613 (patch)
treec270e15f81ea306826c9b77769ec7fbd82868063 /recipes/xbmc
parenta26f3713cbc0d76a87ed2fbb57e62515f0636f76 (diff)
downloadopenembedded-5fba14fa819ed873daa515e03ac65c303f6f9613.tar.gz
xbmc: fix up recipe a bit
Diffstat (limited to 'recipes/xbmc')
-rw-r--r--recipes/xbmc/xbmc_svn.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/recipes/xbmc/xbmc_svn.bb b/recipes/xbmc/xbmc_svn.bb
index da60ce40ab..fdc454086f 100644
--- a/recipes/xbmc/xbmc_svn.bb
+++ b/recipes/xbmc/xbmc_svn.bb
@@ -3,10 +3,10 @@ LICENSE = "xbmc"
DEPENDS = "libxmu fribidi mpeg2dec ffmpeg samba fontconfig curl libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer virtual/egl mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo2 enca avahi libsamplerate0 libxrandr bzip2 virtual/libsdl"
-SRCREV = "11eb9981945e60828678ef641dae8f950a2e9295"
+SRCREV = "e2ab481ebe964321c358ab9d6402088c714adcbe"
PV = "10.05"
-PR = "r3"
+PR = "r7"
PR_append = "+gitr${SRCPV}"
SRC_URI = "git://xbmc.git.sourceforge.net/gitroot/xbmc/xbmc;protocol=git;branch=master \
@@ -34,7 +34,11 @@ EXTRA_OECONF = " \
"
do_configure() {
- sh bootstrap.angstrom
+ if [ -e bootstrap.angstrom ] ; then
+ sh bootstrap.angstrom
+ else
+ sh bootstrap
+ fi
oe_runconf
}
@@ -56,6 +60,9 @@ do_install_append() {
FILES_${PN} += "${datadir}/xsessions"
FILES_${PN}-dbg += "${libdir}/xbmc/.debug ${libdir}/xbmc/*/.debug ${libdir}/xbmc/*/*/.debug ${libdir}/xbmc/*/*/*/.debug"
+# Only builds with glibc currently, so this is "safe"
+RRECOMMENDS_${PN} += "glibc-charmap-ibm850 glibc-gconv-ibm850"
+
# GNU_HASH QA errors...
INSANE_SKIP_${PN} = "True"