aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/upnp
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-01-18 20:46:01 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-01-18 20:48:41 +0100
commit7bf770ae12cd0d6ae45bf0a40670003af6459a12 (patch)
treeec2f0fa6d561a62932bc72328b14a69d68fdcee6 /recipes/upnp
parentd9c5076be1d16f2783716d2bd5de59769e1afb26 (diff)
downloadopenembedded-7bf770ae12cd0d6ae45bf0a40670003af6459a12.tar.gz
gupnp-vala: added 0.6.2
Diffstat (limited to 'recipes/upnp')
-rw-r--r--recipes/upnp/gupnp-vala_0.6.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/upnp/gupnp-vala_0.6.2.bb b/recipes/upnp/gupnp-vala_0.6.2.bb
new file mode 100644
index 0000000000..d5544cb8b3
--- /dev/null
+++ b/recipes/upnp/gupnp-vala_0.6.2.bb
@@ -0,0 +1,22 @@
+LICENSE = "LGPL"
+DEPENDS = "gupnp vala-native"
+
+PR = "r1"
+
+SRC_URI = "http://gupnp.org/sources/bindings/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ mv ${D}${STAGING_DIR_NATIVE}/* ${D}
+}
+
+FILES_${PN}-dev += "${datadir}/vala"
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_DATADIR}/vala/vapi
+ install -m 0644 ${S}/*.deps ${S}/*.vapi ${STAGING_DATADIR}/vala/vapi
+}
+
+