aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-02-18 13:44:11 +0100
committerKoen Kooi <koen@openembedded.org>2010-02-21 18:19:40 +0100
commitff1e09b5e72f92dfc2abe19e1de4d53f10430682 (patch)
treec41757ab95ff791c34b3778e9161b22e3b87c818 /recipes/u-boot
parent276ffe064a5acfdc14c34352b7031bea66f7af6f (diff)
downloadopenembedded-ff1e09b5e72f92dfc2abe19e1de4d53f10430682.tar.gz
u-boot-git: update beagleboard patches for new XM revision
* needs more work, but it sets the correct mux now for DVI output
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-git/beagleboard/0001-omap3-clock.c-don-t-reprogram-clocks-when-trying-to-.patch50
-rw-r--r--recipes/u-boot/u-boot-git/beagleboard/0002-beagleboard-add-pinmuxing-for-beagleboard-XM.patch69
-rw-r--r--recipes/u-boot/u-boot-git/beagleboard/0003-beagleboard-move-muxing-into-revision-print-switch.patch53
-rw-r--r--recipes/u-boot/u-boot-git/beagleboard/720MHz.patch98
-rw-r--r--recipes/u-boot/u-boot-git/beagleboard/revision-detection.patch105
-rw-r--r--recipes/u-boot/u-boot_git.bb5
6 files changed, 181 insertions, 199 deletions
diff --git a/recipes/u-boot/u-boot-git/beagleboard/0001-omap3-clock.c-don-t-reprogram-clocks-when-trying-to-.patch b/recipes/u-boot/u-boot-git/beagleboard/0001-omap3-clock.c-don-t-reprogram-clocks-when-trying-to-.patch
new file mode 100644
index 0000000000..eead4b9d7c
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/beagleboard/0001-omap3-clock.c-don-t-reprogram-clocks-when-trying-to-.patch
@@ -0,0 +1,50 @@
+From 0c597fe20bab64deca7d71e7da6c0a7e553a2a7b Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Thu, 18 Feb 2010 11:05:49 +0100
+Subject: [PATCH 1/2] omap3 clock.c: don't reprogram clocks when trying to find out clock divider
+
+---
+ cpu/arm_cortexa8/omap3/clock.c | 14 +++++++++-----
+ 1 files changed, 9 insertions(+), 5 deletions(-)
+
+diff --git a/cpu/arm_cortexa8/omap3/clock.c b/cpu/arm_cortexa8/omap3/clock.c
+index d67517a..40bd679 100644
+--- a/cpu/arm_cortexa8/omap3/clock.c
++++ b/cpu/arm_cortexa8/omap3/clock.c
+@@ -40,17 +40,19 @@
+ *****************************************************************************/
+ u32 get_osc_clk_speed(void)
+ {
+- u32 start, cstart, cend, cdiff, val;
++ u32 start, cstart, cend, cdiff, cdiv, val;
+ struct prcm *prcm_base = (struct prcm *)PRCM_BASE;
+ struct prm *prm_base = (struct prm *)PRM_BASE;
+ struct gptimer *gpt1_base = (struct gptimer *)OMAP34XX_GPT1;
+ struct s32ktimer *s32k_base = (struct s32ktimer *)SYNC_32KTIMER_BASE;
+
+ val = readl(&prm_base->clksrc_ctrl);
+-
+- /* If SYS_CLK is being divided by 2, remove for now */
+- val = (val & (~SYSCLKDIV_2)) | SYSCLKDIV_1;
+- writel(val, &prm_base->clksrc_ctrl);
++ if (val & SYSCLKDIV_2)
++ cdiv = 2;
++ else if (val & SYSCLKDIV_1)
++ cdiv = 1;
++ else
++ cdiv = 1;
+
+ /* enable timer2 */
+ val = readl(&prcm_base->clksel_wkup) | CLKSEL_GPT1;
+@@ -83,6 +85,8 @@ u32 get_osc_clk_speed(void)
+ cend = readl(&gpt1_base->tcrr); /* get end sys_clk count */
+ cdiff = cend - cstart; /* get elapsed ticks */
+
++ cdiff *= cdiv;
++
+ /* based on number of ticks assign speed */
+ if (cdiff > 19000)
+ return S38_4M;
+--
+1.6.6.1
+
diff --git a/recipes/u-boot/u-boot-git/beagleboard/0002-beagleboard-add-pinmuxing-for-beagleboard-XM.patch b/recipes/u-boot/u-boot-git/beagleboard/0002-beagleboard-add-pinmuxing-for-beagleboard-XM.patch
new file mode 100644
index 0000000000..fe014084d8
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/beagleboard/0002-beagleboard-add-pinmuxing-for-beagleboard-XM.patch
@@ -0,0 +1,69 @@
+From 8698ae8de6be63c35d8816e78b0e53c6a4b74933 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Thu, 18 Feb 2010 11:19:50 +0100
+Subject: [PATCH 2/2] beagleboard: add pinmuxing for beagleboard XM
+
+---
+ board/ti/beagle/beagle.c | 16 ++++++++++++++--
+ board/ti/beagle/beagle.h | 20 ++++++++++++++++++++
+ 2 files changed, 34 insertions(+), 2 deletions(-)
+
+diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
+index 1d91c76..8b5243b 100644
+--- a/board/ti/beagle/beagle.c
++++ b/board/ti/beagle/beagle.c
+@@ -182,6 +182,18 @@ void set_muxconf_regs(void)
+ {
+ MUX_BEAGLE();
+
+- if (beagle_revision != REVISION_AXBX)
+- MUX_BEAGLE_C();
++ switch(beagle_revision) {
++ case REVISION_AXBX:
++ break;
++ case REVISION_CX:
++ MUX_BEAGLE_C();
++ break;
++ case REVISION_C4:
++ MUX_BEAGLE_C();
++ break;
++ case REVISION_XM:
++ MUX_BEAGLE_C();
++ MUX_BEAGLE_XM();
++ break;
++ }
+ }
+diff --git a/board/ti/beagle/beagle.h b/board/ti/beagle/beagle.h
+index db17160..adf8c5a 100644
+--- a/board/ti/beagle/beagle.h
++++ b/board/ti/beagle/beagle.h
+@@ -387,6 +387,26 @@ const omap3_sysinfo sysinfo = {
+ MUX_VAL(CP(UART2_RTS), (IDIS | PTD | DIS | M0)) /*UART2_RTS*/\
+ MUX_VAL(CP(UART2_TX), (IDIS | PTD | DIS | M0)) /*UART2_TX*/
+
++#define MUX_BEAGLE_XM() \
++ MUX_VAL(CP(DSS_DATA0), (IDIS | PTD | DIS | M7)) /*safe_mode*/\
++ MUX_VAL(CP(DSS_DATA1), (IDIS | PTD | DIS | M7)) /*safe_mode*/\
++ MUX_VAL(CP(DSS_DATA2), (IDIS | PTD | DIS | M7)) /*safe_mode*/\
++ MUX_VAL(CP(DSS_DATA3), (IDIS | PTD | DIS | M7)) /*safe_mode*/\
++ MUX_VAL(CP(DSS_DATA4), (IDIS | PTD | DIS | M7)) /*safe_mode*/\
++ MUX_VAL(CP(DSS_DATA5), (IDIS | PTD | DIS | M7)) /*safe_mode*/\
++ MUX_VAL(CP(DSS_DATA18), (IDIS | PTD | DIS | M3)) /*DSS_DATA0*/\
++ MUX_VAL(CP(DSS_DATA19), (IDIS | PTD | DIS | M3)) /*DSS_DATA1*/\
++ MUX_VAL(CP(DSS_DATA20), (IDIS | PTD | DIS | M3)) /*DSS_DATA2*/\
++ MUX_VAL(CP(DSS_DATA21), (IDIS | PTD | DIS | M3)) /*DSS_DATA3*/\
++ MUX_VAL(CP(DSS_DATA22), (IDIS | PTD | DIS | M3)) /*DSS_DATA4*/\
++ MUX_VAL(CP(DSS_DATA23), (IDIS | PTD | DIS | M3)) /*DSS_DATA5*/\
++ MUX_VAL(CP(SYS_BOOT0), (IDIS | PTD | DIS | M3)) /*DSS_DATA18*/\
++ MUX_VAL(CP(SYS_BOOT1), (IDIS | PTD | DIS | M3)) /*DSS_DATA19*/\
++ MUX_VAL(CP(SYS_BOOT3), (IDIS | PTD | DIS | M3)) /*DSS_DATA20*/\
++ MUX_VAL(CP(SYS_BOOT4), (IDIS | PTD | DIS | M3)) /*DSS_DATA21*/\
++ MUX_VAL(CP(SYS_BOOT5), (IDIS | PTD | DIS | M3)) /*DSS_DATA22*/\
++ MUX_VAL(CP(SYS_BOOT6), (IDIS | PTD | DIS | M3)) /*DSS_DATA23*/
++
+ /*
+ * Display Configuration
+ */
+--
+1.6.6.1
+
diff --git a/recipes/u-boot/u-boot-git/beagleboard/0003-beagleboard-move-muxing-into-revision-print-switch.patch b/recipes/u-boot/u-boot-git/beagleboard/0003-beagleboard-move-muxing-into-revision-print-switch.patch
new file mode 100644
index 0000000000..3750cf8990
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/beagleboard/0003-beagleboard-move-muxing-into-revision-print-switch.patch
@@ -0,0 +1,53 @@
+From 24e335a1457da32a1d79621d3a24462d6fb96853 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Thu, 18 Feb 2010 11:55:26 +0100
+Subject: [PATCH] beagleboard: move muxing into revision print switch()
+
+---
+ board/ti/beagle/beagle.c | 19 ++++---------------
+ 1 files changed, 4 insertions(+), 15 deletions(-)
+
+diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
+index 8b5243b..8fac6b2 100644
+--- a/board/ti/beagle/beagle.c
++++ b/board/ti/beagle/beagle.c
+@@ -101,12 +101,16 @@ void beagle_identify(void)
+ break;
+ case REVISION_CX:
+ printf("C1/C2/C3\n");
++ MUX_BEAGLE_C();
+ break;
+ case REVISION_C4:
+ printf("C4\n");
++ MUX_BEAGLE_C();
+ break;
+ case REVISION_XM:
+ printf("XM\n");
++ MUX_BEAGLE_C();
++ MUX_BEAGLE_XM();
+ break;
+ default:
+ printf("unknown 0x%02x\n", beagle_revision);
+@@ -181,19 +185,4 @@ int misc_init_r(void)
+ void set_muxconf_regs(void)
+ {
+ MUX_BEAGLE();
+-
+- switch(beagle_revision) {
+- case REVISION_AXBX:
+- break;
+- case REVISION_CX:
+- MUX_BEAGLE_C();
+- break;
+- case REVISION_C4:
+- MUX_BEAGLE_C();
+- break;
+- case REVISION_XM:
+- MUX_BEAGLE_C();
+- MUX_BEAGLE_XM();
+- break;
+- }
+ }
+--
+1.6.6.1
+
diff --git a/recipes/u-boot/u-boot-git/beagleboard/720MHz.patch b/recipes/u-boot/u-boot-git/beagleboard/720MHz.patch
index 5fe56f37a4..c50e0bd793 100644
--- a/recipes/u-boot/u-boot-git/beagleboard/720MHz.patch
+++ b/recipes/u-boot/u-boot-git/beagleboard/720MHz.patch
@@ -1,87 +1,3 @@
-Delivered-To: koen@beagleboard.org
-Received: by 10.216.36.75 with SMTP id v53cs218072wea;
- Fri, 8 Jan 2010 07:40:21 -0800 (PST)
-Received: by 10.142.4.39 with SMTP id 39mr2584681wfd.128.1262965220278;
- Fri, 08 Jan 2010 07:40:20 -0800 (PST)
-Return-Path: <33FFHSwYPC8Aqngyoshkgmrkhugxj.uxmhkgmrkhugxjmuumrkmxu0vy.ius@listserv.bounces.google.com>
-Received: from mail-pw0-f72.google.com (mail-pw0-f72.google.com [209.85.160.72])
- by mx.google.com with ESMTP id 38si23195897pzk.46.2010.01.08.07.40.18;
- Fri, 08 Jan 2010 07:40:19 -0800 (PST)
-Received-SPF: pass (google.com: domain of 33FFHSwYPC8Aqngyoshkgmrkhugxj.uxmhkgmrkhugxjmuumrkmxu0vy.ius@listserv.bounces.google.com designates 209.85.160.72 as permitted sender) client-ip=209.85.160.72;
-Authentication-Results: mx.google.com; spf=pass (google.com: domain of 33FFHSwYPC8Aqngyoshkgmrkhugxj.uxmhkgmrkhugxjmuumrkmxu0vy.ius@listserv.bounces.google.com designates 209.85.160.72 as permitted sender) smtp.mail=33FFHSwYPC8Aqngyoshkgmrkhugxj.uxmhkgmrkhugxjmuumrkmxu0vy.ius@listserv.bounces.google.com; dkim=pass (test mode) header.i=@googlegroups.com
-Received: by pwj4 with SMTP id 4sf2565630pwj.11
- for <multiple recipients>; Fri, 08 Jan 2010 07:40:18 -0800 (PST)
-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
- d=googlegroups.com; s=beta;
- h=domainkey-signature:received:x-beenthere:received:received:received
- :received:received-spf:received:mime-version:received:date
- :message-id:subject:from:to:x-original-authentication-results
- :x-original-sender:reply-to:precedence:mailing-list:list-id
- :list-post:list-help:list-archive:x-thread-url:x-message-url:sender
- :list-unsubscribe:list-subscribe:content-type;
- bh=sLkJYeKXFIX8TOTxLWasbW6XSWbNbihsEqHqajWruOU=;
- b=hNYYuHunIzWspBNr+rsCpj+cl3TfrJP/qRi2OR8S8fvW1ATmUGwE3UcFxBx/cz4C47
- rPcDSOVMOKJn2ybeb7z12kDUV7FLPbzI26BjmBUXoLC4yYdCeiwS+pR/gCEP/CZsVNam
- 0/sgZd6Zfnui2nrHnqHFA/eBwvBmNr8njjhzc=
-DomainKey-Signature: a=rsa-sha1; c=nofws;
- d=googlegroups.com; s=beta;
- h=x-beenthere:received-spf:mime-version:date:message-id:subject:from
- :to:x-original-authentication-results:x-original-sender:reply-to
- :precedence:mailing-list:list-id:list-post:list-help:list-archive
- :x-thread-url:x-message-url:sender:list-unsubscribe:list-subscribe
- :content-type;
- b=kvIhKL3OOVUlwb+XfiZuzkLNRQqtf4QLC8FZStrd2J1zfvTSjTuxtFrU2bqN6OVn+6
- s9CW3qnGQKNfIuBNUfuQirfG7O/QkdVxGx8nXYPwcm1xL9mJa70CGUoNA4gnwZSFXEmA
- v3N+BsCQs8InO9VHQxTmTP1pW4DH9HIPqIjFs=
-Received: by 10.115.67.15 with SMTP id u15mr3692522wak.15.1262965212711;
- Fri, 08 Jan 2010 07:40:12 -0800 (PST)
-X-BeenThere: beagleboard@googlegroups.com
-Received: by 10.114.19.19 with SMTP id 19ls485387was.0.p; Fri, 08 Jan 2010
- 07:40:07 -0800 (PST)
-Received: by 10.114.3.19 with SMTP id 19mr7029424wac.17.1262965207675;
- Fri, 08 Jan 2010 07:40:07 -0800 (PST)
-Received: by 10.114.3.19 with SMTP id 19mr7029423wac.17.1262965207655;
- Fri, 08 Jan 2010 07:40:07 -0800 (PST)
-Return-Path: <khasim@beagleboard.org>
-Received: from mail-px0-f196.google.com (mail-px0-f196.google.com [209.85.216.196])
- by gmr-mx.google.com with ESMTP id 23si8245940pxi.8.2010.01.08.07.40.07;
- Fri, 08 Jan 2010 07:40:07 -0800 (PST)
-Received-SPF: neutral (google.com: 209.85.216.196 is neither permitted nor denied by best guess record for domain of khasim@beagleboard.org) client-ip=209.85.216.196;
-Received: by pxi34 with SMTP id 34so11355653pxi.8
- for <beagleboard@googlegroups.com>; Fri, 08 Jan 2010 07:40:07 -0800 (PST)
-MIME-Version: 1.0
-Received: by 10.142.75.10 with SMTP id x10mr1272361wfa.153.1262965205948; Fri,
- 08 Jan 2010 07:40:05 -0800 (PST)
-Date: Fri, 8 Jan 2010 21:10:05 +0530
-Message-ID: <a8ca84ad1001080740l63fdac79y6b478863b0a5e316@mail.gmail.com>
-Subject: [beagleboard] TI:OMAP: [PATCH 3/4] Support 720Mhz configuration for
- OMAP35xx
-From: Khasim Syed Mohammed <khasim@beagleboard.org>
-To: u-boot@lists.denx.de, beagleboard@googlegroups.com
-X-Original-Authentication-Results: gmr-mx.google.com; spf=neutral (google.com:
- 209.85.216.196 is neither permitted nor denied by best guess record for
- domain of khasim@beagleboard.org) smtp.mail=khasim@beagleboard.org
-X-Original-Sender: khasim@beagleboard.org
-Reply-To: beagleboard@googlegroups.com
-Precedence: list
-Mailing-list: list beagleboard@googlegroups.com; contact beagleboard+owners@googlegroups.com
-List-ID: <beagleboard.googlegroups.com>
-List-Post: <http://groups.google.com/group/beagleboard/post?hl=>,
- <mailto:beagleboard@googlegroups.com>
-List-Help: <http://groups.google.com/support/?hl=>, <mailto:beagleboard+help@googlegroups.com>
-List-Archive: <http://groups.google.com/group/beagleboard?hl=>
-X-Thread-Url: http://groups.google.com/group/beagleboard/t/1d8e4b923e126fcb
-X-Message-Url: http://groups.google.com/group/beagleboard/msg/b8825bed3084009a
-Sender: beagleboard@googlegroups.com
-List-Unsubscribe: <http://groups.google.com/group/beagleboard/subscribe?hl=>,
- <mailto:beagleboard+unsubscribe@googlegroups.com>
-List-Subscribe: <http://groups.google.com/group/beagleboard/subscribe?hl=>,
- <mailto:beagleboard+subscribe@googlegroups.com>
-Content-Type: multipart/mixed; boundary=001636b2ac6d98250e047ca900e4
-
---001636b2ac6d98250e047ca900e4
-Content-Type: text/plain; charset=ISO-8859-1
-
From bba669562fa208d12f4c7cd8188446e8576cd6ee Mon Sep 17 00:00:00 2001
From: Syed Mohammed Khasim <khasim@ti.com>
Date: Fri, 8 Jan 2010 20:34:37 +0530
@@ -112,7 +28,7 @@ index 0def5a6..7985ee9 100644
twl4030_power_init();
twl4030_led_init();
-+ if (beagle_revision == REVISION_C4) {
++ if ((beagle_revision == REVISION_C4) || (beagle_revision == REVISION_XM)) {
+
+ /* Select TWL4030 VSEL to support 720Mhz */
+ twl4030_pmrecv_vsel_cfg(TWL4030_PM_RECEIVER_VAUX2_DEDICATED,
@@ -248,15 +164,3 @@ index f260ecb..b96c96c 100644
--
1.5.6.3
---001636b2ac6d98250e047ca900e4
-Content-Type: text/plain; charset=ISO-8859-1
-
---
-You received this message because you are subscribed to the Google Groups "Beagle Board" group.
-To post to this group, send email to beagleboard@googlegroups.com.
-To unsubscribe from this group, send email to beagleboard+unsubscribe@googlegroups.com.
-For more options, visit this group at http://groups.google.com/group/beagleboard?hl=en.
-
-
-
---001636b2ac6d98250e047ca900e4--
diff --git a/recipes/u-boot/u-boot-git/beagleboard/revision-detection.patch b/recipes/u-boot/u-boot-git/beagleboard/revision-detection.patch
index c2a41bfcc7..634efda385 100644
--- a/recipes/u-boot/u-boot-git/beagleboard/revision-detection.patch
+++ b/recipes/u-boot/u-boot-git/beagleboard/revision-detection.patch
@@ -1,87 +1,3 @@
-Delivered-To: koen@beagleboard.org
-Received: by 10.216.36.75 with SMTP id v53cs217947wea;
- Fri, 8 Jan 2010 07:38:03 -0800 (PST)
-Received: by 10.141.214.24 with SMTP id r24mr6834000rvq.27.1262965082475;
- Fri, 08 Jan 2010 07:38:02 -0800 (PST)
-Return-Path: <3UlFHSwYPCzYcZSkaeTWSYdWTgSjV.gjYTWSYdWTgSjVYggYdWYjgmhk.Uge@listserv.bounces.google.com>
-Received: from mail-pw0-f72.google.com (mail-pw0-f72.google.com [209.85.160.72])
- by mx.google.com with ESMTP id 31si42836225pzk.96.2010.01.08.07.38.00;
- Fri, 08 Jan 2010 07:38:01 -0800 (PST)
-Received-SPF: pass (google.com: domain of 3UlFHSwYPCzYcZSkaeTWSYdWTgSjV.gjYTWSYdWTgSjVYggYdWYjgmhk.Uge@listserv.bounces.google.com designates 209.85.160.72 as permitted sender) client-ip=209.85.160.72;
-Authentication-Results: mx.google.com; spf=pass (google.com: domain of 3UlFHSwYPCzYcZSkaeTWSYdWTgSjV.gjYTWSYdWTgSjVYggYdWYjgmhk.Uge@listserv.bounces.google.com designates 209.85.160.72 as permitted sender) smtp.mail=3UlFHSwYPCzYcZSkaeTWSYdWTgSjV.gjYTWSYdWTgSjVYggYdWYjgmhk.Uge@listserv.bounces.google.com; dkim=pass (test mode) header.i=@googlegroups.com
-Received: by pwj4 with SMTP id 4sf2565182pwj.11
- for <multiple recipients>; Fri, 08 Jan 2010 07:38:00 -0800 (PST)
-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
- d=googlegroups.com; s=beta;
- h=domainkey-signature:received:x-beenthere:received:received:received
- :received:received-spf:received:mime-version:received:date
- :message-id:subject:from:to:x-original-authentication-results
- :x-original-sender:reply-to:precedence:mailing-list:list-id
- :list-post:list-help:list-archive:x-thread-url:x-message-url:sender
- :list-unsubscribe:list-subscribe:content-type;
- bh=XdDWC3Pjbe6mfVpRg0Nyb4elMKzFUcLRQ+7/Tb3fHMQ=;
- b=NiM6Z+/ubLFaxomCEKnZjYyFgB7ZbE4xWWwqF6i/H8BQiedPp1rBmQSdQ2EH4qDFgm
- D3DR5jXVjtOALhgh/9cxU/S46ltiM5rtGnwtcjgV+Gv9r5/sfqhze9c81t7bzIo+bpqn
- cg8yNHOFjwkPSWdSidIhKnZJGQRj/ZIgxJxCw=
-DomainKey-Signature: a=rsa-sha1; c=nofws;
- d=googlegroups.com; s=beta;
- h=x-beenthere:received-spf:mime-version:date:message-id:subject:from
- :to:x-original-authentication-results:x-original-sender:reply-to
- :precedence:mailing-list:list-id:list-post:list-help:list-archive
- :x-thread-url:x-message-url:sender:list-unsubscribe:list-subscribe
- :content-type;
- b=0jHA96QBedAxJl8vWrKHetbULCj+FIcyXTmI01rlbnfXOm8WuPhJDLyj7Qo34LiQXE
- dYkeQ2RNv3L03nbVuPezNfUKHuKLONUQKVvAfxRDset7eLpsYuKQZADZ+loSfkeVlwDW
- ai/7Z937On5tliSGUDPp+73oUNfje1ReYx+dc=
-Received: by 10.115.87.31 with SMTP id p31mr3273178wal.7.1262965074762;
- Fri, 08 Jan 2010 07:37:54 -0800 (PST)
-X-BeenThere: beagleboard@googlegroups.com
-Received: by 10.115.116.23 with SMTP id t23ls485636wam.1.p; Fri, 08 Jan 2010
- 07:37:51 -0800 (PST)
-Received: by 10.114.3.19 with SMTP id 19mr7028808wac.17.1262965071286;
- Fri, 08 Jan 2010 07:37:51 -0800 (PST)
-Received: by 10.114.3.19 with SMTP id 19mr7028807wac.17.1262965071261;
- Fri, 08 Jan 2010 07:37:51 -0800 (PST)
-Return-Path: <khasim@beagleboard.org>
-Received: from mail-px0-f174.google.com (mail-px0-f174.google.com [209.85.216.174])
- by gmr-mx.google.com with ESMTP id 16si3405423pxi.11.2010.01.08.07.37.51;
- Fri, 08 Jan 2010 07:37:51 -0800 (PST)
-Received-SPF: neutral (google.com: 209.85.216.174 is neither permitted nor denied by best guess record for domain of khasim@beagleboard.org) client-ip=209.85.216.174;
-Received: by mail-px0-f174.google.com with SMTP id 4so2127527pxi.33
- for <beagleboard@googlegroups.com>; Fri, 08 Jan 2010 07:37:51 -0800 (PST)
-MIME-Version: 1.0
-Received: by 10.142.66.15 with SMTP id o15mr4287776wfa.145.1262965071051; Fri,
- 08 Jan 2010 07:37:51 -0800 (PST)
-Date: Fri, 8 Jan 2010 21:07:50 +0530
-Message-ID: <a8ca84ad1001080737r2312270ao80aa04ce60cc780@mail.gmail.com>
-Subject: [beagleboard] TI:OMAP: [PATCH 1/4] OMAP3 Beagle Update revision
- detection
-From: Khasim Syed Mohammed <khasim@beagleboard.org>
-To: u-boot@lists.denx.de, beagleboard@googlegroups.com
-X-Original-Authentication-Results: gmr-mx.google.com; spf=neutral (google.com:
- 209.85.216.174 is neither permitted nor denied by best guess record for
- domain of khasim@beagleboard.org) smtp.mail=khasim@beagleboard.org
-X-Original-Sender: khasim@beagleboard.org
-Reply-To: beagleboard@googlegroups.com
-Precedence: list
-Mailing-list: list beagleboard@googlegroups.com; contact beagleboard+owners@googlegroups.com
-List-ID: <beagleboard.googlegroups.com>
-List-Post: <http://groups.google.com/group/beagleboard/post?hl=>,
- <mailto:beagleboard@googlegroups.com>
-List-Help: <http://groups.google.com/support/?hl=>, <mailto:beagleboard+help@googlegroups.com>
-List-Archive: <http://groups.google.com/group/beagleboard?hl=>
-X-Thread-Url: http://groups.google.com/group/beagleboard/t/1d4ac362a651981d
-X-Message-Url: http://groups.google.com/group/beagleboard/msg/8a2d1aa3c9c40beb
-Sender: beagleboard@googlegroups.com
-List-Unsubscribe: <http://groups.google.com/group/beagleboard/subscribe?hl=>,
- <mailto:beagleboard+unsubscribe@googlegroups.com>
-List-Subscribe: <http://groups.google.com/group/beagleboard/subscribe?hl=>,
- <mailto:beagleboard+subscribe@googlegroups.com>
-Content-Type: multipart/mixed; boundary=0016e64cc3d4779e0f047ca8f8bb
-
---0016e64cc3d4779e0f047ca8f8bb
-Content-Type: text/plain; charset=ISO-8859-1
-
From 15fbe5ff9ee2fd2f8da4c16805d6c7ccf7244bae Mon Sep 17 00:00:00 2001
From: Syed Mohammed Khasim <khasim@ti.com>
Date: Fri, 8 Jan 2010 20:13:47 +0530
@@ -134,7 +50,7 @@ index 32d501e..0def5a6 100644
+ * GPIO173, GPIO172, GPIO171: 1 1 1 => Ax/Bx
+ * GPIO173, GPIO172, GPIO171: 1 1 0 => C1/2/3
+ * GPIO173, GPIO172, GPIO171: 1 0 1 => C4
-+ * GPIO173, GPIO172, GPIO171: 0 0 0 => D
++ * GPIO173, GPIO172, GPIO171: 0 0 0 => XM
*/
void beagle_identify(void)
{
@@ -180,8 +96,8 @@ index 32d501e..0def5a6 100644
+ case REVISION_C4:
+ printf("C4\n");
+ break;
-+ case REVISION_D:
-+ printf("D\n");
++ case REVISION_XM:
++ printf("XM\n");
+ break;
+ default:
+ printf("unknown 0x%02x\n", beagle_revision);
@@ -211,7 +127,7 @@ index 7fe6275..b1720c9 100644
+#define REVISION_AXBX 0x7
+#define REVISION_CX 0x6
+#define REVISION_C4 0x5
-+#define REVISION_D 0x0
++#define REVISION_XM 0x0
/*
* IEN - Input Enable
@@ -226,16 +142,3 @@ index 7fe6275..b1720c9 100644
MUX_VAL(CP(MCSPI1_CS2), (IDIS | PTD | DIS | M4)) /*GPIO_176*/\
--
1.5.6.3
-
---0016e64cc3d4779e0f047ca8f8bb
-Content-Type: text/plain; charset=ISO-8859-1
-
---
-You received this message because you are subscribed to the Google Groups "Beagle Board" group.
-To post to this group, send email to beagleboard@googlegroups.com.
-To unsubscribe from this group, send email to beagleboard+unsubscribe@googlegroups.com.
-For more options, visit this group at http://groups.google.com/group/beagleboard?hl=en.
-
-
-
---0016e64cc3d4779e0f047ca8f8bb--
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index b34b8d13f8..711d7d18f2 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r38"
+PR ="r39"
FILESPATHPKG =. "u-boot-git:"
@@ -23,6 +23,9 @@ file://revision-detection.patch;patch=1 \
file://i2c.patch;patch=1 \
file://720MHz.patch;patch=1 \
file://dss.patch;patch=1 \
+file://0001-omap3-clock.c-don-t-reprogram-clocks-when-trying-to-.patch;patch=1 \
+file://0002-beagleboard-add-pinmuxing-for-beagleboard-XM.patch;patch=1 \
+file://0003-beagleboard-move-muxing-into-revision-print-switch.patch;patch=1 \
"
SRCREV_beagleboard = "a5cf522a91ba479d459f8221135bdb3e9ae97479"