aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-27 21:11:10 +0000
committerKoen Kooi <koen@openembedded.org>2009-10-28 10:16:28 +0100
commite65da86dc1bcfd8f7cf47987689c588b2574f341 (patch)
tree1221047bf93e0b5a39e5d6a8586f8fb6ff69550c /recipes/u-boot
parent12eb9b8d48602863a763b3e2c4a8559285b5beb6 (diff)
downloadopenembedded-e65da86dc1bcfd8f7cf47987689c588b2574f341.tar.gz
u-boot/x-load: Add support for the omap3-pandora building from trees as git.openpandora.org.
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-omap3pandora_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-omap3pandora_git.bb b/recipes/u-boot/u-boot-omap3pandora_git.bb
new file mode 100644
index 0000000000..db68f9eadf
--- /dev/null
+++ b/recipes/u-boot/u-boot-omap3pandora_git.bb
@@ -0,0 +1,28 @@
+require u-boot.inc
+
+COMPATIBLE_MACHINE = "omap3-pandora"
+
+# Latest SRCREV for the final shipping boards.
+SRCREV = "0ffcce5dad2153f5f3094f9114b1ae50aef2f5ad"
+
+# Latest SRCREV for the rev2 < boards.
+#SRCREV = "f1cc097b8a8c3c5e1bb6fbec906cfedd939c5be3"
+
+PROVIDES = "u-boot"
+
+PV = "pandora+${PR}+gitr${SRCREV}"
+PR ="r2"
+PE = "1"
+
+SRC_URI = "git://git.openpandora.org/pandora-u-boot.git;branch=master;protocol=git \
+"
+
+# Rev 2 tree
+#SRC_URI = "git://git.openpandora.org/pandora-u-boot.git;branch=rev3;protocol=git \
+#"
+
+UBOOT_MACHINE_omap3_pandora = "omap3_pandora_config"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"