aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-06 15:12:47 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-06 15:12:47 +0200
commitc273263b147da671b5ee105eb85d4302daf33555 (patch)
tree827b8000a203a559d924befee62a6b2574e601c0 /recipes/u-boot
parent877213524a17c032f8eec9c84c791ab3da46216e (diff)
downloadopenembedded-c273263b147da671b5ee105eb85d4302daf33555.tar.gz
u-boot git: update overo and beagleboard to 2009.03
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/files/dss2.patch61
-rw-r--r--recipes/u-boot/files/fw-env.patch12
-rw-r--r--recipes/u-boot/u-boot_git.bb16
3 files changed, 86 insertions, 3 deletions
diff --git a/recipes/u-boot/files/dss2.patch b/recipes/u-boot/files/dss2.patch
new file mode 100644
index 0000000000..4dfc5d6b10
--- /dev/null
+++ b/recipes/u-boot/files/dss2.patch
@@ -0,0 +1,61 @@
+diff --git a/include/configs/omap3_overo.h b/include/configs/omap3_overo.h
+index dee0417..2f8a952 100644
+--- a/include/configs/omap3_overo.h
++++ b/include/configs/omap3_overo.h
+@@ -149,14 +149,21 @@
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "loadaddr=0x82000000\0" \
+ "console=ttyS2,115200n8\0" \
+- "videomode=1024x768@60,vxres=1024,vyres=768\0" \
+- "videospec=omapfb:vram:2M,vram:4M\0" \
++ "vram=12M\0" \
++ "dvimode=1024x768MR-16@60\0" \
++ "defaultdisplay=dvi\0" \
+ "mmcargs=setenv bootargs console=${console} " \
+- "video=${videospec},mode:${videomode} " \
++ "vram=${vram} " \
++ "omapfb.mode=dvi:${dvimode} " \
++ "omapfb.debug=y " \
++ "omapdss.def_disp=${defaultdisplay} " \
+ "root=/dev/mmcblk0p2 rw " \
+ "rootfstype=ext3 rootwait\0" \
+ "nandargs=setenv bootargs console=${console} " \
+- "video=${videospec},mode:${videomode} " \
++ "vram=${vram} " \
++ "omapfb.mode=dvi:${dvimode} " \
++ "omapfb.debug=y " \
++ "omapdss.def_disp=${defaultdisplay} " \
+ "root=/dev/mtdblock4 rw " \
+ "rootfstype=jffs2\0" \
+ "loadbootscript=fatload mmc 0 ${loadaddr} boot.scr\0" \
+diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
+index dee0417..2f8a952 100644
+--- a/include/configs/omap3_beagle.h
++++ b/include/configs/omap3_beagle.h
+@@ -149,14 +149,21 @@
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+ "loadaddr=0x82000000\0" \
+ "console=ttyS2,115200n8\0" \
+- "videomode=1024x768@60,vxres=1024,vyres=768\0" \
+- "videospec=omapfb:vram:2M,vram:4M\0" \
++ "vram=12M\0" \
++ "dvimode=1024x768MR-16@60\0" \
++ "defaultdisplay=dvi\0" \
+ "mmcargs=setenv bootargs console=${console} " \
+- "video=${videospec},mode:${videomode} " \
++ "vram=${vram} " \
++ "omapfb.mode=dvi:${dvimode} " \
++ "omapfb.debug=y " \
++ "omapdss.def_disp=${defaultdisplay} " \
+ "root=/dev/mmcblk0p2 rw " \
+ "rootfstype=ext3 rootwait\0" \
+ "nandargs=setenv bootargs console=${console} " \
+- "video=${videospec},mode:${videomode} " \
++ "vram=${vram} " \
++ "omapfb.mode=dvi:${dvimode} " \
++ "omapfb.debug=y " \
++ "omapdss.def_disp=${defaultdisplay} " \
+ "root=/dev/mtdblock4 rw " \
+ "rootfstype=jffs2\0" \
+ "loadbootscript=fatload mmc 0 ${loadaddr} boot.scr\0" \
+
diff --git a/recipes/u-boot/files/fw-env.patch b/recipes/u-boot/files/fw-env.patch
new file mode 100644
index 0000000000..f3dd33597b
--- /dev/null
+++ b/recipes/u-boot/files/fw-env.patch
@@ -0,0 +1,12 @@
+--- git/tools/env/fw_env.config.orig 2009-02-04 09:42:50.000000000 -0700
++++ git/tools/env/fw_env.config 2009-02-04 14:25:09.000000000 -0700
+@@ -4,8 +4,4 @@
+ # Notice, that the "Number of sectors" is ignored on NOR.
+
+ # MTD device name Device offset Env. size Flash sector size Number of sectors
+-/dev/mtd1 0x0000 0x4000 0x4000
+-/dev/mtd2 0x0000 0x4000 0x4000
+-
+-# NAND example
+-#/dev/mtd0 0x4000 0x4000 0x20000 2
++/dev/mtd2 0x0000 0x20000 0x40000
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index e5a8d5d327..4b5d5af710 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -9,9 +9,12 @@ SRCREV_spitz = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
SRCREV_c7x0 = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
SRCREV_afeb9260 = "2077e348c2a84901022ad95311b47b70361e6daa"
-SRC_URI_beagleboard = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3-dev;protocol=git"
-SRCREV_beagleboard = "b7038cff739684bb95853eb5bee924c2574a222e"
-PV_beagleboard = "2008.10+${PR}+gitr${SRCREV}"
+SRC_URI_beagleboard = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git \
+ file://fw-env.patch;patch=1 \
+ file://dss2.patch;patch=1 \
+"
+SRCREV_beagleboard = "2dea1db2a3b7c12ed70bbf8ee50755089c5e5170"
+PV_beagleboard = "2009.03+${PR}+gitr${SRCREV}"
SRC_URI_omap3evm = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3;protocol=git"
SRCREV_omap3evm = "1e329ec630b31803ee191d2ee335214662b5bfea"
@@ -21,6 +24,13 @@ SRC_URI_omapzoom = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3-dev;
SRCREV_omapzoom = "d691b424f1f5bf7eea3a4131dfc578d272e8f335"
PV_omapzoom = "2009.01+${PR}+gitr${SRCREV}"
+SRC_URI_overo = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;protocol=git \
+ file://fw-env.patch;patch=1 \
+ file://dss2.patch;patch=1 \
+"
+SRCREV_overo = "2dea1db2a3b7c12ed70bbf8ee50755089c5e5170"
+PV_overo = "2009.03+${PR}+gitr${SRCREV}"
+
SRC_URI_neuros-osd2 = "git://github.com/neuros/u-boot.git;protocol=git;branch=neuros"
SRCREV_neuros-osd2 = "8de979d346624c0e4cfe2e5c0f08ce20ca4b5d14"