aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-03-01 20:50:48 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-03-01 21:41:00 +0100
commit23009a6ecf56c342b3c3f9438630a5912428824b (patch)
tree3cfd37c6321cd0e123d4be148c57a256f2c07794 /recipes/u-boot
parented51f18cdea6fc03cad172235b6964369ddaf248 (diff)
downloadopenembedded-23009a6ecf56c342b3c3f9438630a5912428824b.tar.gz
u-boot: removed environment patches
removed 0006-cmd_itest.c-also-support-environment-variables-as-a.patch this one was rejected upstream as the functionality was already in hush reworked 0007-cmd_setexpr-allow-memory-addresses-and-env-vars-in-e.patch the setenv part was rejected upstream as the functionality was already in hush took that part out of the patch. u-boot-git.bb: bumped PR Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot-git/0006-cmd_itest.c-also-support-environment-variables-as-a.patch39
-rw-r--r--recipes/u-boot/u-boot-git/0007-cmd_setexpr-allow-memory-addresses-and-env-vars-in-e.patch6
-rw-r--r--recipes/u-boot/u-boot_git.bb3
3 files changed, 2 insertions, 46 deletions
diff --git a/recipes/u-boot/u-boot-git/0006-cmd_itest.c-also-support-environment-variables-as-a.patch b/recipes/u-boot/u-boot-git/0006-cmd_itest.c-also-support-environment-variables-as-a.patch
deleted file mode 100644
index fc77736f8a..0000000000
--- a/recipes/u-boot/u-boot-git/0006-cmd_itest.c-also-support-environment-variables-as-a.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 11e8b9d3df819406049b36bed2f3fcf43ddd7f12 Mon Sep 17 00:00:00 2001
-From: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-Date: Wed, 24 Feb 2010 15:33:29 +0100
-Subject: [PATCH] cmd_itest.c: also support environment variables as arguments
-
-Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
----
- common/cmd_itest.c | 8 ++++++++
- 1 files changed, 8 insertions(+), 0 deletions(-)
-
-diff --git a/common/cmd_itest.c b/common/cmd_itest.c
-index 58c5e7b..78a4082 100644
---- a/common/cmd_itest.c
-+++ b/common/cmd_itest.c
-@@ -69,6 +69,10 @@ static long evalexp(char *s, int w)
- long l = 0;
- long *p;
-
-+ /* if the parameter starts with a $ replace it with the environment value */
-+ if (s[0] == '$') {
-+ s = getenv(&s[1]);
-+ }
- /* if the parameter starts with a * then assume is a pointer to the value we want */
- if (s[0] == '*') {
- p = (long *)simple_strtoul(&s[1], NULL, 16);
-@@ -86,6 +90,10 @@ static long evalexp(char *s, int w)
-
- static char * evalstr(char *s)
- {
-+ /* if the parameter starts with a $ replace it with the environment value */
-+ if (s[0] == '$') {
-+ s = getenv(&s[1]);
-+ }
- /* if the parameter starts with a * then assume a string pointer else its a literal */
- if (s[0] == '*') {
- return (char *)simple_strtoul(&s[1], NULL, 16);
---
-1.5.4.3
-
diff --git a/recipes/u-boot/u-boot-git/0007-cmd_setexpr-allow-memory-addresses-and-env-vars-in-e.patch b/recipes/u-boot/u-boot-git/0007-cmd_setexpr-allow-memory-addresses-and-env-vars-in-e.patch
index 10fc4735a2..13408657b4 100644
--- a/recipes/u-boot/u-boot-git/0007-cmd_setexpr-allow-memory-addresses-and-env-vars-in-e.patch
+++ b/recipes/u-boot/u-boot-git/0007-cmd_setexpr-allow-memory-addresses-and-env-vars-in-e.patch
@@ -32,7 +32,7 @@ diff --git a/common/cmd_setexpr.c b/common/cmd_setexpr.c
index f8b5d4d..a7c6f53 100644
--- a/common/cmd_setexpr.c
+++ b/common/cmd_setexpr.c
-@@ -28,10 +28,32 @@
+@@ -28,10 +28,28 @@
#include <config.h>
#include <command.h>
@@ -40,10 +40,6 @@ index f8b5d4d..a7c6f53 100644
+{
+ ulong *p;
+
-+ /* if the parameter starts with a $ replace it with the environment value */
-+ if (s[0] == '$') {
-+ s = getenv(&s[1]);
-+ }
+ /* if the parameter starts with a * then assume is a pointer to the value we want */
+ if (s[0] == '*') {
+ p = (ulong *)simple_strtoul(&s[1], NULL, 16);
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 3c65a1e297..b63edbdf67 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r41"
+PR ="r42"
FILESPATHPKG =. "u-boot-git:"
@@ -43,7 +43,6 @@ SRC_URI_calamari = " \
file://0003-cmd_i2c.c-reworked-subcommand-handling.patch;patch=1 \
file://0004-cmd_i2c.c-sorted-commands-alphabetically.patch;patch=1 \
file://0005-cmd_i2c.c-added-i2c-read-to-memory-function.patch;patch=1 \
- file://0006-cmd_itest.c-also-support-environment-variables-as-a.patch;patch=1 \
file://0007-cmd_setexpr-allow-memory-addresses-and-env-vars-in-e.patch;patch=1 \
"