aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-10-30 11:38:49 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-10-30 11:41:54 +0100
commit04bf7d5d151173ac058f4aff2e4be3ae0f98216e (patch)
treec163b87befc5bc633cafc614c87ebaf6ae4ed717 /recipes/u-boot
parent5da5ee1a5708f9a30c61636f29548acd3a4ae02c (diff)
downloadopenembedded-04bf7d5d151173ac058f4aff2e4be3ae0f98216e.tar.gz
u-boot: added Sheevaplug support
Marvell devices needs u-boot.kwb instead of u-boot.bin due to header for first stage bootloader. UBOOT_BINARY variable was introduced due of that.
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot.inc3
-rw-r--r--recipes/u-boot/u-boot_git.bb13
2 files changed, 14 insertions, 2 deletions
diff --git a/recipes/u-boot/u-boot.inc b/recipes/u-boot/u-boot.inc
index 8ab0282743..6fdbaac87f 100644
--- a/recipes/u-boot/u-boot.inc
+++ b/recipes/u-boot/u-boot.inc
@@ -13,6 +13,7 @@ PARALLEL_MAKE=""
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
UBOOT_MACHINE ?= "${MACHINE}_config"
+UBOOT_BINARY ?= "u-boot.bin"
UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
UBOOT_SYMLINK ?= "u-boot-${MACHINE}.bin"
@@ -39,7 +40,7 @@ do_install () {
do_deploy () {
install -d ${DEPLOY_DIR_IMAGE}
- install ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}
+ install ${S}/${UBOOT_BINARY} ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}
cd ${DEPLOY_DIR_IMAGE}
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 15c3060a39..59c0598f97 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r32"
+PR ="r33"
FILESPATHPKG =. "u-boot-git:"
@@ -143,6 +143,9 @@ SRC_URI_append_c7x0 = "file://pdaXrom-u-boot.patch;patch=1 \
file://uboot-eabi-fix-HACK2.patch;patch=1 \
file://corgi-standard-partitioning.patch;patch=1 \
"
+SRC_URI_sheevaplug = "git://git.denx.de/u-boot-marvell.git;protocol=git;branch=testing"
+SRCREV_sheevaplug = "119b9942da2e450d4e525fc004208dd7f7d062e0"
+
S = "${WORKDIR}/git"
@@ -158,6 +161,14 @@ do_configure_prepend_c7x0() {
sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/corgi.h
}
+do_compile_append_sheevaplug() {
+ oe_runmake u-boot.kwb
+}
+
+UBOOT_IMAGE_sheevaplug = "u-boot-${MACHINE}-${PV}-${PR}.kwb"
+UBOOT_BINARY_sheevaplug = "u-boot.kwb"
+UBOOT_SYMLINK_sheevaplug ?= "u-boot-${MACHINE}.kwb"
+
do_deploy_prepend_mini2440() {
cp ${S}/u-boot-nand16k.bin ${S}/u-boot.bin
}