aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tslib
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-01-12 13:49:03 +0000
committerKhem Raj <raj.khem@gmail.com>2011-01-15 16:00:35 -0800
commit390e8cd69ee11bcc8a10ea3d887a386eab2579cb (patch)
treecaed4582a037e29d9120eed2e7e20671cf85c277 /recipes/tslib
parentd2b56c403a27cbc8e02654caed132ab4695a2ea9 (diff)
downloadopenembedded-390e8cd69ee11bcc8a10ea3d887a386eab2579cb.tar.gz
tslib: relax EV_VERSION check as 2.6.37 has slightly newer EV_VERSION, but works ok without tslib changes
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/tslib')
-rw-r--r--recipes/tslib/tslib/0001-relax-EV_VERSION-check-fail-only-if-version-of-runni.patch25
-rw-r--r--recipes/tslib/tslib_git.bb5
2 files changed, 28 insertions, 2 deletions
diff --git a/recipes/tslib/tslib/0001-relax-EV_VERSION-check-fail-only-if-version-of-runni.patch b/recipes/tslib/tslib/0001-relax-EV_VERSION-check-fail-only-if-version-of-runni.patch
new file mode 100644
index 0000000000..2ff1e0a15c
--- /dev/null
+++ b/recipes/tslib/tslib/0001-relax-EV_VERSION-check-fail-only-if-version-of-runni.patch
@@ -0,0 +1,25 @@
+From cdf285aa7cbcc7de9ad5a8bf4c053372153f4242 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Wed, 12 Jan 2011 14:36:35 +0100
+Subject: [PATCH] relax EV_VERSION check, fail only if version of running kernel is lower than EV_VERSION from kernel headers
+
+---
+ plugins/input-raw.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/plugins/input-raw.c b/plugins/input-raw.c
+index 9511a0d..4396eab 100644
+--- a/plugins/input-raw.c
++++ b/plugins/input-raw.c
+@@ -78,7 +78,7 @@ static int check_fd(struct tslib_input *i)
+ return -1;
+ }
+
+- if (version != EV_VERSION) {
++ if (version < EV_VERSION) {
+ fprintf(stderr, "tslib: Selected device uses a different version of the event protocol than tslib was compiled for\n");
+ return -1;
+ }
+--
+1.7.4.rc1
+
diff --git a/recipes/tslib/tslib_git.bb b/recipes/tslib/tslib_git.bb
index 7c373957d7..74e17c3bf7 100644
--- a/recipes/tslib/tslib_git.bb
+++ b/recipes/tslib/tslib_git.bb
@@ -1,8 +1,9 @@
-SRC_URI = "git://github.com/kergoth/tslib.git;protocol=git"
+SRC_URI = "git://github.com/kergoth/tslib.git;protocol=git \
+ file://0001-relax-EV_VERSION-check-fail-only-if-version-of-runni.patch"
S = "${WORKDIR}/git"
SRCREV = "860d69cadedef0dec8ba6259ab5850691d3402e7"
PV = "1.0+gitr${SRCPV}"
-PR = "${INC_PR}.4"
+PR = "${INC_PR}.5"
DEFAULT_PREFERENCE = "-1"