aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/totem
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/totem
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/totem')
-rw-r--r--recipes/totem/files/cflags.patch33
-rw-r--r--recipes/totem/files/gtkonly.patch38
-rw-r--r--recipes/totem/files/include.patch11
-rw-r--r--recipes/totem/files/intl.patch33
-rw-r--r--recipes/totem/files/nonautilus.patch16
-rw-r--r--recipes/totem/files/omf.patch13
-rw-r--r--recipes/totem/totem-2.24.2/gst-detect.diff28
-rw-r--r--recipes/totem/totem-pl-parser_2.23.3.bb15
-rw-r--r--recipes/totem/totem-pl-parser_2.24.1.bb15
-rw-r--r--recipes/totem/totem/gst-detect.diff37
-rw-r--r--recipes/totem/totem_0.99.15.bb30
-rw-r--r--recipes/totem/totem_1.0.4.bb33
-rw-r--r--recipes/totem/totem_2.23.4.bb72
-rw-r--r--recipes/totem/totem_2.24.2.bb70
14 files changed, 444 insertions, 0 deletions
diff --git a/recipes/totem/files/cflags.patch b/recipes/totem/files/cflags.patch
new file mode 100644
index 0000000000..a03247332f
--- /dev/null
+++ b/recipes/totem/files/cflags.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- totem-1.0.4/src/Makefile.am~cflags
++++ totem-1.0.4/src/Makefile.am
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = bvw-test list_v4l test-parser disc-test metadata-test
++#noinst_PROGRAMS = bvw-test list_v4l test-parser disc-test metadata-test
+
+ if TOTEM_VANITY
+ VANITY=vanity
+@@ -179,8 +179,10 @@
+ list_v4l_SOURCES = list_v4l.c $(BACON_V4L_SELECTION)
+ list_v4l_LDADD = $(GTK_LIBS)
+
++test_parser_CFLAGS = $(TOTEM_PLPARSER_CFLAGS)
+ test_parser_SOURCES = test-parser.c
+ test_parser_LDADD = \
++ $(TOTEM_PLPARSER_LIBS)
+ $(EXTRA_GNOME_LIBS) \
+ libtotem-plparser.la
+
+@@ -224,6 +226,8 @@
+ totem-disc.h \
+ totem-pl-parser.h
+
++libtotem_plparser_la_CFLAGS = $(TOTEM_PLPARSER_CFLAGS)
++
+ libtotem_plparser_la_LDFLAGS = \
+ -version-info $(PLPARSER_LT_VERSION) \
+ -no-undefined \
diff --git a/recipes/totem/files/gtkonly.patch b/recipes/totem/files/gtkonly.patch
new file mode 100644
index 0000000000..8a7fbd2a0b
--- /dev/null
+++ b/recipes/totem/files/gtkonly.patch
@@ -0,0 +1,38 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- totem-1.0.4/src/totem.c~gtkonly
++++ totem-1.0.4/src/totem.c
+@@ -1667,8 +1667,10 @@
+ totem_action_set_mrl_and_play (totem, mrl);
+ g_free (mrl);
+
++#ifndef HAVE_GTK_ONLY
+ gnome_entry_append_history (GNOME_ENTRY (gentry),
+ TRUE, uri);
++#endif
+ }
+ }
+
+@@ -3593,7 +3595,9 @@
+ /* Properties */
+ totem->properties = bacon_video_widget_properties_new ();
+
++#ifndef HAVE_GTK_ONLY
+ totem_session_setup (totem, argv);
++#endif
+ totem_setup_recent (totem);
+ totem_callback_connect (totem);
+ totem_setup_window (totem);
+@@ -3617,7 +3621,9 @@
+ /* Command-line handling */
+ if (totem_options_process_late (totem, &argc, &argv) != FALSE)
+ {
++#ifndef HAVE_GTK_ONLY
+ totem_session_restore (totem, argv);
++#endif
+ } else if (argc >= 1 && totem_action_open_files (totem, argv)) {
+ totem_action_play_pause (totem);
+ } else {
diff --git a/recipes/totem/files/include.patch b/recipes/totem/files/include.patch
new file mode 100644
index 0000000000..6e99c4e21e
--- /dev/null
+++ b/recipes/totem/files/include.patch
@@ -0,0 +1,11 @@
+--- totem-0.99.15/src/video-utils.c 2004-07-03 16:54:31.000000000 -0700
++++ totem-0.99.15.new/src/video-utils.c 2004-08-04 11:03:30.822669856 -0700
+@@ -4,7 +4,7 @@
+ #include "video-utils.h"
+
+ #include <glib/gi18n.h>
+-#include <libintl.h>
++/* #include <libintl.h> */
+
+ #include <gdk/gdk.h>
+ #include <gdk/gdkx.h>
diff --git a/recipes/totem/files/intl.patch b/recipes/totem/files/intl.patch
new file mode 100644
index 0000000000..2a1a32cc2d
--- /dev/null
+++ b/recipes/totem/files/intl.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- totem-1.0.4/src/totem.c~intl
++++ totem-1.0.4/src/totem.c
+@@ -35,6 +35,25 @@
+ #include <gtk/gtk.h>
+ #include <gdk/gdkkeysyms.h>
+ #include <stdlib.h>
++#ifdef ENABLE_NLS
++# include <libintl.h>
++# define _(String) dgettext (GETTEXT_PACKAGE, String)
++# ifdef gettext_noop
++# define N_(String) gettext_noop (String)
++# else
++# define N_(String) (String)
++# endif
++#else
++/* Stubs that do something close enough. */
++# define textdomain(String) (String)
++# define gettext(String) (String)
++# define dgettext(Domain,Message) (Message)
++# define dcgettext(Domain,Message,Type) (Message)
++# define ngettext(Singular, Plural, IsPlural) (Singular)
++# define bindtextdomain(Domain,Directory) (Domain)
++# define _(String) (String)
++# define N_(String) (String)
++#endif
+ #endif /* !HAVE_GTK_ONLY */
+
+ #include <string.h>
diff --git a/recipes/totem/files/nonautilus.patch b/recipes/totem/files/nonautilus.patch
new file mode 100644
index 0000000000..3cfce7c9aa
--- /dev/null
+++ b/recipes/totem/files/nonautilus.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- totem-1.0.4/configure.in~nonautilus
++++ totem-1.0.4/configure.in
+@@ -144,7 +144,7 @@
+ PKG_CHECK_MODULES(EXTRA_GNOME, glib-2.0 >= 2.6.3 gtk+-2.0 >= 2.5.6 libgnomeui-2.0 >= 2.3.3 libglade-2.0 gnome-vfs-2.0 >= 2.1.6 gnome-vfs-module-2.0 >= 2.1.6 gnome-desktop-2.0 >= 2.1.5 $MM)
+ HAVE_GNOME=yes
+ else
+- PKG_CHECK_MODULES(EXTRA_GNOME, glib-2.0 >= 2.6.3 gtk+-2.0 >= 2.5.6 libglade-2.0 gnome-vfs-2.0 >= 2.1.6 gnome-vfs-module-2.0 >= 2.1.6 libnautilus-burn >= 2.9.0 $MM)
++ PKG_CHECK_MODULES(EXTRA_GNOME, glib-2.0 >= 2.6.3 gtk+-2.0 >= 2.5.6 libglade-2.0 gnome-vfs-2.0 >= 2.1.6 gnome-vfs-module-2.0 >= 2.1.6 $MM)
+ AC_DEFINE(USE_STABLE_LIBGNOMEUI, 1, [defined if we don't have GNOME])
+ AC_DEFINE(HAVE_GTK_ONLY, 1, [defined if GNOME isn't used])
+ HAVE_GNOME=no
diff --git a/recipes/totem/files/omf.patch b/recipes/totem/files/omf.patch
new file mode 100644
index 0000000000..a889db10ba
--- /dev/null
+++ b/recipes/totem/files/omf.patch
@@ -0,0 +1,13 @@
+--- totem-0.99.12/omf.make 2003-11-08 18:04:41.000000000 -0700
++++ totem-0.99.12.new/omf.make 2004-06-30 09:39:58.765495480 -0700
+@@ -41,7 +41,9 @@
+ install-data-hook-omf:
+ $(mkinstalldirs) $(DESTDIR)$(omf_dest_dir)
+ for file in $(omffile); do \
+- $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
++ if [ -f $$file.out ]; then \
++ $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
++ fi; \
+ done
+ -scrollkeeper-update -o $(DESTDIR)$(omf_dest_dir)
+
diff --git a/recipes/totem/totem-2.24.2/gst-detect.diff b/recipes/totem/totem-2.24.2/gst-detect.diff
new file mode 100644
index 0000000000..57c2a3cedf
--- /dev/null
+++ b/recipes/totem/totem-2.24.2/gst-detect.diff
@@ -0,0 +1,28 @@
+--- /tmp/configure.in 2008-08-10 15:27:06.000000000 +0200
++++ totem-2.23.4/configure.in 2008-08-10 20:37:08.743198000 +0200
+@@ -142,11 +142,7 @@
+ if $gst010_inspect $base_element >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT([yes])
+ else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$base_element'.
+- It should be part of gst-plugins-base. Please install it.
+- ])
++ AC_MSG_RESULT([yes, we assume OE has already built them])
+ fi
+ done
+
+@@ -157,11 +153,7 @@
+ if $gst010_inspect $good_element >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT([yes])
+ else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$good_element'.
+- It should be part of gst-plugins-good. Please install it.
+- ])
++ AC_MSG_RESULT([yes, we assume OE has already built them])
+ fi
+ done
+
diff --git a/recipes/totem/totem-pl-parser_2.23.3.bb b/recipes/totem/totem-pl-parser_2.23.3.bb
new file mode 100644
index 0000000000..7f3cd861e9
--- /dev/null
+++ b/recipes/totem/totem-pl-parser_2.23.3.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Playlist parser for Totem, a GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+DEPENDS = "eds-dbus"
+
+inherit gnome
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/totem/totem-pl-parser_2.24.1.bb b/recipes/totem/totem-pl-parser_2.24.1.bb
new file mode 100644
index 0000000000..7f3cd861e9
--- /dev/null
+++ b/recipes/totem/totem-pl-parser_2.24.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Playlist parser for Totem, a GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+DEPENDS = "eds-dbus"
+
+inherit gnome
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/totem/totem/gst-detect.diff b/recipes/totem/totem/gst-detect.diff
new file mode 100644
index 0000000000..6d37515995
--- /dev/null
+++ b/recipes/totem/totem/gst-detect.diff
@@ -0,0 +1,37 @@
+--- /tmp/configure.in 2008-08-10 15:27:06.000000000 +0200
++++ totem-2.23.4/configure.in 2008-08-10 20:37:08.743198000 +0200
+@@ -142,11 +142,7 @@
+ if $gst010_inspect $base_element >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT([yes])
+ else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$base_element'.
+- It should be part of gst-plugins-base. Please install it.
+- ])
++ AC_MSG_RESULT([yes, we assume OE has already built them])
+ fi
+ done
+
+@@ -157,11 +153,7 @@
+ if $gst010_inspect $good_element >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT([yes])
+ else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$good_element'.
+- It should be part of gst-plugins-good. Please install it.
+- ])
++ AC_MSG_RESULT([yes, we assume OE has already built them])
+ fi
+ done
+
+@@ -565,7 +557,7 @@
+ fi
+ ;;
+ mythtv)
+- PKG_CHECK_MODULES(GMYTH, gmyth >= 0.7 gmyth-upnp >= 0.7.1,
++ PKG_CHECK_MODULES(GMYTH, gmyth >= 0.7.0 gmyth-upnp,
+ [HAVE_GMYTH=yes], [HAVE_GMYTH=no])
+ if test "${HAVE_GMYTH}" != "yes"; then
+ plugin_error_or_ignore "you need GMyth >= 0.7 installed for the MythTV plugin"
diff --git a/recipes/totem/totem_0.99.15.bb b/recipes/totem/totem_0.99.15.bb
new file mode 100644
index 0000000000..3defdaebe6
--- /dev/null
+++ b/recipes/totem/totem_0.99.15.bb
@@ -0,0 +1,30 @@
+SECTION = "x11/multimedia"
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A GTK2 based media player"
+HOMEPAGE="http://www.hadess.net/totem.php3"
+LICENSE="GPL"
+
+SRC_URI="http://ftp.acc.umu.se/pub/GNOME/sources/totem/0.99/totem-${PV}.tar.gz \
+ file://include.patch;patch=1 \
+ file://omf.patch;patch=1"
+
+DEPENDS="gtk+ libglade gnome-vfs gconf libxine-x11 libgnomeui"
+RDEPENDS += " libgnomeui"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
+
+#SELECTED_OPTIMIZATION="-O0 -g"
+LDFLAGS_append = " -Wl,--export-dynamic"
+
+pkg_postinst_totem() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi;
+SOURCE=`gconftool-2 --get-default-source`
+GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
+/etc/gconf/schemas/totem.schemas > /dev/null
+}
diff --git a/recipes/totem/totem_1.0.4.bb b/recipes/totem/totem_1.0.4.bb
new file mode 100644
index 0000000000..a12f307ffa
--- /dev/null
+++ b/recipes/totem/totem_1.0.4.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/multimedia"
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A GTK2 based media player"
+HOMEPAGE="http://www.gnome.org/projects/totem/"
+LICENSE="GPL"
+
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/totem/1.0/totem-${PV}.tar.gz \
+ file://include.patch;patch=1 \
+ file://omf.patch;patch=1 \
+ file://nonautilus.patch;patch=1 \
+ file://intl.patch;patch=1 \
+ file://cflags.patch;patch=1 \
+ file://gtkonly.patch;patch=1"
+
+DEPENDS="gtk+ libglade gnome-vfs gconf libxine-x11 libxml2"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
+
+#SELECTED_OPTIMIZATION="-O0 -g"
+LDFLAGS_append = " -Wl,--export-dynamic"
+
+pkg_postinst_totem() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi;
+SOURCE=`gconftool-2 --get-default-source`
+GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
+/etc/gconf/schemas/totem.schemas > /dev/null
+}
diff --git a/recipes/totem/totem_2.23.4.bb b/recipes/totem/totem_2.23.4.bb
new file mode 100644
index 0000000000..f2e945fd87
--- /dev/null
+++ b/recipes/totem/totem_2.23.4.bb
@@ -0,0 +1,72 @@
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "A GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+PR = "r3"
+
+DEPENDS = " totem-pl-parser gtk+ dbus bluez-libs libglade gconf libxml2 gst-ffmpeg gst-plugins-bad gst-plugins-base"
+RDEPENDS_${PN} += "iso-codes"
+RRECOMMENDS_${PN} += "gst-plugin-playbin \
+ gst-plugin-gconfelements \
+ gst-plugin-decodebin \
+ gst-plugin-decodebin2 \
+ gst-ffmpeg \
+ gst-plugin-audioresample \
+ gst-plugin-ximagesink \
+ gst-plugin-xvimagesink \
+ gst-plugin-alsa \
+ gst-plugin-avi \
+ gst-plugin-ffmpegcolorspace \
+ gst-plugin-flvdemux \
+ gst-plugin-nuvdemux \
+ gst-plugin-videoscale \
+ gst-plugin-a52dec \
+ gst-plugin-mpegaudioparse \
+ gst-plugin-ossaudio \
+ gst-plugin-pulse \
+ gst-plugin-autodetect \
+ "
+
+inherit gnome
+
+SRC_URI += "file://gst-detect.diff;patch=1"
+
+EXTRA_OECONF=" --disable-schemas-install \
+ --enable-gtk \
+ --disable-iso-codes \
+ --disable-debug \
+ --enable-gstreamer \
+ --enable-browser-plugins \
+ --disable-run-in-source-tree \
+ --disable-python \
+ --disable-vala \
+ --with-dbus \
+ "
+
+do_configure_prepend() {
+ sed -i -e s:help::g ${S}/Makefile.am
+}
+
+PACKAGES += "totem-plugin-bemused totem-plugin-gromit totem-plugin-lirc totem-plugin-media-player-keys totem-plugin-mythtv totem-plugin-ontop totem-plugin-properties totem-plugin-screensaver totem-plugin-skipto totem-plugin-thumbnail totem-plugin-youtube totem-browser-plugin-dbg totem-browser-plugin"
+
+FILES_totem-plugin-bemused += "${libdir}/totem/plugins/bemused/*"
+FILES_totem-plugin-gromit += "${libdir}/totem/plugins/gromit/*"
+FILES_totem-plugin-lirc += "${libdir}/totem/plugins/lirc/*"
+FILES_totem-plugin-media-player-keys += "${libdir}/totem/plugins/media-player-keys/*"
+FILES_totem-plugin-mythtv += "${libdir}/totem/plugins/mythtv/*"
+FILES_totem-plugin-ontop += "${libdir}/totem/plugins/ontop/*"
+FILES_totem-plugin-properties += "${libdir}/totem/plugins/properties/*"
+FILES_totem-plugin-screensaver += "${libdir}/totem/plugins/screensaver/*"
+FILES_totem-plugin-skipto += "${libdir}/totem/plugins/skipto/*"
+FILES_totem-plugin-thumbnail += "${libdir}/totem/plugins/thumbnail/*"
+FILES_totem-plugin-youtube += "${libdir}/totem/plugins/youtube/*"
+
+FILES_${PN} = "${bindir}/* ${sysconfdir} ${libdir}/lib*.so.* ${libexecdir} ${datadir}/icons ${datadir}/totem ${datadir}/applications"
+FILES_${PN}-dbg += "${libdir}/totem/plugins/*/.debug"
+FILES_${PN}-dev += "${libdir}/totem/plugins/*/*a"
+FILES_totem-browser-plugin-dbg += "${libdir}/mozilla/plugins/.debug"
+FILES_totem-browser-plugin += "${libdir}/mozilla/plugins/"
diff --git a/recipes/totem/totem_2.24.2.bb b/recipes/totem/totem_2.24.2.bb
new file mode 100644
index 0000000000..a0de5705cf
--- /dev/null
+++ b/recipes/totem/totem_2.24.2.bb
@@ -0,0 +1,70 @@
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "A GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+DEPENDS = " totem-pl-parser gtk+ dbus bluez-libs libglade gconf libxml2 gst-ffmpeg gst-plugins-bad gst-plugins-base"
+RDEPENDS_${PN} += "iso-codes"
+RRECOMMENDS_${PN} += "gst-plugin-playbin \
+ gst-plugin-gconfelements \
+ gst-plugin-decodebin \
+ gst-plugin-decodebin2 \
+ gst-ffmpeg \
+ gst-plugin-audioresample \
+ gst-plugin-ximagesink \
+ gst-plugin-xvimagesink \
+ gst-plugin-alsa \
+ gst-plugin-avi \
+ gst-plugin-ffmpegcolorspace \
+ gst-plugin-flvdemux \
+ gst-plugin-nuvdemux \
+ gst-plugin-videoscale \
+ gst-plugin-a52dec \
+ gst-plugin-mpegaudioparse \
+ gst-plugin-ossaudio \
+ gst-plugin-pulse \
+ gst-plugin-autodetect \
+ "
+
+inherit gnome
+
+SRC_URI += "file://gst-detect.diff;patch=1"
+
+EXTRA_OECONF=" --disable-schemas-install \
+ --enable-gtk \
+ --disable-iso-codes \
+ --disable-debug \
+ --enable-gstreamer \
+ --enable-browser-plugins \
+ --disable-run-in-source-tree \
+ --disable-python \
+ --disable-vala \
+ --with-dbus \
+ "
+
+do_configure_prepend() {
+ sed -i -e s:help::g ${S}/Makefile.am
+}
+
+PACKAGES += "totem-plugin-bemused totem-plugin-gromit totem-plugin-lirc totem-plugin-media-player-keys totem-plugin-mythtv totem-plugin-ontop totem-plugin-properties totem-plugin-screensaver totem-plugin-skipto totem-plugin-thumbnail totem-plugin-youtube totem-browser-plugin-dbg totem-browser-plugin"
+
+FILES_totem-plugin-bemused += "${libdir}/totem/plugins/bemused/*"
+FILES_totem-plugin-gromit += "${libdir}/totem/plugins/gromit/*"
+FILES_totem-plugin-lirc += "${libdir}/totem/plugins/lirc/*"
+FILES_totem-plugin-media-player-keys += "${libdir}/totem/plugins/media-player-keys/*"
+FILES_totem-plugin-mythtv += "${libdir}/totem/plugins/mythtv/*"
+FILES_totem-plugin-ontop += "${libdir}/totem/plugins/ontop/*"
+FILES_totem-plugin-properties += "${libdir}/totem/plugins/properties/*"
+FILES_totem-plugin-screensaver += "${libdir}/totem/plugins/screensaver/*"
+FILES_totem-plugin-skipto += "${libdir}/totem/plugins/skipto/*"
+FILES_totem-plugin-thumbnail += "${libdir}/totem/plugins/thumbnail/*"
+FILES_totem-plugin-youtube += "${libdir}/totem/plugins/youtube/*"
+
+FILES_${PN} = "${bindir}/* ${sysconfdir} ${libdir}/lib*.so.* ${libexecdir} ${datadir}/icons ${datadir}/totem ${datadir}/applications"
+FILES_${PN}-dbg += "${libdir}/totem/plugins/*/.debug"
+FILES_${PN}-dev += "${libdir}/totem/plugins/*/*a"
+FILES_totem-browser-plugin-dbg += "${libdir}/mozilla/plugins/.debug"
+FILES_totem-browser-plugin += "${libdir}/mozilla/plugins/"