aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tar/tar_1.20.bb
diff options
context:
space:
mode:
authorChris Larson <clarson@mvista.com>2009-08-11 11:16:09 -0700
committerChris Larson <clarson@mvista.com>2009-08-20 12:25:01 -0700
commitf2442f18ecdb310750195753f8c122f2cd81e364 (patch)
tree68f6be24c195c3065727f3201ac722933447db5f /recipes/tar/tar_1.20.bb
parentdf0c1f671b493f6300e51b5b4c7d41956f486d62 (diff)
downloadopenembedded-f2442f18ecdb310750195753f8c122f2cd81e364.tar.gz
tar: inherit gettext & use a .inc to avoid duplicated metadata.
Signed-off-by: Chris Larson <clarson@mvista.com>
Diffstat (limited to 'recipes/tar/tar_1.20.bb')
-rw-r--r--recipes/tar/tar_1.20.bb26
1 files changed, 1 insertions, 25 deletions
diff --git a/recipes/tar/tar_1.20.bb b/recipes/tar/tar_1.20.bb
index 701c0b77bf..25163acdad 100644
--- a/recipes/tar/tar_1.20.bb
+++ b/recipes/tar/tar_1.20.bb
@@ -1,25 +1 @@
-DESCRIPTION = "GNU tar saves many files together into a single tape \
-or disk archive, and can restore individual files from the archive."
-SECTION = "base"
-LICENSE = "GPLv3"
-
-SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2"
-
-inherit autotools
-
-do_install () {
- autotools_do_install
- install -d ${D}${base_bindir}
- mv ${D}${bindir}/tar ${D}${base_bindir}/tar.${PN}
- mv ${D}${libexecdir}/rmt ${D}${libexecdir}/rmt.${PN}
-}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${base_bindir}/tar tar tar.${PN} 100
- update-alternatives --install ${libexecdir}/rmt rmt rmt.${PN} 100
-}
-
-pkg_prerm_${PN} () {
- update-alternatives --remove tar tar.${PN}
- update-alternatives --remove rmt rmt.${PN}
-}
+require tar.inc