aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/syslog-ng
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-11-30 17:06:57 +1030
committerStefan Schmidt <stefan@buglabs.net>2010-12-02 16:47:18 +0100
commit7e9f17963ba4cd67065440d70785af17fb39defd (patch)
tree6705bf2e84abe21dbc02e7f37fdf2387d7556083 /recipes/syslog-ng
parent82749d923f255f748d10d7206ecc4b0566d879aa (diff)
downloadopenembedded-7e9f17963ba4cd67065440d70785af17fb39defd.tar.gz
syslog-ng.inc: Fix build when DISTRO_FEATURES lacks largefile and/or ipv6.
In file included from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/limits.h:27:0, from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/lib/glib-2.0/include/glibconfig.h:11, from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/glib-2.0/glib/gtypes.h:34, from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/glib-2.0/glib/galloca.h:34, from /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/glib-2.0/glib.h:32, from syslog-ng.h:37, from misc.h:27, from misc.c:24: /mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include/features.h:216:5: error: #error It appears you have defined _FILE_OFFSET_BITS=64. Unfortunately, uClibc was built without large file support enabled. | afinet.c: In function 'afinet_setup_socket': | afinet.c:205:42: error: 'IPV6_JOIN_GROUP' undeclared (first use in this function) | afinet.c:205:42: note: each undeclared identifier is reported only once for each function it appears in | afinet.c:206:42: error: 'IPV6_MULTICAST_LOOP' undeclared (first use in this function) | afinet.c:211:44: error: 'IPV6_MULTICAST_HOPS' undeclared (first use in this function) | afinet.c:217:40: error: 'IPV6_UNICAST_HOPS' undeclared (first use in this function) | afinet.c: In function 'afinet_dd_construct_ipv6_packet': | afinet.c:448:36: warning: dereferencing type-punned pointer will break strict-aliasing rules | afinet.c:449:36: warning: dereferencing type-punned pointer will break strict-aliasing rules Signed-off-by: Graham Gower <graham.gower@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/syslog-ng')
-rw-r--r--recipes/syslog-ng/syslog-ng.inc7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/syslog-ng/syslog-ng.inc b/recipes/syslog-ng/syslog-ng.inc
index f12791dddd..452dd78461 100644
--- a/recipes/syslog-ng/syslog-ng.inc
+++ b/recipes/syslog-ng/syslog-ng.inc
@@ -10,7 +10,12 @@ INC_PR = "r4"
inherit autotools
-EXTRA_OECONF = "--with-libol=${STAGING_BINDIR_CROSS}/ --enable-dynamic-linking"
+noipv6 = "${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6', d)}"
+EXTRA_OECONF = "--with-libol=${STAGING_BINDIR_CROSS}/ --enable-dynamic-linking ${noipv6}"
+
+do_configure_prepend() {
+ eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_LARGEFILE_SOURCE//" -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/configure.in', d)}"
+}
do_install_append() {
install -d ${D}/${sysconfdir}/${PN}