aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-03-01 14:49:04 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-01 16:54:16 +0100
commit517816ac3c3d43cb53569955ad6705f468da6cf4 (patch)
tree1441d4ea6930add2238dbb5bd727489d1311b3fb /recipes/shr
parent175f25a8e3032c515ee6f951115c349596b15cc0 (diff)
downloadopenembedded-517816ac3c3d43cb53569955ad6705f468da6cf4.tar.gz
initscripts-shr: create /dev/pts, /dev/shm if they doesn't exist (devtmpfs doesn't create them for us and ssh login fails later due to missing PTYs)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/initscripts-shr/mountdevsubfs.sh13
-rw-r--r--recipes/shr/initscripts-shr_0.0.1.bb2
2 files changed, 8 insertions, 7 deletions
diff --git a/recipes/shr/initscripts-shr/mountdevsubfs.sh b/recipes/shr/initscripts-shr/mountdevsubfs.sh
index c6cfb05af2..4308dab44e 100644
--- a/recipes/shr/initscripts-shr/mountdevsubfs.sh
+++ b/recipes/shr/initscripts-shr/mountdevsubfs.sh
@@ -4,11 +4,12 @@
test -c /dev/ptmx || mknod -m 666 /dev/ptmx c 5 2
-if [ -d /dev/pts ]; then
- mount -n -t devpts devpts /dev/pts -ogid=${TTYGRP},mode=${TTYMODE}
+if [ ! -d /dev/pts ]; then
+ mkdir /dev/pts
fi
-
-
-if [ -d /dev/shm ]; then
- mount -n -t tmpfs shmfs /dev/shm -omode=0777
+if [ ! -d /dev/shm ]; then
+ mkdir /dev/shm
fi
+
+mount -n -t devpts devpts /dev/pts -ogid=${TTYGRP},mode=${TTYMODE}
+mount -n -t tmpfs shmfs /dev/shm -omode=0777
diff --git a/recipes/shr/initscripts-shr_0.0.1.bb b/recipes/shr/initscripts-shr_0.0.1.bb
index 89df6ce375..ac7d83f96b 100644
--- a/recipes/shr/initscripts-shr_0.0.1.bb
+++ b/recipes/shr/initscripts-shr_0.0.1.bb
@@ -5,7 +5,7 @@ DEPENDS = ""
RDEPENDS = ""
LICENSE = "GPL"
PV = "0.0.1"
-PR = "r14"
+PR = "r15"
RPROVIDES_${PN} = "initscripts"
RCONFLICTS_${PN} = "initscripts"