aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 16:51:49 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2009-09-17 18:38:24 +0000
commit0393c7cc15c233154ea0b8add2820eabf89d63b3 (patch)
tree1088643c7e85b4e8f6e0599f05c3950afb031ca4 /recipes/shr
parent2ff4462e97f4da82b244a307b147f6e218cef1df (diff)
downloadopenembedded-0393c7cc15c233154ea0b8add2820eabf89d63b3.tar.gz
e-wm-sysactions-shr: Add recipe (from SHR)
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/e-wm-sysactions-shr_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/shr/e-wm-sysactions-shr_git.bb b/recipes/shr/e-wm-sysactions-shr_git.bb
new file mode 100644
index 0000000000..293edaeba3
--- /dev/null
+++ b/recipes/shr/e-wm-sysactions-shr_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "illume SHR sysactions config"
+SECTION = "e/utils"
+LICENSE = "MIT BSD"
+PV = "1.1-${EFL_SRCREV}-gitr${SRCREV}"
+PR = "r3"
+
+RPROVIDES_${PN} = "e-wm-sysactions"
+RCONFLICTS_${PN} = "e-wm-sysactions"
+#RREPLACES_${PN} = "e-wm-sysactions"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/e-wm/${PN}"
+
+FILES_${PN} = "${sysconfdir}/enlightenment"
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment/
+ install -m 0755 ${S}/sysactions.conf ${D}${sysconfdir}/enlightenment/sysactions.conf
+ install -m 0755 ${S}/suspend.sh ${D}${sysconfdir}/enlightenment/suspend.sh
+}