aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shorewall
diff options
context:
space:
mode:
authorDvorkin Dmitry <dvorkin@tibbo.com>2010-11-15 07:17:58 +0000
committerMichael Smith <msmith@cbnco.com>2010-11-15 13:25:55 -0500
commit3e3253ae59ec2a7e7ff06d1baed42f32ffba34b1 (patch)
tree0f8949864e61c1c147c74088e6de869ff8d61bca /recipes/shorewall
parentb79c5f4e3f9cc1ce7db90f31fbb9eb04f9be8334 (diff)
downloadopenembedded-3e3253ae59ec2a7e7ff06d1baed42f32ffba34b1.tar.gz
shorewall: updated to 4.2-shell and 4.4-perl versions
Signed-off-by: Dvorkin Dmitry <dvorkin@tibbo.com> Acked-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/shorewall')
-rw-r--r--recipes/shorewall/shorewall-deps.inc20
-rw-r--r--recipes/shorewall/shorewall-shell_4.2.11.bb14
-rw-r--r--recipes/shorewall/shorewall.inc20
-rw-r--r--recipes/shorewall/shorewall_4.4.14.bb12
4 files changed, 66 insertions, 0 deletions
diff --git a/recipes/shorewall/shorewall-deps.inc b/recipes/shorewall/shorewall-deps.inc
new file mode 100644
index 0000000000..5ad98f0425
--- /dev/null
+++ b/recipes/shorewall/shorewall-deps.inc
@@ -0,0 +1,20 @@
+
+# version 4.4.x requires perl + some perl modules
+RDEPENDS_${PN} += "\
+ perl \
+ perl-module-lib \
+ perl-module-autouse \
+ perl-module-cwd \
+ perl-module-file-basename \
+ perl-module-file-temp \
+ perl-module-getopt-long \
+ perl-module-carp \
+ perl-module-findbin \
+ perl-module-file-spec-unix \
+ perl-module-scalar-util \
+ perl-module-io \
+ perl-module-io-handle \
+ perl-module-exporter-heavy \
+ perl-module-list-util \
+ perl-module-socket \
+"
diff --git a/recipes/shorewall/shorewall-shell_4.2.11.bb b/recipes/shorewall/shorewall-shell_4.2.11.bb
new file mode 100644
index 0000000000..fc0465742f
--- /dev/null
+++ b/recipes/shorewall/shorewall-shell_4.2.11.bb
@@ -0,0 +1,14 @@
+require shorewall.inc
+
+PR = "${INC_PR}.0"
+
+# this version (4.2, legacy!) require only shell as parser
+
+SRC_URI = " \
+ http://www.shorewall.net/pub/shorewall/4.2/shorewall-${PV}/${PN}-${PV}.tar.bz2 \
+ "
+
+FILES_${PN} += "/usr/share/shorewall-shell/*"
+
+SRC_URI[md5sum] = "518a7f389a6f606c109acb7dfbe18372"
+SRC_URI[sha256sum] = "c85c8400015794b8fb191e519a0b8711028c865ca2b7e85099c7be26fe479e02"
diff --git a/recipes/shorewall/shorewall.inc b/recipes/shorewall/shorewall.inc
new file mode 100644
index 0000000000..8b3bc89b97
--- /dev/null
+++ b/recipes/shorewall/shorewall.inc
@@ -0,0 +1,20 @@
+AUTHOR = "Dvorkin Dmitry dvorkin@tibbo.com"
+DESCRIPTION = "Shorewall is a high-level tool for configuring Netfilter."
+HOMEPAGE = "http://www.shorewall.net/"
+LICENSE = "GPLv2"
+SECTION = "network"
+PRIORITY = "optional"
+
+INC_PR = "r0"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+RDEPENDS_${PN} += "iptables"
+RRECOMMENDS_${PN} = "kernel-module-ip-tables kernel-module-ip-conntrack kernel-module-ipt-conntrack kernel-module-ipt-multiport kernel-module-ipt-log kernel-module-ipt-mac kernel-module-ipt-mark kernel-module-ipt-masquerade kernel-module-ipt-pkttype kernel-module-ipt-reject kernel-module-ipt-state kernel-module-ipt-tos kernel-module-iptable-filter kernel-module-iptable-mangle kernel-module-iptable-nat"
+
+do_install() {
+ export PREFIX=${D}
+ ${WORKDIR}/${PN}-${PV}/install.sh
+}
+
+FILES_${PN} += "/usr/share/shorewall/*"
diff --git a/recipes/shorewall/shorewall_4.4.14.bb b/recipes/shorewall/shorewall_4.4.14.bb
new file mode 100644
index 0000000000..6e3e418154
--- /dev/null
+++ b/recipes/shorewall/shorewall_4.4.14.bb
@@ -0,0 +1,12 @@
+require shorewall.inc
+# this version (4.4) requires some deps (perl)
+require shorewall-deps.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = " \
+ http://www.shorewall.net/pub/shorewall/4.4/shorewall-${PV}/${PN}-${PV}.tar.bz2 \
+ "
+
+SRC_URI[md5sum] = "9f8705d69d42eb949e352af72c3af8bb"
+SRC_URI[sha256sum] = "af097fc18c0d5a3b562812814107b627bfd3d802e3b5fe45fec4e53a4e84f17c"