aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/samba/samba_3.2.15.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-12-13 22:21:32 -0800
committerKhem Raj <raj.khem@gmail.com>2010-12-14 12:12:17 -0800
commit4ba7aa07c0dcd28f94515ff9927e2a04403fcf15 (patch)
tree26a1688ac8a31bf755c92283568f24704d46e0bd /recipes/samba/samba_3.2.15.bb
parentcf2f37aaa8b244a1e608e8e82bd82548ac68ae2d (diff)
downloadopenembedded-4ba7aa07c0dcd28f94515ff9927e2a04403fcf15.tar.gz
samba_3.2.15.bb: Fix build failure on ARM/thumb due to GCC ICE
* As a hotfix we currently avoid compiling it in thumb mode. Due to gcc bug http://gcc.gnu.org/bugzilla/show_bug.cgi?id=46934 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/samba/samba_3.2.15.bb')
-rw-r--r--recipes/samba/samba_3.2.15.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/samba/samba_3.2.15.bb b/recipes/samba/samba_3.2.15.bb
index eda95d0e82..3f535b6018 100644
--- a/recipes/samba/samba_3.2.15.bb
+++ b/recipes/samba/samba_3.2.15.bb
@@ -9,7 +9,7 @@ SRC_URI += "file://configure-3.2.8.patch \
SRC_URI[md5sum] = "5a3bcc4927c9643b9f42970d0815b18f"
SRC_URI[sha256sum] = "84281fd1faeffee8558e49dff865dd382abbf78bc1be00f8cb5aa70aeea67d46"
-PR = "r1"
+PR = "r2"
EXTRA_OECONF += "\
SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
@@ -22,6 +22,11 @@ EXTRA_OECONF += "\
samba_cv_HAVE_WRFILE_KEYTAB=yes \
"
+# for arm we always use ARM instruction set
+# gcc 4.5 ICE's in thumb mode
+# see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=46934
+
+ARM_INSTRUCTION_SET = "arm"
do_configure() {
oe_runconf
}