aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rt2x00/rt73-chumby_1.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rt2x00/rt73-chumby_1.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rt2x00/rt73-chumby_1.2.bb')
-rw-r--r--recipes/rt2x00/rt73-chumby_1.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/rt2x00/rt73-chumby_1.2.bb b/recipes/rt2x00/rt73-chumby_1.2.bb
new file mode 100644
index 0000000000..3c03fc94a8
--- /dev/null
+++ b/recipes/rt2x00/rt73-chumby_1.2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Driver for Ralink rt73 USB 802.11g WiFi sticks found in the Chumby"
+HOMEPAGE = "http://www.chumby.com"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI="http://files.chumby.com/source/ironforge/build396/${PN}-${PV}.tar.gz"
+
+inherit module
+
+S = "${WORKDIR}/wifi/rt73/Module/"
+
+EXTRA_OEMAKE = "KERNDIR=${STAGING_KERNEL_DIR}"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+ install -m 0644 rt73${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+ install -d ${D}${sysconfdir}/Wireless/RT73STA/
+ install -m 0644 rt73.bin ${D}${sysconfdir}/Wireless/RT73STA/
+}
+