aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-05-08 14:34:16 +0200
committerSimon Busch <morphis@gravedo.de>2011-05-10 06:49:08 +0200
commit5a6efd58cdc85d08ab9e106c84bbac5110b5aecd (patch)
treeb85084dc9736698dbf7aba325dd5efd90cf6ad41 /recipes/qt4
parent5502a2c56885ea1dd6df0e9e5488abdf6848ef3d (diff)
downloadopenembedded-5a6efd58cdc85d08ab9e106c84bbac5110b5aecd.tar.gz
qt4-native: introduce the native version of qt4 and remove old qt4-tools-native
The new recipe is based on the qt4-tool-native one but it even installs the libraries of qt4 and not only the tools like moc/rcc. It will not increase the build time as most libraries are already build for the qt4-tool-native but not staged. This commit removes the old qt4-tools-native too. All versions provided by qt4-tools-native are even supported by qt4-native so it is a drop-in replacement. Signed-off-by: Simon Busch <morphis@gravedo.de> Acked-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/qt4-native.inc (renamed from recipes/qt4/qt4-tools-native.inc)34
-rw-r--r--recipes/qt4/qt4-native_4.5.2.bb (renamed from recipes/qt4/qt4-tools-native_4.5.2.bb)2
-rw-r--r--recipes/qt4/qt4-native_4.6.3.bb (renamed from recipes/qt4/qt4-tools-native_4.6.3.bb)2
-rw-r--r--recipes/qt4/qt4-native_4.7.2.bb (renamed from recipes/qt4/qt4-tools-native_4.7.2.bb)4
4 files changed, 15 insertions, 27 deletions
diff --git a/recipes/qt4/qt4-tools-native.inc b/recipes/qt4/qt4-native.inc
index 4a0cccea60..ee702e9f9b 100644
--- a/recipes/qt4/qt4-tools-native.inc
+++ b/recipes/qt4/qt4-native.inc
@@ -1,11 +1,12 @@
-DESCRIPTION = "Native tools for Qt/[X11|Mac|Embedded] version 4.x"
+DESCRIPTION = "Native version Qt/[X11|Mac|Embedded]"
DEPENDS = "zlib-native dbus-native"
SECTION = "libs"
HOMEPAGE = "http://www.trolltech.com"
PRIORITY = "optional"
LICENSE = "GPL"
+PROVIDES = "qt4-tools-native"
-INC_PR = "r10"
+INC_PR = "r0"
inherit native
@@ -22,11 +23,11 @@ EXTRA_OECONF = "-prefix ${prefix} \
-no-libjpeg -no-libpng -no-libmng -no-libtiff \
-no-accessibility \
-no-cups \
- -no-exceptions \
-no-nas-sound \
-no-nis -no-openssl \
- -verbose -release -static \
+ -verbose -release \
-embedded -no-freetype -no-glib -no-iconv \
+ -exceptions -xmlpatterns \
-qt3support"
# yank default -e, otherwise we get the following error:
@@ -41,17 +42,15 @@ TOBUILD = "\
src/tools/moc \
src/corelib \
src/sql \
- src/dbus \
- src/qt3support \
src/xml \
+ src/network \
src/tools/uic \
src/tools/rcc \
- src/network \
+ src/xmlpatterns \
+ src/dbus \
src/gui \
- src/tools/uic3 \
- tools/linguist/lrelease \
- tools/linguist/lupdate \
- tools/qdbus \
+ src/testlib \
+ src/qt3support \
"
do_compile() {
@@ -63,16 +62,7 @@ do_compile() {
NATIVE_INSTALL_WORKS = "1"
do_install() {
- install -d ${D}${bindir}/
- install -m 0755 bin/qmake ${D}${bindir}/qmake2
- for i in moc uic uic3 rcc lrelease lupdate qdbuscpp2xml qdbusxml2cpp; do
- install -m 0755 bin/${i} ${D}${bindir}/${i}4
+ for i in ${TOBUILD}; do
+ cd ${S}/$i && oe_runmake install INSTALL_ROOT=${D}
done
-
- install -d ${D}${datadir}/qt4/
- cp -PfR mkspecs ${D}${datadir}/qt4/
- ln -sf linux-g++ ${D}${datadir}/qt4/mkspecs/${BUILD_OS}-oe-g++
- cp -f ${WORKDIR}/g++.conf ${WORKDIR}/linux.conf ${D}${datadir}/qt4/mkspecs/common/
-
- install -m 0644 tools/porting/src/q3porting.xml ${D}${datadir}/qt4/
}
diff --git a/recipes/qt4/qt4-tools-native_4.5.2.bb b/recipes/qt4/qt4-native_4.5.2.bb
index 206e486810..8a94694f74 100644
--- a/recipes/qt4/qt4-tools-native_4.5.2.bb
+++ b/recipes/qt4/qt4-native_4.5.2.bb
@@ -1,4 +1,4 @@
-require qt4-tools-native.inc
+require qt4-native.inc
# Older releases have different source archive name, than .inc
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
diff --git a/recipes/qt4/qt4-tools-native_4.6.3.bb b/recipes/qt4/qt4-native_4.6.3.bb
index a1881570c9..b0c9bcb1dc 100644
--- a/recipes/qt4/qt4-tools-native_4.6.3.bb
+++ b/recipes/qt4/qt4-native_4.6.3.bb
@@ -1,6 +1,6 @@
DEFAULT_PREFERENCE = "-1"
-require qt4-tools-native.inc
+require qt4-native.inc
LICENSE = "LGPLv2.1 GPLv3"
PR = "${INC_PR}.0"
diff --git a/recipes/qt4/qt4-tools-native_4.7.2.bb b/recipes/qt4/qt4-native_4.7.2.bb
index 7dbb5695d1..7e98035fe6 100644
--- a/recipes/qt4/qt4-tools-native_4.7.2.bb
+++ b/recipes/qt4/qt4-native_4.7.2.bb
@@ -1,6 +1,4 @@
-DEFAULT_PREFERENCE = "-1"
-
-require qt4-tools-native.inc
+require qt4-native.inc
LICENSE = "LGPLv2.1 GPLv3"
PR = "${INC_PR}.0"