aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-03-11 12:35:41 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-11 13:42:14 +0100
commitb6cef8b5214f0a07bc0b2511a65a954517ee4d6d (patch)
treec2c07f456532fe023762ff33396fd190a41ed7d2 /recipes/python
parent21c2ae56fb13bed3fe3245aa181b7cfbe1ef5167 (diff)
downloadopenembedded-b6cef8b5214f0a07bc0b2511a65a954517ee4d6d.tar.gz
python-pygame: add version 1.9.1, with new staging and smpeg compatibility
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-pygame-1.8.1/Setup63
-rw-r--r--recipes/python/python-pygame_1.9.1.bb (renamed from recipes/python/python-pygame_1.8.1.bb)18
2 files changed, 7 insertions, 74 deletions
diff --git a/recipes/python/python-pygame-1.8.1/Setup b/recipes/python/python-pygame-1.8.1/Setup
deleted file mode 100644
index dd6d540da5..0000000000
--- a/recipes/python/python-pygame-1.8.1/Setup
+++ /dev/null
@@ -1,63 +0,0 @@
-#This Setup file is used by the setup.py script to configure the
-#python extensions. You will likely use the "config.py" which will
-#build a correct Setup file for you based on your system settings.
-#If not, the format is simple enough to edit by hand. First change
-#the needed commandline flags for each dependency, then comment out
-#any unavailable optional modules in the first optional section.
-
-
-SDL = -D_REENTRANT -Xlinker -lSDL -lpthread
-FONT = -lSDL_ttf
-IMAGE = -lSDL_image
-MIXER = -lSDL_mixer
-SMPEG = -lsmpeg
-PNG = -lpng
-JPEG = -ljpeg
-SCRAP = -lX11
-
-#DEBUG = -C-W -C-Wall
-DEBUG =
-
-#the following modules are optional. you will want to compile
-#everything you can, but you can ignore ones you don't have
-#dependencies for, just comment them out
-
-imageext src/imageext.c $(SDL) $(IMAGE) $(PNG) $(JPEG) $(DEBUG)
-font src/font.c $(SDL) $(FONT) $(DEBUG)
-mixer src/mixer.c $(SDL) $(MIXER) $(DEBUG)
-mixer_music src/music.c $(SDL) $(MIXER) $(DEBUG)
-_numericsurfarray src/_numericsurfarray.c $(SDL) $(DEBUG)
-_numericsndarray src/_numericsndarray.c $(SDL) $(MIXER) $(DEBUG)
-scrap src/scrap.c $(SDL) $(SCRAP) $(DEBUG)
-
-#experimental new movie movie. requires libavcodec and libavformat.
-#add any necessary compile flags to this line and uncomment.
-#movieext src/movie.c src/ffmovie.c $(SDL) -lavcodec -lavformat
-
-
-#these modules are required for pygame to run. they only require
-#SDL as a dependency. these should not be altered
-
-base src/base.c $(SDL) $(DEBUG)
-cdrom src/cdrom.c $(SDL) $(DEBUG)
-color src/color.c $(SDL) $(DEBUG)
-constants src/constants.c $(SDL) $(DEBUG)
-display src/display.c $(SDL) $(DEBUG)
-event src/event.c $(SDL) $(DEBUG)
-fastevent src/fastevent.c src/fastevents.c $(SDL) $(DEBUG)
-key src/key.c $(SDL) $(DEBUG)
-mouse src/mouse.c $(SDL) $(DEBUG)
-rect src/rect.c $(SDL) $(DEBUG)
-rwobject src/rwobject.c $(SDL) $(DEBUG)
-surface src/surface.c src/alphablit.c src/surface_fill.c $(SDL) $(DEBUG)
-surflock src/surflock.c $(SDL) $(DEBUG)
-time src/time.c $(SDL) $(DEBUG)
-joystick src/joystick.c $(SDL) $(DEBUG)
-draw src/draw.c $(SDL) $(DEBUG)
-image src/image.c $(SDL) $(DEBUG)
-overlay src/overlay.c $(SDL) $(DEBUG)
-transform src/transform.c src/rotozoom.c src/scale2x.c $(SDL) $(DEBUG)
-mask src/mask.c src/bitmask.c $(SDL) $(DEBUG)
-bufferproxy src/bufferproxy.c $(SDL) $(DEBUG)
-pixelarray src/pixelarray.c $(SDL) $(DEBUG)
-
diff --git a/recipes/python/python-pygame_1.8.1.bb b/recipes/python/python-pygame_1.9.1.bb
index 95191ce350..bbeedda3a9 100644
--- a/recipes/python/python-pygame_1.8.1.bb
+++ b/recipes/python/python-pygame_1.9.1.bb
@@ -4,27 +4,23 @@ HOMEPAGE = "http://www.pygame.org"
LICENSE = "LGPL"
DEPENDS = "libsdl-x11 libsdl-image libsdl-mixer libsdl-net libsdl-ttf python-numeric"
DEPENDS += "${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'smpeg', d)}"
+RDEPENDS = "python-numeric"
SRCNAME = "pygame"
PR = "ml4"
-SRC_URI = "\
- ftp://ftp.pygame.org/pub/pygame/${SRCNAME}-${PV}release.tar.gz \
- file://Setup \
-"
+SRC_URI = "http://www.pygame.org/ftp/${SRCNAME}-${PV}release.tar.gz;name=archive"
+SRC_URI[archive.md5sum] = "1c4cdc708d17c8250a2d78ef997222fc"
+SRC_URI[archive.sha256sum] = "a26095472ae4be9631e0d5bfb9a52ac57a3a091e45757913128e4a473807d433"
S = "${WORKDIR}/${SRCNAME}-${PV}release"
inherit distutils
do_configure_prepend() {
- cat ${WORKDIR}/Setup >Setup
+ # Drop options to replace them later and drom pypm as we don't have portmidi/porttime
+ sed '/^SDL =/d; /^SMPEG =/d; /^movie src/d; /^pypm src/d' Setup.in > Setup
SDL="`sdl-config --cflags` `sdl-config --libs`"; echo "SDL=$SDL" >>Setup
if [ '${ENTERPRISE_DISTRO}' != '1' ]; then
+ SMPEG="`smpeg-config --cflags` `smpeg-config --libs`"; echo "SMPEG=$SMPEG" >>Setup
echo "movie src/movie.c \$(SDL) \$(SMPEG) \$(DEBUG)" >>Setup
fi
}
-
-do_stage() {
- distutils_stage_all
-}
-
-RDEPENDS = "python-numeric"