aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-05-05 10:22:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-05-07 12:37:36 +0200
commit8f718886aedb441827bbd5c355b4437df9b43c5a (patch)
treec25690cf20731605bc2d9b8ce9faf153c5792b42 /recipes/python
parent037e0370587a77e6efa4e5b4aebbd12b4156aaaf (diff)
downloadopenembedded-8f718886aedb441827bbd5c355b4437df9b43c5a.tar.gz
python-argparse: add new recipe to provide argparse module for python and python-native older then 2.7
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-argparse_1.2.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/python/python-argparse_1.2.1.bb b/recipes/python/python-argparse_1.2.1.bb
new file mode 100644
index 0000000000..6f2bcb4be1
--- /dev/null
+++ b/recipes/python/python-argparse_1.2.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Python command-line parsing library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=09d08bb5b7047e2688ea3faad6408aa8"
+SRCNAME = argparse
+
+SRC_URI = "http://argparse.googlecode.com/files/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "2fbef8cb61e506c706957ab6e135840c"
+SRC_URI[sha256sum] = "ddaf4b0a618335a32b6664d4ae038a1de8fbada3b25033f9021510ed2b3941a4"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+BBCLASSEXTEND = "native"
+NATIVE_INSTALL_WORKS = "1"