aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-28 09:45:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-28 23:34:52 +0100
commit79e7f0ed89a58100f0ab7757ed4d58c699e98c21 (patch)
tree74eb6c4b98e76758d23f3ac559b6a92f8ec5d6cb /recipes/python
parentb8cef50628eca9c5044ee3eb49fea694901c94b8 (diff)
downloadopenembedded-79e7f0ed89a58100f0ab7757ed4d58c699e98c21.tar.gz
python-pycurl: add newer version 7.19.0
* dont use "versioned" depend on curl as 7.18.2 does * it pulls 2 curl providers (newest curl and curl from python-curl depends) for many targets and bitbake is rightfully complaining Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-pycurl_7.19.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/python/python-pycurl_7.19.0.bb b/recipes/python/python-pycurl_7.19.0.bb
new file mode 100644
index 0000000000..36d90d657c
--- /dev/null
+++ b/recipes/python/python-pycurl_7.19.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "libcurl Python Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "curl"
+SRCNAME = "pycurl"
+PR = "ml2"
+
+SRC_URI = "\
+ http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
+ file://no-static-link.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+SRC_URI[archive.md5sum] = "919d58fe37e69fe87ce4534d8b6a1c7b"
+SRC_URI[archive.sha256sum] = "eb782dfcc5a7c023539a077462b83c167e178128ee9f7201665b9fbb1a8b0642"
+
+inherit distutils
+
+RDEPENDS = "python-core curl"