aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:10:13 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:27 +0100
commit43d06b2c0ec3a7bd3f64526e00b95dd6ee5b208f (patch)
treee4c111fa52ca3fd4081c01c8744bd593f5819746 /recipes/python
parent53449d0731132f4630294b812c824cfd225850c2 (diff)
downloadopenembedded-43d06b2c0ec3a7bd3f64526e00b95dd6ee5b208f.tar.gz
python-epydoc: new recipe from SHR
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-epydoc-native_3.0.1.bb8
-rw-r--r--recipes/python/python-epydoc_3.0.1.bb12
2 files changed, 20 insertions, 0 deletions
diff --git a/recipes/python/python-epydoc-native_3.0.1.bb b/recipes/python/python-epydoc-native_3.0.1.bb
new file mode 100644
index 0000000000..7f64f64e64
--- /dev/null
+++ b/recipes/python/python-epydoc-native_3.0.1.bb
@@ -0,0 +1,8 @@
+require python-epydoc_${PV}.bb
+DEPENDS = "python-native"
+inherit native
+
+do_stage() {
+ distutils_stage_all
+}
+
diff --git a/recipes/python/python-epydoc_3.0.1.bb b/recipes/python/python-epydoc_3.0.1.bb
new file mode 100644
index 0000000000..36d22ad5a0
--- /dev/null
+++ b/recipes/python/python-epydoc_3.0.1.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Epydoc is a tool for generating API documentation for Python modules, based on their docstrings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT"
+HOMEPAGE = "http://epydoc.sourceforge.net/"
+SRCNAME = "epydoc"
+DEPENDS = "python"
+
+SRC_URI = "http://downloads.sourceforge.net/project/${SRCNAME}/${SRCNAME}/${PV}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils