aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powertop/powertop.inc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-09-11 23:31:12 -0700
committerKhem Raj <raj.khem@gmail.com>2009-09-11 23:35:07 -0700
commit53c0673ba015ba400d4e18fef5c5903830a06c09 (patch)
tree2cce6ccdd94a0713614fc5c8b85b665287e47bcf /recipes/powertop/powertop.inc
parentaa6a11a7168bf804925f78f9003920bce4b3a5e9 (diff)
downloadopenembedded-53c0673ba015ba400d4e18fef5c5903830a06c09.tar.gz
powertop: Make it compile on uclibc.
* Use INC_PR * Move common stuff to powertop.inc * Add -lint for uclibc bases systems * Add a patch to tinker with order of CFLAGS in commandline * Eliminate the sed expression in favor of a patch to substitute nsursesw with ncurses Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/powertop/powertop.inc')
-rw-r--r--recipes/powertop/powertop.inc27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/powertop/powertop.inc b/recipes/powertop/powertop.inc
new file mode 100644
index 0000000000..931abadc44
--- /dev/null
+++ b/recipes/powertop/powertop.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+HOMEPAGE = "http://www.linuxpowertop.org/"
+LICENSE = "GPLv2"
+DEPENDS = "virtual/libintl ncurses"
+
+INC_PR = "r1"
+
+SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
+ file://ldflags.patch;patch=1 \
+ "
+
+CFLAGS = "${LDFLAGS}"
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ # sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+ :
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+
+LDFLAGS_append_linux-uclibc = " -lintl"
+LDFLAGS_append_linux-uclibceabi = " -lintl"
+LDFLAGS_append_linux-uclibcspe = " -lintl"