aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/postmark
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-04 11:04:20 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-04 11:06:04 -0700
commit82ead3bfec1b30a8ed04748cc8edf0fb2c0e512c (patch)
tree068c309e124d1527e6d0e5496320ec0d773b3bee /recipes/postmark
parent630b8ed6743753d5ce848270ef6e01abf9733c82 (diff)
downloadopenembedded-82ead3bfec1b30a8ed04748cc8edf0fb2c0e512c.tar.gz
postmark: A benchmarking app, add.
Signed-off-by: Nikita Shulga <nikita_shulga@mentor.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/postmark')
-rw-r--r--recipes/postmark/postmark_1.51.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/postmark/postmark_1.51.bb b/recipes/postmark/postmark_1.51.bb
new file mode 100644
index 0000000000..305e869640
--- /dev/null
+++ b/recipes/postmark/postmark_1.51.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Benchmarks filesystem under workload similar to that of a mail server."
+LICENSE = "Artistic"
+PR = "r0"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/p/${PN}/${PN}_${PV}.orig.tar.gz \
+ ${DEBIAN_MIRROR}/main/p/${PN}/${PN}_${PV}-7.diff.gz;name=patch"
+
+SRC_URI[md5sum] = "b494167c2df1850004110ab28e5ad164"
+SRC_URI[sha256sum] = "7cb7c31d4e7725ce8d8e11fb7df62ed700dee4dbd5ca1e31bf3a9161fc890b41"
+SRC_URI[patch.md5sum] = "c2aafa2c1cc5aafe96390d582e119181"
+SRC_URI[patch.sha256sum] = "345d2b656699e331774a77ef337178ba3e702f96d20e2aefc18e6ce4b50f4a23"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile() {
+ ${CC} ${CFLAGS} -o ${PN} ${PN}-${PV}.c
+}
+
+do_install () {
+ install -d ${D}/usr/bin
+ install -m 0755 ${PN} ${D}/usr/bin
+}