aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opie-sheet
diff options
context:
space:
mode:
authorMichal Hrusecky <Michal@Hrusecky.net>2009-05-30 14:08:14 +0100
committerPaul Eggleton <bluelightning@bluelightning.org>2009-05-30 14:08:14 +0100
commite57d048f0895b369144de0b2f626964fb1e8e998 (patch)
tree6e38e5a303c1aa623b388d8badea8b7e1a8f5020 /recipes/opie-sheet
parent618bf2cd022e97a36a5f321d5f90cff9bb17bd3f (diff)
downloadopenembedded-e57d048f0895b369144de0b2f626964fb1e8e998.tar.gz
opie-sheet: fix compilation failure due to two function arguments with
the same name. Signed-off-by: Michal Hrusecky <Michal@Hrusecky.net>
Diffstat (limited to 'recipes/opie-sheet')
-rw-r--r--recipes/opie-sheet/opie-sheet/different-arg-names.patch11
-rw-r--r--recipes/opie-sheet/opie-sheet_1.2.4.bb4
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/opie-sheet/opie-sheet/different-arg-names.patch b/recipes/opie-sheet/opie-sheet/different-arg-names.patch
new file mode 100644
index 0000000000..a86aa9edd3
--- /dev/null
+++ b/recipes/opie-sheet/opie-sheet/different-arg-names.patch
@@ -0,0 +1,11 @@
+--- opie-sheet/sheet.h 2009-05-25 07:47:12.042719009 +0200
++++ opie-sheet/sheet.h 2009-05-25 08:07:19.291516199 +0200
+@@ -209,7 +207,7 @@
+ void insertRows(int no=1, bool allColumns=TRUE);
+ void insertColumns(int no=1, bool allRows=TRUE);
+
+- void dataFindReplace(const QString &find, const QString &replace, bool matchCase=TRUE, bool allCells=TRUE, bool entireCell=FALSE, bool replace=FALSE, bool replaceAll=FALSE);
++ void dataFindReplace(const QString &find, const QString &replacestr, bool matchCase=TRUE, bool allCells=TRUE, bool entireCell=FALSE, bool replace=FALSE, bool replaceAll=FALSE);
+
+ // Static functions
+ static int getHeaderColumn(const QString &section);
diff --git a/recipes/opie-sheet/opie-sheet_1.2.4.bb b/recipes/opie-sheet/opie-sheet_1.2.4.bb
index ca0cdaff5a..b2cd1d213d 100644
--- a/recipes/opie-sheet/opie-sheet_1.2.4.bb
+++ b/recipes/opie-sheet/opie-sheet_1.2.4.bb
@@ -1,6 +1,8 @@
require ${PN}.inc
+PR = "r1"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/apps/opie-sheet \
${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
- ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+ file://different-arg-names.patch;patch=1 "