aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opencv/opencv_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-29 11:07:32 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-29 11:12:33 +0200
commit418dde34e9824c7201e1e009536c25d2937e128f (patch)
treecc473710a6c4b97b777fc3423ea15dacdef52b98 /recipes/opencv/opencv_svn.bb
parentd295fc9fefc34f03e3b8d1b87f8658119cae1437 (diff)
downloadopenembedded-418dde34e9824c7201e1e009536c25d2937e128f.tar.gz
opencv: update to latest svn, tweak buildsystem a bit
* the autofoo buildsystem has problems with exporting symbols * the cmake buildsystem introduces bad RPATHs into the python extensions
Diffstat (limited to 'recipes/opencv/opencv_svn.bb')
-rw-r--r--recipes/opencv/opencv_svn.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/recipes/opencv/opencv_svn.bb b/recipes/opencv/opencv_svn.bb
index ce54d8c773..ab14c58e43 100644
--- a/recipes/opencv/opencv_svn.bb
+++ b/recipes/opencv/opencv_svn.bb
@@ -11,12 +11,12 @@ DEPENDS = "ffmpeg gtk+ libtool swig swig-native python jpeg zlib libpng tiff gli
SRC_URI = "svn://opencvlibrary.svn.sourceforge.net/svnroot/opencvlibrary/trunk;module=opencv;proto=https \
file://acinclude.m4"
-SRCREV = "2027"
+SRCREV = "2196"
PV = "1.0.0+1.1pre1+svnr${SRCREV}"
S = "${WORKDIR}/opencv"
-inherit distutils-base autotools pkgconfig
+inherit distutils-base autotools_stage pkgconfig cmake
EXTRA_OECONF = " \
--disable-debug \
@@ -29,16 +29,19 @@ EXTRA_OECONF = " \
--enable-apps \
--enable-optimization \
--disable-sse \
- --without-python az_python_cspec=${STAGING_INCDIR}/${PYTHON_DIR} \
+ --with-swig \
+ --with-python az_python_cspec=${STAGING_INCDIR}/${PYTHON_DIR} \
"
export BUILD_SYS
export HOST_SYS
export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}"
+export PYTHON=${STAGING_BINDIR_NATIVE}/python
do_configure_prepend() {
cp ${WORKDIR}/acinclude.m4 ${S}
sed -i -e /AC_CONFIG_MACRO_DIR/d -e /AZ_PYTHON_CSPEC/d ${S}/configure.in
+ sed -i -e s:samples::g -e 's: doc::g' ${S}/Makefile.am
}
TARGET_CC_ARCH += "-I${S}/include "
@@ -55,16 +58,15 @@ python populate_packages_prepend () {
}
FILES_${PN} = ""
-FILES_${PN}-doc += "${datadir}/opencv/"
-FILES_${PN}-apps = "${bindir}/*"
+FILES_${PN}-apps = "${bindir}/* ${datadir}/opencv/"
FILES_${PN}-dbg += "${libdir}/.debug"
FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
+INSANE_SKIP_python-opencv = True
DESCRIPTION_python-opencv = "Python bindings to opencv"
FILES_python-opencv = "${libdir}/*/site-packages/*"
RDEPENDS_python-opencv = "python-core"
-do_stage() {
- autotools_stage_all
+do_stage_append() {
+ cp ${S}/include/opencv/*.h ${STAGING_INCDIR}/opencv/
}
-