aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mplayer
diff options
context:
space:
mode:
authorJosua Mayer <josua.mayer97@googlemail.com>2011-08-02 21:05:49 +0200
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-08-03 13:11:29 +0200
commit1a91fc4b705b0c4f45eb088a2f7aea01ebc9c98e (patch)
treef9056f6502da095e03f26d5b9b79dc31fd04be06 /recipes/mplayer
parent3195e1a544edacbbcc904e3a3088071888dcb419 (diff)
downloadopenembedded-1a91fc4b705b0c4f45eb088a2f7aea01ebc9c98e.tar.gz
mplayer_git: Add patch to fix linker error on x86 machines
For x86 machines the option `--enable-runtime-cpudetection` is passed to the configure script. EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'x86', '--enable-runtime-cpudetection', '',d)} " This causes a linker error like fix undefined references in loader/module.o: module.c:(.text+0xd60): undefined reference to `report_entry' module.c:(.text+0xd6a): undefined reference to `report_ret' module.c:(.text+0xd74): undefined reference to `wrapper_target' module.c:(.text+0xd7a): undefined reference to `wrapper' as reported and fixed in the Gentoo’s Bugzilla Bug 213836 [1]. The patch was partly adopted and applied already to `mplayer_svn` in OpenEmbedded in commit »mplayer_svn : fix compilation problem« (ff57f14c) [2]. This patch is build tested for `DISTRO = "shr"` with a modified `conf/machine/ion.conf`. [1] https://bugs.gentoo.org/213836?id=213836 [2] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=ff57f14c99a6ff61ffb7f1c533523e3e934f96e5 Signed-off-by: Josua Mayer <josua.mayer97@googlemail.com> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
Diffstat (limited to 'recipes/mplayer')
-rw-r--r--recipes/mplayer/mplayer_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes/mplayer/mplayer_git.bb b/recipes/mplayer/mplayer_git.bb
index 259ce99759..c6950f837c 100644
--- a/recipes/mplayer/mplayer_git.bb
+++ b/recipes/mplayer/mplayer_git.bb
@@ -8,7 +8,8 @@ DEPENDS = "libvpx live555 libdvdread libtheora virtual/libsdl ffmpeg xsp zlib li
RDEPENDS_${PN} = "mplayer-common"
LICENSE = "GPL"
SRC_URI = "git://repo.or.cz/mplayer/glamo.git;protocol=git;branch=mplayer2 \
- "
+ file://fix-emu_qtx_api.diff \
+ "
SRC_URI_append_armv7a = " \
file://0001-video-out-for-omapfb-support.patch \
@@ -32,6 +33,8 @@ RCONFLICTS_${PN} = "mplayer-atty"
RREPLACES_${PN} = "mplayer-atty"
PV = "2.0+gitr${SRCPV}"
+PR = "r1"
+
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_shr = "2"