aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mokosuite2
diff options
context:
space:
mode:
authorDaniele Ricci <daniele.athome@gmail.com>2011-01-15 17:57:34 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2011-01-15 20:12:29 +0100
commite29a9875c64d937f750ac41951042981591d3960 (patch)
tree83646c1bc5d451b6cec6baa2f1158f55e5872763 /recipes/mokosuite2
parentb54ee6a1c53e276ca384ea08e593ff4ff35aff86 (diff)
downloadopenembedded-e29a9875c64d937f750ac41951042981591d3960.tar.gz
mokomessages: new recipe
MokoMessages - for reading and sending SMS messages First version: * Thread list * Progressive message load * Reply to messages Signed-off-by: Daniele Ricci <daniele.athome@gmail.com> Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes/mokosuite2')
-rw-r--r--recipes/mokosuite2/mokomessages_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/mokosuite2/mokomessages_git.bb b/recipes/mokosuite2/mokomessages_git.bb
new file mode 100644
index 0000000000..ea5ece05ac
--- /dev/null
+++ b/recipes/mokosuite2/mokomessages_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Desktop environment and phone stack GUI for SHR - messages application"
+HOMEPAGE = "http://gitorious.org/mokosuite2"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "libmokosuite libfreesmartphone-glib libphone-utils glib-2.0 dbus-glib elementary edje-native"
+SECTION = "misc/utils"
+
+PV = "1.0.99+gitr${SRCPV}"
+SRCREV = "9d3f51f73d7ea9febcf59525ec6444b322238c7e"
+
+SRC_URI = "git://gitorious.org/mokosuite2/mokomessages.git;protocol=git"
+S = "${WORKDIR}/git"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc --enable-debug"
+FILES_${PN} += "${datadir}/mokosuite/messages"
+
+inherit autotools
+
+do_install_append() {
+ ln -s themes/gry.edj ${D}${datadir}/mokosuite/messages/theme.edj
+}