aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mokosuite2
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-12-07 10:04:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-12-08 00:46:19 +0100
commit196b71166e680a9a3255182f787a98ef2e857e97 (patch)
treea4eb752618d7c82bee07dd502ca8fade5fbf15a9 /recipes/mokosuite2
parentdd4ca2170b5c3d14db260095bd92ebdea40cb867 (diff)
downloadopenembedded-196b71166e680a9a3255182f787a98ef2e857e97.tar.gz
mokosuite2: move older recipes from openmoko-3rdparty also to mokosuite2 directory
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/mokosuite2')
-rw-r--r--recipes/mokosuite2/mokosuite2_git.bb22
-rw-r--r--recipes/mokosuite2/mokowm-imf-ecore_git.bb17
-rw-r--r--recipes/mokosuite2/mokowm_git.bb23
3 files changed, 62 insertions, 0 deletions
diff --git a/recipes/mokosuite2/mokosuite2_git.bb b/recipes/mokosuite2/mokosuite2_git.bb
new file mode 100644
index 0000000000..7ac9b7aae7
--- /dev/null
+++ b/recipes/mokosuite2/mokosuite2_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Desktop environment and phone stack GUI for SHR"
+HOMEPAGE = "http://gitorious.org/mokosuite2"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "mokowm elementary libfakekey libfreesmartphone-glib libphone-utils eggdbus glib-2.0 dbus-glib alsa-lib db sqlite3 vala-native"
+SECTION = "misc/utils"
+
+PV = "1.0.99+gitr${SRCPV}"
+PR = "r2"
+SRCREV = "c2fbbf1de2694d6fb1031efb1a1c9335bd33e8e3"
+
+SRC_URI = "git://gitorious.org/mokosuite2/appbunch.git;protocol=git"
+S = "${WORKDIR}/git"
+
+PARALLEL_MAKE = ""
+
+CFLAGS += "-DOPENMOKO"
+EXTRA_OECONF = " --enable-contactsdb-sqlite --enable-settings-config --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+FILES_${PN} += "${datadir}/mokosuite ${sysconfdir}/dbus-1 ${sysconfdir}/X11 ${sysconfdir}/mokosuite.conf {$datadir}/applications"
+CONFFILES_${PN} = "${sysconfdir}/mokosuite.conf"
+
+inherit pkgconfig autotools
diff --git a/recipes/mokosuite2/mokowm-imf-ecore_git.bb b/recipes/mokosuite2/mokowm-imf-ecore_git.bb
new file mode 100644
index 0000000000..22e49bc2c4
--- /dev/null
+++ b/recipes/mokosuite2/mokowm-imf-ecore_git.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Ecore input method for the Mokosuite window manager"
+HOMEPAGE = "http://gitorious.org/mokosuite2"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "ecore eina"
+SECTION = "misc/utils"
+
+PV = "1.0.99+gitr${SRCPV}"
+SRCREV = "7ce10c69038c664a08fa345270865ddcd7445cf1"
+
+SRC_URI = "git://gitorious.org/mokosuite2/mokowm-imf-ecore.git;protocol=git"
+S = "${WORKDIR}/git"
+
+FILES_${PN}-dbg += "${libdir}/ecore/immodules/.debug"
+FILES_${PN} += "${libdir}/ecore/immodules"
+
+inherit autotools
diff --git a/recipes/mokosuite2/mokowm_git.bb b/recipes/mokosuite2/mokowm_git.bb
new file mode 100644
index 0000000000..43a5b0d3b8
--- /dev/null
+++ b/recipes/mokosuite2/mokowm_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "A minimal X11 window manager for the Mokosuite"
+HOMEPAGE = "http://gitorious.org/mokosuite2"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "glib-2.0 ecore evas edje libfakekey"
+SECTION = "x11/clients"
+
+PV = "1.0.99+gitr${SRCPV}"
+SRCREV = "823d3bfa136a534d97ddb65ec4b2c348ea46afe1"
+
+SRC_URI = "git://gitorious.org/mokosuite2/mokowm.git;protocol=git"
+S = "${WORKDIR}/git"
+
+CFLAGS += "-DOPENMOKO"
+EXTRA_OECONF = " --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+FILES_${PN} += "${datadir}/mokosuite ${sysconfdir}/X11"
+
+inherit autotools update-alternatives
+
+ALTERNATIVE_PATH = "${bindir}/mokosession"
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PRIORITY = "20"