aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/midpath
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-07 19:08:14 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-07 19:08:14 -0700
commitb389158b1194810db0f4249581c839729271cab5 (patch)
tree1301f83286e5ddbaf0b760457ad1ed8e6157dc3c /recipes/midpath
parentb095bd20734460c03710f19f4a38a180c5ecebc9 (diff)
downloadopenembedded-b389158b1194810db0f4249581c839729271cab5.tar.gz
midpath-core_0.2+0.3rc2.bb: Fix compilation error and QA HASH error on ARM
* Remove legacy staging Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/midpath')
-rw-r--r--recipes/midpath/files/hci_read_local_name.patch13
-rw-r--r--recipes/midpath/midpath-backend-sdl_0.2+0.3rc2.bb2
-rw-r--r--recipes/midpath/midpath-common.inc2
-rw-r--r--recipes/midpath/midpath-core_0.2+0.3rc2.bb26
4 files changed, 24 insertions, 19 deletions
diff --git a/recipes/midpath/files/hci_read_local_name.patch b/recipes/midpath/files/hci_read_local_name.patch
new file mode 100644
index 0000000000..e4ce11464a
--- /dev/null
+++ b/recipes/midpath/files/hci_read_local_name.patch
@@ -0,0 +1,13 @@
+Index: midpath-0.3rc2/external/avetanabt-cldc/native/de_avetana_bluetooth_stack_BlueZ.cpp
+===================================================================
+--- midpath-0.3rc2.orig/external/avetanabt-cldc/native/de_avetana_bluetooth_stack_BlueZ.cpp 2010-09-07 18:49:11.000000000 -0700
++++ midpath-0.3rc2/external/avetanabt-cldc/native/de_avetana_bluetooth_stack_BlueZ.cpp 2010-09-07 18:51:52.877682002 -0700
+@@ -649,7 +649,7 @@ JNIEXPORT jstring JNICALL Java_de_avetan
+
+ //printf("Function called: %s, %i\n"__FILE__, __LINE__);
+
+- if (hci_local_name(dd, sizeof(name_str), name_str, timeOut) < 0)
++ if (hci_read_local_name(dd, sizeof(name_str), name_str, timeOut) < 0)
+ {
+ throwException(env, "Java_de_avetana_bluetooth_stack_BlueZ_hciLocalName: Unable to read local name");
+ return 0;
diff --git a/recipes/midpath/midpath-backend-sdl_0.2+0.3rc2.bb b/recipes/midpath/midpath-backend-sdl_0.2+0.3rc2.bb
index d5934ef534..938e6e8b66 100644
--- a/recipes/midpath/midpath-backend-sdl_0.2+0.3rc2.bb
+++ b/recipes/midpath/midpath-backend-sdl_0.2+0.3rc2.bb
@@ -10,8 +10,6 @@ DEPENDS += "midpath-cldc virtual/libsdl libsdl-mixer libsdl-ttf libsdl-image lib
RDEPENDS_${PN} = "${PN}-jni"
-TARGET_CC_ARCH += "${LDFLAGS}"
-
do_compile() {
# Only sdljava-cldc and native SDL backend library is enabled
midpath_build \
diff --git a/recipes/midpath/midpath-common.inc b/recipes/midpath/midpath-common.inc
index 0c320e4408..b3d2cdcf26 100644
--- a/recipes/midpath/midpath-common.inc
+++ b/recipes/midpath/midpath-common.inc
@@ -11,6 +11,8 @@ GLIBJ_ZIP = "${STAGING_DATADIR}/classpath/glibj.zip"
CLDC_JAR = "${STAGING_DATADIR}/midpath-cldc/midpath-cldc1.1.jar"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
do_unpackpost() {
# Remove unneccessary binary bits.
find lib -name "*.jar" -exec rm \{\} \;
diff --git a/recipes/midpath/midpath-core_0.2+0.3rc2.bb b/recipes/midpath/midpath-core_0.2+0.3rc2.bb
index 1c87d42271..a23b26f977 100644
--- a/recipes/midpath/midpath-core_0.2+0.3rc2.bb
+++ b/recipes/midpath/midpath-core_0.2+0.3rc2.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "MIDPath is a Java library which provides a MIDP2 implementation"
-PR = "r3"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz"
@@ -9,7 +9,8 @@ S = "${WORKDIR}/midpath-0.3rc2"
require midpath-common.inc
SRC_URI += "\
- file://fix-openfile.patch \
+ file://fix-openfile.patch \
+ file://hci_read_local_name.patch \
file://midpath-suitemanager \
file://midpath-launcher-j2se \
file://midpath-suitemanager.desktop \
@@ -46,12 +47,12 @@ do_compile() {
do_install() {
oe_libinstall -C dist -so libavetanabtcldc ${D}${libdir_jni}
- install -d ${D}${datadir}/midpath
- install -m 0644 dist/${JAR} ${D}${datadir}/midpath
- install -m 0644 dist/microbackend.jar ${D}${datadir}/midpath
- install -m 0644 dist/avetanabt-cldc.jar ${D}${datadir}/midpath
- install -m 0644 dist/jorbis-cldc.jar ${D}${datadir}/midpath
- install -m 0644 dist/jlayerme-cldc.jar ${D}${datadir}/midpath
+ install -d ${D}${datadir}/midpath
+ install -m 0644 dist/${JAR} ${D}${datadir}/midpath
+ install -m 0644 dist/microbackend.jar ${D}${datadir}/midpath
+ install -m 0644 dist/avetanabt-cldc.jar ${D}${datadir}/midpath
+ install -m 0644 dist/jorbis-cldc.jar ${D}${datadir}/midpath
+ install -m 0644 dist/jlayerme-cldc.jar ${D}${datadir}/midpath
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/midpath-launcher-j2se ${D}${bindir}
@@ -64,15 +65,6 @@ do_install() {
install -m 0644 ${WORKDIR}/midpath.png ${D}${datadir}/pixmaps
}
-do_stage() {
- install -d ${STAGING_DATADIR}/midpath
- install -m 0644 dist/${JAR} ${STAGING_DATADIR}/midpath
- install -m 0644 dist/microbackend.jar ${STAGING_DATADIR}/midpath
- install -m 0644 dist/avetanabt-cldc.jar ${STAGING_DATADIR}/midpath
- install -m 0644 dist/jorbis-cldc.jar ${STAGING_DATADIR}/midpath
- install -m 0644 dist/jlayerme-cldc.jar ${STAGING_DATADIR}/midpath
-}
-
PACKAGES = "${PN}-bluetooth ${PN}-bluetooth-jni ${PN}-bluetooth-jni-dbg ${PN}-mp3 ${PN}-ogg ${PN}"
RDEPENDS_${PN}-bluetooth = "${PN}-bluetooth-jni"