aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/makedevs
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-10-22 00:18:22 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-10-22 00:31:01 +0200
commit243600420c28acd7ef4b2dfc46862f9151972657 (patch)
treed74258ef2f36887b7430dff20d5385b4b0b4ddf8 /recipes/makedevs
parentbd9190c53157c64620fb08f0349d8d7d6a64fb79 (diff)
downloadopenembedded-243600420c28acd7ef4b2dfc46862f9151972657.tar.gz
makedevs: fix interpretation of device table (count).
Signed-off-by: Antonio Ospite <ospite@studenti.unina.it>
Diffstat (limited to 'recipes/makedevs')
-rw-r--r--recipes/makedevs/makedevs-1.0.0/makedevs.c2
-rw-r--r--recipes/makedevs/makedevs_1.0.0.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes/makedevs/makedevs-1.0.0/makedevs.c b/recipes/makedevs/makedevs-1.0.0/makedevs.c
index c7ad722f2e..80f21f0841 100644
--- a/recipes/makedevs/makedevs-1.0.0/makedevs.c
+++ b/recipes/makedevs/makedevs-1.0.0/makedevs.c
@@ -221,7 +221,7 @@ static int interpret_table_entry(char *line)
dev_t rdev;
char buf[80];
- for (i = start; i < count; i++) {
+ for (i = start; i < start+count; i++) {
sprintf(buf, "%s%d", name, i);
/* FIXME: MKDEV uses illicit insider knowledge of kernel
* major/minor representation... */
diff --git a/recipes/makedevs/makedevs_1.0.0.bb b/recipes/makedevs/makedevs_1.0.0.bb
index 5579e61bdd..cab1a4c1e5 100644
--- a/recipes/makedevs/makedevs_1.0.0.bb
+++ b/recipes/makedevs/makedevs_1.0.0.bb
@@ -6,7 +6,7 @@ PRIORITY = "required"
SRC_URI = "file://makedevs.c"
S = "${WORKDIR}/makedevs-${PV}"
-PR = "r7"
+PR = "r8"
inherit update-alternatives