aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lmbench
diff options
context:
space:
mode:
authorCarlos Hernandez <carher@gmail.com>2011-04-03 00:13:16 +0000
committerTom Rini <tom_rini@mentor.com>2011-04-07 10:32:25 -0700
commitce5c4621a55a27c41af36747b53576765f2d40c2 (patch)
treeea2f8ec486bab7600b8a498c7d4908c23d8e897b /recipes/lmbench
parentfc65614bf2db97697b3bb8c633309df4dd873194 (diff)
downloadopenembedded-ce5c4621a55a27c41af36747b53576765f2d40c2.tar.gz
lmbench: rename 'line' binary as 'lm_line'
Both lmbench and util-linux-ng packages provide own /usr/bin/line binaries. Even though the binaries name is the same, their functionality is different. This patch renames lmbench's line binary as lm_line to avoid conflicts with util-linux-ng. script/config-run is also modified (patch) to call lm_line instead of line. Signed-off-By: Carlos Hernandez <c-hernandez8@ti.com> Acked-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/lmbench')
-rw-r--r--recipes/lmbench/lmbench/rename-line-binary.patch11
-rw-r--r--recipes/lmbench/lmbench_3.0-a9.bb6
2 files changed, 15 insertions, 2 deletions
diff --git a/recipes/lmbench/lmbench/rename-line-binary.patch b/recipes/lmbench/lmbench/rename-line-binary.patch
new file mode 100644
index 0000000000..997143b3b0
--- /dev/null
+++ b/recipes/lmbench/lmbench/rename-line-binary.patch
@@ -0,0 +1,11 @@
+--- patches/scripts/config-run 2006-11-26 15:11:04.000000000 -0500
++++ patches/scripts/config-run 2011-04-01 09:35:50.000000000 -0400
+@@ -224,7 +224,7 @@ fi
+
+ echo "Hang on, we are calculating your cache line size."
+ ../bin/$OS/msleep 250
+-LINE_SIZE=`../bin/$OS/line -M ${MB}M`
++LINE_SIZE=`../bin/$OS/lm_line -M ${MB}M`
+ export LINE_SIZE
+ echo "OK, it looks like your cache line is $LINE_SIZE bytes."
+ echo ""
diff --git a/recipes/lmbench/lmbench_3.0-a9.bb b/recipes/lmbench/lmbench_3.0-a9.bb
index 1e2598ac65..d1e9162bbe 100644
--- a/recipes/lmbench/lmbench_3.0-a9.bb
+++ b/recipes/lmbench/lmbench_3.0-a9.bb
@@ -3,12 +3,13 @@ DESCRIPTION = "Tools for performance analysis."
LICENSE = "GPL"
RDEPENDS_${PN} = "debianutils"
-PR = "r2"
+PR = "r3"
inherit autotools
SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
- file://lmbench-run"
+ file://lmbench-run \
+ file://rename-line-binary.patch"
SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
@@ -56,6 +57,7 @@ do_install () {
install -m 0755 ${S}/scripts/lmbench ${D}${bindir}
install -d ${D}${datadir}/lmbench/scripts
install -m 0755 ${S}/scripts/* ${D}${datadir}/lmbench/scripts
+ mv ${D}${bindir}/line ${D}${bindir}/lm_line
}
FILES_${PN} += "${datadir}/lmbench"