aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.24.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-26 13:45:32 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-26 13:45:32 +0100
commit8af5e0ed1a7c79cd97ac5c58a7663c56b7f11621 (patch)
tree39c6c19e441e1dc48a671a96e81d6c9aa3ebad63 /recipes/linux/linux_2.6.24.bb
parent39e66d2f9b322ea7f8711bdcfa9b251b614e60fa (diff)
downloadopenembedded-8af5e0ed1a7c79cd97ac5c58a7663c56b7f11621.tar.gz
linux 2.6.24: add support for smartq5 device (machine.conf will follow later)
* also fix task ordering due to kernel.bbclass changes
Diffstat (limited to 'recipes/linux/linux_2.6.24.bb')
-rw-r--r--recipes/linux/linux_2.6.24.bb19
1 files changed, 15 insertions, 4 deletions
diff --git a/recipes/linux/linux_2.6.24.bb b/recipes/linux/linux_2.6.24.bb
index 7df18dad9c..ac7def59d0 100644
--- a/recipes/linux/linux_2.6.24.bb
+++ b/recipes/linux/linux_2.6.24.bb
@@ -106,17 +106,28 @@ SRC_URI_append_hipox = " \
file://hipox-sata-module.patch;patch=1 \
"
-
+EXTRA_OEMAKE_smartq5 = " OBJCOPY=${OBJCOPY}"
SRC_URI_smartq5 = " ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
http://ftp.kernel.org/pub/linux/kernel/v2.6/patch-2.6.24.7.bz2;patch=1 \
file://smartq-gitupdate.diff;patch=1 \
file://base/0001-Apply-samsung-kernel-patch.patch;patch=1 \
file://base/0002-Apply-smartq-patch.patch;patch=1 \
- file://base/0003-Apply-cpufreq-patch-from-gqwang.patch;patch=1 \
- file://base/0004-Better-compatibility-with-some-memory-chips.patch;patch=1 \
+ file://mer/0001-Mer-keymappings-change.patch;patch=1 \
+ file://mer/0002-no-DM9000.patch;patch=1 \
+ file://mer/0003-Mer-WPA-fix.patch;patch=1 \
+ file://mer/0004-Mer-hardwire-USB-OTG-gadget-type.patch;patch=1 \
+ file://mer/0005-backlight-parameter-and-fixes.patch;patch=1 \
+ file://mer/0006-tv-encoder.patch;patch=1 \
+ file://mer/0007-make-tv-encoder-scaler-compile.patch;patch=1 \
+ file://mer/0008-build-TV-by-default.patch;patch=1 \
+ file://mer/0009-Apply-cpufreq-patch-from-gqwang.patch;patch=1 \
+ file://mer/0010-Better-compatibility-with-some-memory-chips.patch;patch=1 \
+ file://mer/0011-Only-reserve-memory-for-TV-if-CONFIG_VIDEO_SAMSUNG_T.patch;patch=1 \
+ file://mer/0012-Disable-TV-out-to-save-RAM.patch;patch=1 \
file://defconfig \
"
+
CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=1 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
FILES_kernel-image_gesbc-9302 = ""
@@ -157,5 +168,5 @@ python do_compulab_image() {
}
-addtask compulab_image after do_deploy before do_package
+addtask compulab_image after do_deploy before do_package_write