aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-sun4cdm_2.6.8.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-sun4cdm_2.6.8.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-sun4cdm_2.6.8.1.bb')
-rw-r--r--recipes/linux/linux-sun4cdm_2.6.8.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/linux/linux-sun4cdm_2.6.8.1.bb b/recipes/linux/linux-sun4cdm_2.6.8.1.bb
new file mode 100644
index 0000000000..40583903d8
--- /dev/null
+++ b/recipes/linux/linux-sun4cdm_2.6.8.1.bb
@@ -0,0 +1,19 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for sparc32/sun4c"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://sun4c_defconfig"
+S = "${WORKDIR}/linux-${PV}"
+
+COMPATIBLE_HOST = 'sparc-linux'
+
+inherit kernel
+
+ARCH = "sparc"
+KERNEL_IMAGETYPE = "image"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/sun4c_defconfig ${S}/.config
+}