aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap_2.6.29.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-13 16:30:10 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-15 19:26:15 +0200
commitd861047e32eacf91974108a5eeba1f847bad5b9f (patch)
treeac07eaf5fe935b4f58aae20528f3cf101b712549 /recipes/linux/linux-omap_2.6.29.bb
parent72c1fd8a2b6ab59a28467c033ec7fa18cfb67225 (diff)
downloadopenembedded-d861047e32eacf91974108a5eeba1f847bad5b9f.tar.gz
linux-omap 2.6.29: add support for the omap3-touchbook
Diffstat (limited to 'recipes/linux/linux-omap_2.6.29.bb')
-rw-r--r--recipes/linux/linux-omap_2.6.29.bb31
1 files changed, 30 insertions, 1 deletions
diff --git a/recipes/linux/linux-omap_2.6.29.bb b/recipes/linux/linux-omap_2.6.29.bb
index 56e6107a4c..7c16354b2d 100644
--- a/recipes/linux/linux-omap_2.6.29.bb
+++ b/recipes/linux/linux-omap_2.6.29.bb
@@ -3,7 +3,7 @@ require linux.inc
DESCRIPTION = "Linux kernel for OMAP processors"
KERNEL_IMAGETYPE = "uImage"
-COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom"
+COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom|omap3-touchbook"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_overo = "1"
@@ -175,6 +175,35 @@ SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
file://beaglebug/beaglebug-full.patch;patch=1 \
"
+SRC_URI_append_omap3-touchbook = " \
+ file://beagle-asoc.patch;patch=1 \
+ file://accelerometer-mma7455l.patch;patch=1 \
+ file://accelerometer-touchscreen-mux-spi.patch;patch=1 \
+ file://touchscreen-ads7846-export-settings.patch;patch=1 \
+ file://touchscreen-ads7846-rotation-support.patch;patch=1 \
+ file://dspbridge.patch;patch=1 \
+ file://battery2-bq27200-no-error-message.patch;patch=1 \
+ file://sound-headphone-detection.patch;patch=1 \
+ file://dss2-fix-XY-coordinates-when-rotating.patch;patch=1 \
+ file://screen-backlight.patch;patch=1 \
+ file://battery1-tps65950-charging-management-1.patch;patch=1 \
+ file://dss2-fix-scaling-when-rotating.patch;patch=1 \
+ file://dss2-export-status.patch;patch=1 \
+ file://usb-otg-pc-connection.patch;patch=1 \
+ file://battery1-tps65950-charging-management-2.patch;patch=1 \
+ file://memory-move-malloc-end.patch;patch=1 \
+ file://aufs-1.patch;patch=1 \
+ file://aufs-2.patch;patch=1 \
+ file://aufs-3.patch;patch=1 \
+ file://aufs-squashfs-mount-to-avoid-initramfs.patch;patch=1 \
+ file://screen-backlight-accessible-by-user.patch;patch=1 \
+ file://dss2-blank-rotate-accessible-by-user.patch;patch=1 \
+ file://boot-no-power-message.patch;patch=1 \
+ file://usb-lower-current-consumption-upon-insertion.patch;patch=1 \
+ file://battery2-bq27200-gpio-charged.patch;patch=1 \
+ file://board-omap3beagle.c \
+"
+
SRC_URI_append_omap3evm = " \
file://evm-mcspi-ts.diff;patch=1 \
"