aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-jlime-jornada6xx_2.6.17.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-jlime-jornada6xx_2.6.17.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-jlime-jornada6xx_2.6.17.bb')
-rw-r--r--recipes/linux/linux-jlime-jornada6xx_2.6.17.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/linux/linux-jlime-jornada6xx_2.6.17.bb b/recipes/linux/linux-jlime-jornada6xx_2.6.17.bb
new file mode 100644
index 0000000000..86a5f6083f
--- /dev/null
+++ b/recipes/linux/linux-jlime-jornada6xx_2.6.17.bb
@@ -0,0 +1,29 @@
+SECTION = "kernel"
+DESCRIPTION = "JLime Linux kernel for SuperH based Jornada 6xx"
+LICENSE = "GPL"
+PR = "r0"
+
+COMPATIBLE_HOST = "sh.*-linux"
+#COMPATIBLE_MACHINE = "jornada6xx"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.17.tar.gz \
+ file://defconfig_jlime \
+ file://LinuxSH-2.6.17.patch;patch=0 \
+ file://unexpected-int-fix.patch;patch=0 \
+ file://keymap-fix.patch;patch=0 \
+ file://io.h-fix.patch;patch=0 \
+ file://keyboard-fix-deadkeys.patch;patch=0"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+#Lets let 3.4.x handle the compilation of this one
+KERNEL_CCSUFFIX = "-3.4.4"
+
+ARCH = "sh"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig_jlime ${S}/.config
+}