aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/files
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2011-04-28 17:14:15 +0200
committerAndrea Adami <andrea.adami@gmail.com>2011-04-28 17:14:15 +0200
commit47150289dffdad8de25d810a3046c7add30c1f19 (patch)
treecddc6afffb880d2cea9a1bb9916c2c972327b7ff /recipes/linux/files
parent889e243003c5752cf6e56b674d598fe4ee293a0a (diff)
downloadopenembedded-47150289dffdad8de25d810a3046c7add30c1f19.tar.gz
linux: move handelds- stale files to obsolete
* ipaq-hal.init only used in * recipes/obsolete/linux/handhelds-pxa_2.4.19-rmk6-pxa1-hh42.bb * recipes/obsolete/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb * * usb-gadget-ether-compat.patch used only in * recipes/obsolete/linux/handhelds-pxa_2.4.19-rmk6-pxa1-hh42.bb Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes/linux/files')
-rw-r--r--recipes/linux/files/ipaq-hal.init14
-rw-r--r--recipes/linux/files/usb-gadget-ether-compat.patch30
2 files changed, 0 insertions, 44 deletions
diff --git a/recipes/linux/files/ipaq-hal.init b/recipes/linux/files/ipaq-hal.init
deleted file mode 100644
index 4efb52ec97..0000000000
--- a/recipes/linux/files/ipaq-hal.init
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-# make sure update-modules has been run
-# since the calls below depend on aliases...
-if [ ! -f /etc/modules.conf ]; then
- update-modules || true
-fi
-
-modprobe ipaq_hal || exit 0
-
-if [ -d /proc/hal ]; then
- model=`cat /proc/hal/model`
- modprobe ipaq_hal_$model
-fi
diff --git a/recipes/linux/files/usb-gadget-ether-compat.patch b/recipes/linux/files/usb-gadget-ether-compat.patch
deleted file mode 100644
index 9e336cfa3c..0000000000
--- a/recipes/linux/files/usb-gadget-ether-compat.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- kernel/drivers/usb/gadget/ether.c 2005-04-24 12:40:08.867411535 +0200
-+++ /tmp/ether.c 2005-04-24 12:39:02.119093498 +0200
-@@ -231,6 +231,16 @@
- MODULE_PARM(host_addr, "s");
- MODULE_PARM_DESC(host_addr, "Host Ethernet Address");
-
-+#ifdef CONFIG_USB_ETH_RNDIS
-+/* setting it to 1 disables the RNDIS extension,
-+ * needed to make g_ether compatible with usbnet from kernel < 2.6.10:
-+ * - simple vendor/product
-+ * - just the CDC interface
-+ */
-+static u8 __initdata compat_mode;
-+MODULE_PARM(compat_mode, "b");
-+MODULE_PARM_DESC(compat_mode, "non-zero value reverts to traditional usbnet compatibility (RNDIS disabled)");
-+#endif
-
- /*-------------------------------------------------------------------------*/
-
-@@ -2336,6 +2346,10 @@
- #endif
- #ifndef CONFIG_USB_ETH_RNDIS
- rndis = 0;
-+#else
-+ if (compat_mode) {
-+ rndis = 0;
-+ }
- #endif
-
- /* Because most host side USB stacks handle CDC Ethernet, that