aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdbus-binding-tool
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-05 10:13:22 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-05 10:14:19 +0100
commite2c0c14c40f9cb771ccd68feb07fb40b6c7c9346 (patch)
treec36502d43f0619f47d7459e3f9d9dcb4cf66e6d6 /recipes/gdbus-binding-tool
parent01ffe4edd15741590cc825aad2281d83ca42fc16 (diff)
downloadopenembedded-e2c0c14c40f9cb771ccd68feb07fb40b6c7c9346.tar.gz
gdbus-binding-tool: fix do_configure in native build
* do_configure_prepend without _virtclass-native override is also prepended, that's not what I intended Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/gdbus-binding-tool')
-rw-r--r--recipes/gdbus-binding-tool/gdbus-binding-tool_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes/gdbus-binding-tool/gdbus-binding-tool_git.bb b/recipes/gdbus-binding-tool/gdbus-binding-tool_git.bb
index 50b33dfbd3..14352ba60f 100644
--- a/recipes/gdbus-binding-tool/gdbus-binding-tool_git.bb
+++ b/recipes/gdbus-binding-tool/gdbus-binding-tool_git.bb
@@ -3,7 +3,7 @@ DEPENDS = "glib-2.0 gdbus-binding-tool-native"
DEPENDS_virtclass-native = "glib-2.0-native"
RDEPENDS_${PN} = "glib-2.0-utils"
-PR = "r1"
+PR = "r2"
inherit autotools pkgconfig
@@ -12,18 +12,22 @@ SRCREV = "229fd9adbb6bd9d824b38a3bd092229016540f41"
PV = "0.1+gitr${SRCPV}"
S = "${WORKDIR}/git"
-do_configure_prepend() {
+do_configure() {
# missing ${topdir}/gtk-doc.make and --disable-gtk-doc* is not enough
sed -i '/^doc\/Makefile/d' ${S}/configure.ac
sed -i 's/SUBDIRS = src doc/SUBDIRS = src/g' ${S}/Makefile.am
# cannot execute target binary, so use staged native
sed -i "s#\$(top_builddir)/src/gdbus-codegen#${STAGING_BINDIR_NATIVE}/gdbus-codegen#g" ${S}/src/Makefile.am
+
+ autotools_do_configure
}
-do_configure_prepend_virtclass-native() {
+do_configure_virtclass-native() {
# missing ${topdir}/gtk-doc.make and --disable-gtk-doc* is not enough
sed -i '/^doc\/Makefile/d' ${S}/configure.ac
sed -i 's/SUBDIRS = src doc/SUBDIRS = src/g' ${S}/Makefile.am
+
+ autotools_do_configure
}
BBCLASSEXTEND = "native"