aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freenx
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-25 22:03:40 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-25 22:07:28 +0200
commit29ceee356c56e0300184ce4dd839c4b3f71da800 (patch)
treea9ef04c8accaab76f78c03a52d104a0246bfb6d2 /recipes/freenx
parent8f7131659cb9aa260a6f4d0a51b39d6f40d117b3 (diff)
downloadopenembedded-29ceee356c56e0300184ce4dd839c4b3f71da800.tar.gz
nxcompsh: new recipe
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/freenx')
-rw-r--r--recipes/freenx/nxcompsh/iostream.patch14
-rw-r--r--recipes/freenx/nxcompsh_3.4.0-2.bb33
-rw-r--r--recipes/freenx/nxcompshad_3.4.0-3.bb17
3 files changed, 64 insertions, 0 deletions
diff --git a/recipes/freenx/nxcompsh/iostream.patch b/recipes/freenx/nxcompsh/iostream.patch
new file mode 100644
index 0000000000..2326fc5ef5
--- /dev/null
+++ b/recipes/freenx/nxcompsh/iostream.patch
@@ -0,0 +1,14 @@
+Index: nxcompsh/Misc.h
+===================================================================
+--- nxcompsh.orig/Misc.h
++++ nxcompsh/Misc.h
+@@ -18,7 +18,8 @@
+ #ifndef Misc_H
+ #define Misc_H
+
+-#include <iostream.h>
++#include <iostream>
++using namespace std;
+
+ #include <errno.h>
+ #include <string.h>
diff --git a/recipes/freenx/nxcompsh_3.4.0-2.bb b/recipes/freenx/nxcompsh_3.4.0-2.bb
new file mode 100644
index 0000000000..dd44c29cff
--- /dev/null
+++ b/recipes/freenx/nxcompsh_3.4.0-2.bb
@@ -0,0 +1,33 @@
+LICENSE = "GPL"
+
+SRC_URI = "http://64.34.161.181/download/3.4.0/sources/${PN}-${PV}.tar.gz \
+ file://iostream.patch \
+ "
+
+SRC_URI[md5sum] = "f94501249ad7d4453524f88ef0cfb1ff"
+SRC_URI[sha256sum] = "d6d29c59f070ea1ff65901a33e2013902abb3765dc6a8858f5bd6d09eccb6bf0"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools
+
+do_install () {
+ oe_runmake "bindir=${D}${bindir}" \
+ "man1dir=${D}${mandir}" \
+ install
+
+ install -p ${S}/Connector.h ${STAGING_INCDIR}
+ install -p ${S}/Dispatcher.h ${STAGING_INCDIR}
+ install -p ${S}/Display.h ${STAGING_INCDIR}
+ install -p ${S}/Event.h ${STAGING_INCDIR}
+ install -p ${S}/Listener.h ${STAGING_INCDIR}
+ install -p ${S}/Logger.h ${STAGING_INCDIR}
+ install -p ${S}/Misc.h ${STAGING_INCDIR}
+ install -p ${S}/Process.h ${STAGING_INCDIR}
+ install -p ${S}/Request.h ${STAGING_INCDIR}
+ install -p ${S}/Runnable.h ${STAGING_INCDIR}
+ install -p ${S}/Socket.h ${STAGING_INCDIR}
+ install -p ${S}/System.h ${STAGING_INCDIR}
+ install -p ${S}/Timestamp.h ${STAGING_INCDIR}
+ install -p ${S}/libXcompsh* ${STAGING_LIBDIR}
+}
diff --git a/recipes/freenx/nxcompshad_3.4.0-3.bb b/recipes/freenx/nxcompshad_3.4.0-3.bb
new file mode 100644
index 0000000000..2c337c712f
--- /dev/null
+++ b/recipes/freenx/nxcompshad_3.4.0-3.bb
@@ -0,0 +1,17 @@
+LICENSE = "GPL"
+
+SRC_URI = "http://64.34.161.181/download/3.4.0/sources/${PN}-${PV}.tar.gz \
+ "
+
+SRC_URI[md5sum] = "15deba68e12e13b524a723b49e7ec813"
+SRC_URI[sha256sum] = "8c5a67ea156afb0fb2a50adbb89b8b26b6f0860cf3f53c45eb53f59ec4deaa98"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools
+
+do_install () {
+ oe_runmake "bindir=${D}${bindir}" \
+ "man1dir=${D}${mandir}" \
+ install
+}