aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ffalarms
diff options
context:
space:
mode:
authorƁukasz Pankowski <lukpank@o2.pl>2010-10-15 21:43:14 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-16 13:24:19 +0200
commitf3a3b438a3b5ba65f51b109427bf042aa4bf39e2 (patch)
tree4f1312b2a1ab9e30d1ceeaf3571430b98a4a3b0e /recipes/ffalarms
parent68abc465559a68e9201c9525be3c4acc6297eaed (diff)
downloadopenembedded-f3a3b438a3b5ba65f51b109427bf042aa4bf39e2.tar.gz
ffalarms: bump SRCREV, remove patch applied upstream
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/ffalarms')
-rw-r--r--recipes/ffalarms/ffalarms/ical.timezone.patch40
-rw-r--r--recipes/ffalarms/ffalarms_git.bb5
2 files changed, 2 insertions, 43 deletions
diff --git a/recipes/ffalarms/ffalarms/ical.timezone.patch b/recipes/ffalarms/ffalarms/ical.timezone.patch
deleted file mode 100644
index e19ebc991a..0000000000
--- a/recipes/ffalarms/ffalarms/ical.timezone.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -uNr git.orig//ffalarms.vala git/ffalarms.vala
---- git.orig//ffalarms.vala 2010-09-26 16:15:04.000000000 +0200
-+++ git/ffalarms.vala 2010-10-13 21:31:15.000000000 +0200
-@@ -139,7 +139,7 @@
- }
-
-
--unowned TimeZone local_tz()
-+unowned ICal.TimeZone local_tz()
- {
- string s = Environment.get_variable("TZ");
- try {
-@@ -149,15 +149,15 @@
- } catch (FileError e) {
- s = "UTC";
- }
-- return TimeZone.get_builtin_timezone(s.strip());
-+ return ICal.TimeZone.get_builtin_timezone(s.strip());
- }
-
-
- // XXX may return time_t
- ICal.Time next_alarm_as_utc(Component c)
- {
-- unowned TimeZone tz = local_tz();
-- unowned TimeZone utc = TimeZone.get_utc_timezone();
-+ unowned ICal.TimeZone tz = local_tz();
-+ unowned ICal.TimeZone utc = ICal.TimeZone.get_utc_timezone();
- var t = time_t();
- var utc_now = ICal.Time.from_timet_with_zone(t, false, utc);
- ICal.Time tz_now = ICal.Time.from_timet_with_zone(t, false, tz);
-@@ -173,7 +173,7 @@
- }
- if (!next.is_utc() && next.zone == null)
- ICal.Time.set_timezone(ref next, tz);
-- TimeZone.convert_time(ref next, tz, utc);
-+ ICal.TimeZone.convert_time(ref next, tz, utc);
- next.set_timezone(ref next, utc);
- return (next.compare (utc_now) >= 0) ? next : ICal.Time.null_time();
- }
diff --git a/recipes/ffalarms/ffalarms_git.bb b/recipes/ffalarms/ffalarms_git.bb
index d904859e9e..ec7fe72a62 100644
--- a/recipes/ffalarms/ffalarms_git.bb
+++ b/recipes/ffalarms/ffalarms_git.bb
@@ -10,10 +10,9 @@ RSUGGESTS_${PN} = "mplayer alsa-utils-aplay frameworkd"
PV = "0.4+gitr${SRCPV}"
PR = "r7"
-SRC_URI = "git://git.shr-project.org/repo/ffalarms.git;protocol=http;branch=master \
- file://ical.timezone.patch"
+SRC_URI = "git://git.shr-project.org/repo/ffalarms.git;protocol=http;branch=master"
-SRCREV = "4ff7daa50ca4f7093d4c331d0274d95f3171c4c6"
+SRCREV = "7dfb98bff1da11131a1eae9018f5b9916b298104"
S = "${WORKDIR}/git"
inherit vala