aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/c3110x
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-13 20:52:11 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-13 21:54:28 +0200
commit3561c594c2d3a3acffac7364e3cb299d4c1573bf (patch)
treed2cae0747481d3cb24a04359b096b6a5f28020ad /recipes/c3110x
parent09885916eefb7445bf23cd49b087196beed3869b (diff)
downloadopenembedded-3561c594c2d3a3acffac7364e3cb299d4c1573bf.tar.gz
cx3110x_1.1: add checksums, drop ^Ms
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/c3110x')
-rw-r--r--recipes/c3110x/cx3110x_1.1.bb63
1 files changed, 33 insertions, 30 deletions
diff --git a/recipes/c3110x/cx3110x_1.1.bb b/recipes/c3110x/cx3110x_1.1.bb
index 15cf51427d..797c7caee6 100644
--- a/recipes/c3110x/cx3110x_1.1.bb
+++ b/recipes/c3110x/cx3110x_1.1.bb
@@ -1,30 +1,33 @@
-DESCRIPTION = "cx3110x wifi support as found in the Nokia 770/800"
-SECTION = "kernel/modules"
-LICENSE = "GPL"
-PR = "r4"
-
-COMPATIBLE_MACHINE = "(nokia770|nokia800)"
-
-export KERNEL_SRC_DIR = ${STAGING_KERNEL_DIR}
-export LDFLAGS = ""
-
-SRC_URI = "https://garage.maemo.org/frs/download.php/939/cx3110x-1.1.tar.gz \
- file://umac_binary.patch;patch=1 \
- http://use.the.umac.ko.from.your.own.nokia800/umac.ko"
-
-S = "${WORKDIR}/cx3110x-${PV}"
-
-inherit module
-
-do_compile() {
- cp ${WORKDIR}/umac.ko ${S}/src/binary_umac.o
- ${OBJCOPY} ${S}/src/binary_umac.o -R __ksymtab
- ${OBJCOPY} ${S}/src/binary_umac.o -R __ksymtab_strings
- ${OBJCOPY} ${S}/src/binary_umac.o -R .gnu.linkonce.this_module
- ${OBJCOPY} ${S}/src/binary_umac.o -R .modinfo
- ${OBJCOPY} ${S}/src/binary_umac.o -R .init.text
- ${OBJCOPY} ${S}/src/binary_umac.o -R .exit.text
-
- oe_runmake modules
-}
-
+DESCRIPTION = "cx3110x wifi support as found in the Nokia 770/800"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PR = "r4"
+
+COMPATIBLE_MACHINE = "(nokia770|nokia800)"
+
+export KERNEL_SRC_DIR = ${STAGING_KERNEL_DIR}
+export LDFLAGS = ""
+
+SRC_URI = "https://garage.maemo.org/frs/download.php/939/cx3110x-1.1.tar.gz \
+ file://umac_binary.patch;patch=1 \
+ http://use.the.umac.ko.from.your.own.nokia800/umac.ko"
+
+S = "${WORKDIR}/cx3110x-${PV}"
+
+inherit module
+
+do_compile() {
+ cp ${WORKDIR}/umac.ko ${S}/src/binary_umac.o
+ ${OBJCOPY} ${S}/src/binary_umac.o -R __ksymtab
+ ${OBJCOPY} ${S}/src/binary_umac.o -R __ksymtab_strings
+ ${OBJCOPY} ${S}/src/binary_umac.o -R .gnu.linkonce.this_module
+ ${OBJCOPY} ${S}/src/binary_umac.o -R .modinfo
+ ${OBJCOPY} ${S}/src/binary_umac.o -R .init.text
+ ${OBJCOPY} ${S}/src/binary_umac.o -R .exit.text
+
+ oe_runmake modules
+}
+
+
+SRC_URI[md5sum] = "18e5dc522aa9424cf9b32b86da19b85e"
+SRC_URI[sha256sum] = "b0e00a7c164711512549d3ad82707c53a20fd978c2448ec22d2ea76df1954eee"