aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bzip2/bzip2_1.0.5.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2010-01-10 16:41:29 +0000
committerutx@penguin.cz <utx@penguin.cz>2010-01-10 16:41:29 +0000
commitfd9e3c2b0720bc838fba383f5f1a9bd75c421afa (patch)
tree8cd2daf5f140e9a2162224dc2443d3b2038a924c /recipes/bzip2/bzip2_1.0.5.bb
parentd6279520f7bf850922d86e58d9111af066d941bf (diff)
downloadopenembedded-fd9e3c2b0720bc838fba383f5f1a9bd75c421afa.tar.gz
bzip2: Security update to version 1.0.5 (CVE-2008-1372, CERT-FI 20469) and a migration to autoconf.
* More about security issue: * https://www.cert.fi/haavoittuvuudet/joint-advisory-archive-formats.html * http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2008-1372 * More about autoconf: See README.autotools in the patched source.
Diffstat (limited to 'recipes/bzip2/bzip2_1.0.5.bb')
-rw-r--r--recipes/bzip2/bzip2_1.0.5.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/bzip2/bzip2_1.0.5.bb b/recipes/bzip2/bzip2_1.0.5.bb
new file mode 100644
index 0000000000..45c97163d4
--- /dev/null
+++ b/recipes/bzip2/bzip2_1.0.5.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Very high-quality data compression program"
+SECTION = "console/utils"
+PR = "r0"
+
+LICENSE = "bzip2"
+SRC_URI = "http://www.bzip.org/${PV}/bzip2-${PV}.tar.gz \
+ file://bzip2-1.0.5-autoconfiscated.patch;patch=1"
+
+inherit autotools_stage pkgconfig
+
+do_configure_prepend () {
+ if test -f LICENSE ; then sh ./autogen.sh ; fi
+}
+
+do_install_append () {
+ mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
+ mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
+ update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove bunzip2 bunzip2.${PN}
+ update-alternatives --remove bzcat bzcat.${PN}
+}